]> git.pld-linux.org Git - packages/SDL2_sound.git/blob - SDL2_sound.spec
- added use-builtin-clz patch (rely on gcc to choose proper instruction for target...
[packages/SDL2_sound.git] / SDL2_sound.spec
1 # TODO: system libmodplug, timidity?
2 Summary:        An abstract soundfile decoder
3 Summary(pl.UTF-8):      Abstrakcyjny dekoder plików dźwiękowych
4 Name:           SDL2_sound
5 Version:        2.0.1
6 Release:        1
7 License:        Zlib
8 Group:          Libraries
9 #Source0Download: https://github.com/icculus/SDL_sound/releases
10 Source0:        https://github.com/icculus/SDL_sound/archive/v%{version}/SDL_sound-%{version}.tar.gz
11 # Source0-md5:  4917a87b45f7b940a68cd1b60881cabb
12 Patch0:         SDL_sound-use-builtin-clz.patch
13 URL:            http://www.icculus.org/SDL_sound/
14 BuildRequires:  SDL2-devel >= 2.0
15 BuildRequires:  cmake >= 2.8.12
16 Requires:       SDL2 >= 2.0
17 Obsoletes:      SDL_sound-play < 2
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 SDL_sound is a library that handles the decoding of several popular
22 sound file formats, such as .WAV and .MP3. It is meant to make the
23 programmer's sound playback tasks simpler. The programmer gives
24 SDL_sound a filename, or feeds it data directly from one of many
25 sources, and then reads the decoded waveform data back at her leisure.
26 If resource constraints are a concern, SDL_sound can process sound
27 data in programmer-specified blocks. Alternately, SDL_sound can decode
28 a whole sound file and hand back a single pointer to the whole
29 waveform. SDL_sound can also handle sample rate, audio format, and
30 channel conversion on-the-fly and behind-the-scenes, if the programmer
31 desires.
32
33 %description -l pl.UTF-8
34 SDL_sound to biblioteka obsługująca dekodowanie kilku popularnych
35 formatów plików dźwiękowych, takich jak .WAV lub .MP3. Jej celem
36 jest uproszczenie pracy programisty przy odtwarzaniu dźwięku.
37 Programista przekazuje SDL_sound nazwę pliku lub dostarcza dane
38 bezpośrednio z jednego z wielu źródeł, a następnie odczytuje strumień
39 zdekodowanych danych. Jeśli ograniczenia zasobów są istotne, SDL_sound
40 może obsługiwać dane dźwiękowe w podanych blokach. Alternatywnie,
41 SDL_sound może dekodować cały plik dźwiękowy i przekazywać z powrotem
42 pojedynczy wskaźnik do całości zdekodowanych danych. SDL_sound może
43 także obsługiwać w locie konwersję częstotliwości próbkowania, formatu
44 dźwięku i liczby kanałów.
45
46 %package play
47 Summary:        SDL_sound/physfs based music player
48 Summary(pl.UTF-8):      Odtwarzacz muzyki oparty na SDL_sound/physfs
49 Group:          Applications/Sound
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       physfs >= 3
52
53 %description play
54 SDL_sound/physfs based music player.
55
56 %description play -l pl.UTF-8
57 Odtwarzacz muzyki oparty na SDL_sound/physfs.
58
59 %package devel
60 Summary:        Header files and more to develop SDL_sound applications
61 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia aplikacji z użyciem SDL_sound
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       SDL2-devel >= 2.0
65
66 %description devel
67 Header files and more to develop SDL_sound applications.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe do tworzenia aplikacji z użyciem SDL_sound.
71
72 %package static
73 Summary:        Static SDL_sound libraries
74 Summary(pl.UTF-8):      Statyczne biblioteki SDL_sound
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static SDL_sound libraries.
80
81 %description static -l pl.UTF-8
82 Statyczne biblioteki SDL_sound.
83
84 %prep
85 %setup -q -n SDL_sound-%{version}
86 %patch0 -p1
87
88 %build
89 install -d build 
90 cd build
91 %cmake .. \
92         -DSDLSOUND_DECODER_MIDI=ON
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} -C build install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc LICENSE.txt docs/{CHANGELOG,CREDITS,README}.txt
111 %attr(755,root,root) %{_bindir}/playsound
112 %attr(755,root,root) %{_libdir}/libSDL2_sound.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libSDL2_sound.so.2
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libSDL2_sound.so
118 %{_includedir}/SDL2/SDL_sound.h
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libSDL2_sound.a
This page took 0.08156 seconds and 3 git commands to generate.