]> git.pld-linux.org Git - packages/SDL2_sound.git/blob - SDL2_sound.spec
- new, SDL2 version of SDL_sound
[packages/SDL2_sound.git] / SDL2_sound.spec
1 # TODO: system libmodplug, timidity?
2 Summary:        An abstract soundfile decoder
3 Summary(pl.UTF-8):      Abstrakcyjny dekoder plików dźwiękowych
4 Name:           SDL2_sound
5 Version:        2.0.1
6 Release:        1
7 License:        Zlib
8 Group:          Libraries
9 #Source0Download: https://github.com/icculus/SDL_sound/releases
10 Source0:        https://github.com/icculus/SDL_sound/archive/v%{version}/SDL_sound-%{version}.tar.gz
11 # Source0-md5:  4917a87b45f7b940a68cd1b60881cabb
12 URL:            http://www.icculus.org/SDL_sound/
13 BuildRequires:  SDL2-devel >= 2.0
14 BuildRequires:  cmake >= 2.8.12
15 Requires:       SDL2 >= 2.0
16 Obsoletes:      SDL_sound-play < 2
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 SDL_sound is a library that handles the decoding of several popular
21 sound file formats, such as .WAV and .MP3. It is meant to make the
22 programmer's sound playback tasks simpler. The programmer gives
23 SDL_sound a filename, or feeds it data directly from one of many
24 sources, and then reads the decoded waveform data back at her leisure.
25 If resource constraints are a concern, SDL_sound can process sound
26 data in programmer-specified blocks. Alternately, SDL_sound can decode
27 a whole sound file and hand back a single pointer to the whole
28 waveform. SDL_sound can also handle sample rate, audio format, and
29 channel conversion on-the-fly and behind-the-scenes, if the programmer
30 desires.
31
32 %description -l pl.UTF-8
33 SDL_sound to biblioteka obsługująca dekodowanie kilku popularnych
34 formatów plików dźwiękowych, takich jak .WAV lub .MP3. Jej celem
35 jest uproszczenie pracy programisty przy odtwarzaniu dźwięku.
36 Programista przekazuje SDL_sound nazwę pliku lub dostarcza dane
37 bezpośrednio z jednego z wielu źródeł, a następnie odczytuje strumień
38 zdekodowanych danych. Jeśli ograniczenia zasobów są istotne, SDL_sound
39 może obsługiwać dane dźwiękowe w podanych blokach. Alternatywnie,
40 SDL_sound może dekodować cały plik dźwiękowy i przekazywać z powrotem
41 pojedynczy wskaźnik do całości zdekodowanych danych. SDL_sound może
42 także obsługiwać w locie konwersję częstotliwości próbkowania, formatu
43 dźwięku i liczby kanałów.
44
45 %package play
46 Summary:        SDL_sound/physfs based music player
47 Summary(pl.UTF-8):      Odtwarzacz muzyki oparty na SDL_sound/physfs
48 Group:          Applications/Sound
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       physfs >= 3
51
52 %description play
53 SDL_sound/physfs based music player.
54
55 %description play -l pl.UTF-8
56 Odtwarzacz muzyki oparty na SDL_sound/physfs.
57
58 %package devel
59 Summary:        Header files and more to develop SDL_sound applications
60 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia aplikacji z użyciem SDL_sound
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       SDL2-devel >= 2.0
64
65 %description devel
66 Header files and more to develop SDL_sound applications.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe do tworzenia aplikacji z użyciem SDL_sound.
70
71 %package static
72 Summary:        Static SDL_sound libraries
73 Summary(pl.UTF-8):      Statyczne biblioteki SDL_sound
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static SDL_sound libraries.
79
80 %description static -l pl.UTF-8
81 Statyczne biblioteki SDL_sound.
82
83 %prep
84 %setup -q -n SDL_sound-%{version}
85
86 %build
87 install -d build 
88 cd build
89 %cmake .. \
90         -DSDLSOUND_DECODER_MIDI=ON
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} -C build install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %doc LICENSE.txt docs/{CHANGELOG,CREDITS,README}.txt
109 %attr(755,root,root) %{_bindir}/playsound
110 %attr(755,root,root) %{_libdir}/libSDL2_sound.so.*.*.*
111 %attr(755,root,root) %ghost %{_libdir}/libSDL2_sound.so.2
112
113 %files devel
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_libdir}/libSDL2_sound.so
116 %{_includedir}/SDL2/SDL_sound.h
117
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/libSDL2_sound.a
This page took 0.081089 seconds and 3 git commands to generate.