]> git.pld-linux.org Git - packages/SDL2.git/blob - SDL2.spec
- fcitx support; release 2
[packages/SDL2.git] / SDL2.spec
1 #
2 # Conditional build:
3 %bcond_with     directfb        # DirectFB graphics support
4 %bcond_with     nas             # NAS audio support
5 %bcond_without  alsa            # ALSA audio support
6 %bcond_with     arts            # aRts audio support
7 %bcond_with     esd             # EsounD audio support
8 %bcond_with     jack            # JACK audio support
9 %bcond_without  opengl          # OpenGL (GLX) support
10 %bcond_without  gles            # OpenGL ES (EGL) support
11 %bcond_with     kms             # KMS/DRM graphics support
12 %bcond_without  vulkan          # Vulkan graphics support
13 %bcond_without  wayland         # Wayland graphics support
14 %bcond_without  fcitx           # Fcitx IM support
15 %bcond_without  static_libs     # don't build static libraries
16 %bcond_with     mmx             # MMX instructions
17 %bcond_with     sse             # SSE instructions
18 %bcond_with     sse2            # SSE2 instructions
19 %bcond_with     3dnow           # 3Dnow! instructions
20 %bcond_with     altivec         # Altivec instructions
21 #
22 # NOTE: the following libraries are dlopened by soname detected at build time:
23 # libartsc.so.?                 [if with arts]
24 # libasound.so.2                [if with alsa]
25 # libaudio.so.2                 [if with nas]
26 # libdirectfb-*.so --needs patch (-release not supported by configure)
27 # libdrm.so.2                   [if with kms]
28 # libesd.so.0                   [if with esd]
29 # libfusionsound-*.so --needs patch (-release not supported by configure)
30 # libgbm.so.1                   [if with kms]
31 # libjack.so.0                  [if with jack]
32 # libpulse-simple.so.0
33 # libsamplerate.so.0
34 # libwayland-client.so.0        [if with wayland]
35 # libwayland-cursor.so.0        [if with wayland]
36 # libwayland-egl.so.1           [if with wayland]
37 # libxkbcommon.so.0             [if with wayland]
38 # libX11.so.6
39 # libXcursor.so.1
40 # libXext.so.6
41 # libXi.so.6
42 # libXinerama.so.1
43 # libXrandr.so.2
44 # libXrender.so.1
45 # libXss.so.1
46 # libXxf86vm.so.1
47 %ifarch k6 athlon
48 %define with_3dnow      1
49 %endif
50 %ifarch %{x8664} pentium2 pentium3 pentium4 athlon
51 %define with_mmx        1
52 %endif
53 %ifarch %{x8664} pentium3 pentium4
54 %define with_sse        1
55 %endif
56 %ifarch %{x8664} pentium4
57 %define with_sse2       1
58 %endif
59 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
60 Summary(pl.UTF-8):      SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
61 Summary(zh_CN.UTF-8):   SDL (Simple DirectMedia Layer) Generic APIs - 游戏/多媒体库
62 Name:           SDL2
63 Version:        2.0.12
64 Release:        2
65 License:        Zlib (BSD-like)
66 Group:          Libraries
67 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
68 # Source0-md5:  783b6f2df8ff02b19bb5ce492b99c8ff
69 Patch0:         %{name}-config.patch
70 Patch1:         %{name}-cflags.patch
71 URL:            http://www.libsdl.org/
72 %{?with_kms:BuildRequires:      Mesa-libgbm-devel >= 9.0.0}
73 %{?with_directfb:BuildRequires: DirectFB-devel >= 1.0.0}
74 %{?with_directfb:BuildRequires: FusionSound-devel >= 1.1.1}
75 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
76 %{?with_gles:BuildRequires:     OpenGLES-devel}
77 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 1.0.11}
78 %{?with_arts:BuildRequires:     artsc-devel >= 1.1}
79 BuildRequires:  autoconf >= 2.59-9
80 BuildRequires:  automake
81 BuildRequires:  dbus-devel
82 %{?with_esd:BuildRequires:      esound-devel >= 0.2.8}
83 %{?with_fcitx:BuildRequires:    fcitx-devel}
84 BuildRequires:  gcc >= 5:4.0
85 BuildRequires:  ibus-devel >= 1.0
86 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel >= 0.125}
87 %{?with_kms:BuildRequires:      libdrm-devel >= 2.4.46}
88 BuildRequires:  libsamplerate-devel
89 BuildRequires:  libtool >= 2:2.0
90 %{?with_nas:BuildRequires:      nas-devel}
91 BuildRequires:  perl-modules
92 BuildRequires:  pkgconfig >= 1:0.7
93 BuildRequires:  pulseaudio-devel >= 0.9
94 BuildRequires:  tslib-devel
95 BuildRequires:  udev-devel
96 # wayland-client, wayland-cursor
97 %{?with_wayland:BuildRequires:  wayland-devel}
98 %{?with_wayland:BuildRequires:  wayland-egl-devel}
99 BuildRequires:  xorg-lib-libX11-devel
100 BuildRequires:  xorg-lib-libXScrnSaver-devel
101 BuildRequires:  xorg-lib-libXcursor-devel
102 BuildRequires:  xorg-lib-libXext-devel
103 BuildRequires:  xorg-lib-libXi-devel
104 BuildRequires:  xorg-lib-libXinerama-devel
105 BuildRequires:  xorg-lib-libXrandr-devel
106 BuildRequires:  xorg-lib-libXrender-devel
107 BuildRequires:  xorg-lib-libXxf86vm-devel
108 %if %{with wayland}
109 BuildRequires:  xorg-lib-libxkbcommon-devel
110 %endif
111 BuildRequires:  xorg-proto-xextproto-devel
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         specflags_ppc   -maltivec
115
116 %description
117 SDL (Simple DirectMedia Layer) is a library that allows you portable,
118 low level access to a video framebuffer, audio output, mouse, and
119 keyboard. It can support both windowed and DGA modes of XFree86, and
120 it is designed to be portable - applications linked with SDL can also
121 be built on Win32 and BeOS.
122
123 %description -l pl.UTF-8
124 SDL (Simple DirectMedia Layer) jest biblioteką udostępniającą
125 przenośny, niskopoziomowy dostęp do bufora ramki video, wyjścia audio,
126 myszy oraz klawiatury. Może obsługiwać zarówno okienkowy tryb XFree86
127 jak i DGA. Konstruując ją miano na uwadze przenośność: aplikacje
128 konsolidowane z SDL można również budować w systemach Win32 i BeOS.
129
130 %description -l pt_BR.UTF-8
131 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
132 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
133
134 Essa biblioteca é usada por alguns jogos.
135
136 %description -l ru.UTF-8
137 SDL (Simple DirectMedia Layer) это набор функций, предоставляющий
138 низкоуровневый доступ к звуку, клавиатуре, манипулятору мышь и к
139 буферу экрана на множестве различных платформ.
140
141 %package devel
142 Summary:        SDL - Header files
143 Summary(pl.UTF-8):      SDL - Pliki nagłówkowe
144 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de cabeçalho para aplicações SDL
145 Summary(ru.UTF-8):      Файлы, необходимые для разработки программ, использующих SDL
146 Summary(uk.UTF-8):      Файли, необхідні для розробки програм, що використовують SDL
147 Summary(zh_CN.UTF-8):   SDL (Simple DirectMedia Layer) 开发库
148 Group:          Development/Libraries
149 Requires:       %{name} = %{version}-%{release}
150 %{?with_directfb:Requires:      DirectFB-devel >= 1.0.0}
151 Requires:       tslib-devel
152 Requires:       xorg-lib-libX11-devel
153 Suggests:       OpenGL-GLU-devel
154
155 %description devel
156 SDL - Header files.
157
158 %description devel -l pl.UTF-8
159 SDL - Pliki nagłówkowe.
160
161 %description devel -l pt_BR.UTF-8
162 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
163 recursos para o desenvolvimento de aplicativos com SDL.
164
165 %description devel -l ru.UTF-8
166 Этот пакет содержит файлы, необходимые для разработки программ,
167 использующих SDL.
168
169 %description devel -l uk.UTF-8
170 Цей пакет містить файли, необхідні для розробки програм, що
171 використовують SDL.
172
173 %package static
174 Summary:        SDL - static libraries
175 Summary(pl.UTF-8):      SDL - biblioteki statyczne
176 Summary(pt_BR.UTF-8):   Biblioteca estática para desenvolvimento de aplicações com a SDL
177 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием SDL
178 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням SDL
179 Group:          Development/Libraries
180 Requires:       %{name}-devel = %{version}-%{release}
181
182 %description static
183 SDL - static libraries.
184
185 %description static -l pl.UTF-8
186 SDL - biblioteki statyczne.
187
188 %description static -l pt_BR.UTF-8
189 Biblioteca estática para desenvolvimento de aplicações com a SDL.
190
191 %description static -l ru.UTF-8
192 Этот пакет содержит статические библиотеки для разработки программ,
193 использующих SDL.
194
195 %description static -l uk.UTF-8
196 Цей пакет містить статичні бібліотеки для розробки програм, що
197 використовують SDL.
198
199 %package examples
200 Summary:        SDL - example programs
201 Summary(pl.UTF-8):      SDL - programy przykładowe
202 License:        Public Domain
203 Group:          Development/Libraries
204 Requires:       %{name}-devel = %{version}-%{release}
205
206 %description examples
207 SDL - example programs.
208
209 %description examples -l pl.UTF-8
210 SDL - przykładowe programy.
211
212 %prep
213 %setup -q
214 %patch0 -p1
215 %patch1 -p1
216
217 %build
218 %{__libtoolize}
219 %{__aclocal} -I acinclude
220 %{__autoconf}
221 %configure \
222         %{!?with_3dnow:--disable-3dnow} \
223         %{!?with_alsa:--disable-alsa} \
224         %{!?with_altiveca:--disable-altivec} \
225         %{!?with_arts:--disable-arts} \
226         %{!?with_esd:--disable-esd} \
227         %{!?with_fcitx:--disable-fcitx} \
228         %{!?with_jack:--disable-jack} \
229         %{!?with_mmx:--disable-mmx} \
230         %{!?with_nas:--disable-nas} \
231         --enable-pthreads \
232         --enable-pthread-sem \
233         --disable-rpath \
234         %{!?with_sse:--disable-sse --disable-ssemath} \
235         %{!?with_sse2:--disable-sse2} \
236         %{?with_sse:--enable-ssemath} \
237         %{!?with_static_libs:--disable-static} \
238         %{!?with_directfb:--disable-video-directfb} \
239         %{?with_kms:--enable-video-kmsdrm} \
240         --enable-video-opengl%{!?with_opengl:=no} \
241         --enable-video-opengles%{!?with_gles:=no} \
242         --enable-video-vulkan%{!?with_vulkan:=no} \
243         --enable-video-wayland%{!?with_wayland:=no} \
244         --with-x
245
246 %{__make} \
247         V=1
248
249 %install
250 rm -rf $RPM_BUILD_ROOT
251 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
252
253 %{__make} install \
254         DESTDIR=$RPM_BUILD_ROOT \
255         m4datadir=%{_aclocaldir}
256
257 cp -pr test/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
258
259 %clean
260 rm -rf $RPM_BUILD_ROOT
261
262 %post   -p /sbin/ldconfig
263 %postun -p /sbin/ldconfig
264
265 %files
266 %defattr(644,root,root,755)
267 # non-Linux READMEs packaged for portability information
268 %doc BUGS.txt COPYING.txt CREDITS.txt README*.txt TODO.txt WhatsNew.txt
269 %attr(755,root,root) %{_libdir}/libSDL2-2.0.so.*.*.*
270 %attr(755,root,root) %ghost %{_libdir}/libSDL2-2.0.so.0
271
272 %files devel
273 %defattr(644,root,root,755)
274 %attr(755,root,root) %{_bindir}/sdl2-config
275 %attr(755,root,root) %{_libdir}/libSDL2.so
276 %{_libdir}/libSDL2.la
277 %{_libdir}/libSDL2_test.a
278 %{_libdir}/libSDL2_test.la
279 %{_libdir}/libSDL2main.a
280 %{_libdir}/libSDL2main.la
281 %{_includedir}/SDL2
282 %{_aclocaldir}/sdl2.m4
283 %{_pkgconfigdir}/sdl2.pc
284 %{_libdir}/cmake/SDL2
285
286 %if %{with static_libs}
287 %files static
288 %defattr(644,root,root,755)
289 %{_libdir}/libSDL2.a
290 %endif
291
292 %files examples
293 %defattr(644,root,root,755)
294 %{_examplesdir}/%{name}-%{version}
This page took 0.0626 seconds and 4 git commands to generate.