]> git.pld-linux.org Git - packages/SDL2.git/blob - SDL2.spec
up to 2.0.18
[packages/SDL2.git] / SDL2.spec
1 #
2 # Conditional build:
3 %bcond_with     directfb        # DirectFB graphics support
4 %bcond_with     nas             # NAS audio support
5 %bcond_without  alsa            # ALSA audio support
6 %bcond_with     arts            # aRts audio support
7 %bcond_with     esd             # EsounD audio support
8 %bcond_with     jack            # JACK audio support
9 %bcond_without  opengl          # OpenGL (GLX) support
10 %bcond_without  gles            # OpenGL ES (EGL) support
11 %bcond_with     kms             # KMS/DRM graphics support
12 %bcond_without  vulkan          # Vulkan graphics support
13 %bcond_without  wayland         # Wayland graphics support
14 %bcond_without  fcitx           # Fcitx IM support
15 %bcond_without  static_libs     # don't build static libraries
16 %bcond_with     mmx             # MMX instructions
17 %bcond_with     sse             # SSE instructions
18 %bcond_with     sse2            # SSE2 instructions
19 %bcond_with     3dnow           # 3Dnow! instructions
20 %bcond_with     altivec         # Altivec instructions
21 #
22 # NOTE: the following libraries are dlopened by soname detected at build time:
23 # libartsc.so.?                 [if with arts]
24 # libasound.so.2                [if with alsa]
25 # libaudio.so.2                 [if with nas]
26 # libdirectfb-*.so --needs patch (-release not supported by configure)
27 # libdrm.so.2                   [if with kms]
28 # libesd.so.0                   [if with esd]
29 # libfusionsound-*.so --needs patch (-release not supported by configure)
30 # libgbm.so.1                   [if with kms]
31 # libjack.so.0                  [if with jack]
32 # libpulse-simple.so.0
33 # libsamplerate.so.0
34 # libwayland-client.so.0        [if with wayland]
35 # libwayland-cursor.so.0        [if with wayland]
36 # libwayland-egl.so.1           [if with wayland]
37 # libxkbcommon.so.0             [if with wayland]
38 # libX11.so.6
39 # libXcursor.so.1
40 # libXext.so.6
41 # libXi.so.6
42 # libXinerama.so.1
43 # libXrandr.so.2
44 # libXrender.so.1
45 # libXss.so.1
46 # libXxf86vm.so.1
47 %ifarch k6 athlon
48 %define with_3dnow      1
49 %endif
50 %ifarch %{x8664} x32 pentium2 pentium3 pentium4 athlon
51 %define with_mmx        1
52 %endif
53 %ifarch %{x8664} x32 pentium3 pentium4
54 %define with_sse        1
55 %endif
56 %ifarch %{x8664} x32 pentium4
57 %define with_sse2       1
58 %endif
59 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
60 Summary(pl.UTF-8):      SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
61 Summary(zh_CN.UTF-8):   SDL (Simple DirectMedia Layer) Generic APIs - 游戏/多媒体库
62 Name:           SDL2
63 Version:        2.0.18
64 Release:        1
65 License:        Zlib (BSD-like)
66 Group:          Libraries
67 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
68 # Source0-md5:  c1dd33299db5b7091f37d989c68d5212
69 Patch0:         %{name}-config.patch
70 URL:            http://www.libsdl.org/
71 %{?with_kms:BuildRequires:      Mesa-libgbm-devel >= 11.1.0}
72 %{?with_directfb:BuildRequires: DirectFB-devel >= 1.0.0}
73 %if %{with opengl} || %{with gles}
74 BuildRequires:  EGL-devel
75 %endif
76 %{?with_directfb:BuildRequires: FusionSound-devel >= 1.1.1}
77 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
78 %{?with_gles:BuildRequires:     OpenGLES-devel}
79 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 1.0.11}
80 %{?with_arts:BuildRequires:     artsc-devel >= 1.1}
81 BuildRequires:  autoconf >= 2.59-9
82 BuildRequires:  automake
83 BuildRequires:  dbus-devel
84 %{?with_esd:BuildRequires:      esound-devel >= 0.2.8}
85 %{?with_fcitx:BuildRequires:    fcitx-devel}
86 BuildRequires:  gcc >= 5:4.0
87 BuildRequires:  hidapi-devel
88 BuildRequires:  ibus-devel >= 1.0
89 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel >= 0.125}
90 %{?with_kms:BuildRequires:      libdrm-devel >= 1.4.82}
91 BuildRequires:  libsamplerate-devel
92 BuildRequires:  libtool >= 2:2.0
93 %{?with_nas:BuildRequires:      nas-devel}
94 BuildRequires:  perl-modules
95 BuildRequires:  pipewire-devel >= 0.3.20
96 BuildRequires:  pkgconfig >= 1:0.7
97 BuildRequires:  pulseaudio-devel >= 0.9
98 BuildRequires:  udev-devel
99 # wayland-client, wayland-cursor
100 %{?with_wayland:BuildRequires:  wayland-devel >= 1.15}
101 %{?with_wayland:BuildRequires:  wayland-egl-devel}
102 BuildRequires:  xorg-lib-libX11-devel
103 BuildRequires:  xorg-lib-libXScrnSaver-devel
104 BuildRequires:  xorg-lib-libXcursor-devel
105 BuildRequires:  xorg-lib-libXext-devel
106 BuildRequires:  xorg-lib-libXi-devel
107 BuildRequires:  xorg-lib-libXinerama-devel
108 BuildRequires:  xorg-lib-libXrandr-devel
109 BuildRequires:  xorg-lib-libXrender-devel
110 BuildRequires:  xorg-lib-libXxf86vm-devel
111 %if %{with wayland}
112 BuildRequires:  xorg-lib-libxkbcommon-devel >= 0.5.0
113 %endif
114 BuildRequires:  xorg-proto-xextproto-devel
115 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
116
117 %define         specflags_ppc   -maltivec
118
119 %description
120 SDL (Simple DirectMedia Layer) is a library that allows you portable,
121 low level access to a video framebuffer, audio output, mouse, and
122 keyboard. It can support both windowed and DGA modes of XFree86, and
123 it is designed to be portable - applications linked with SDL can also
124 be built on Win32 and BeOS.
125
126 %description -l pl.UTF-8
127 SDL (Simple DirectMedia Layer) jest biblioteką udostępniającą
128 przenośny, niskopoziomowy dostęp do bufora ramki video, wyjścia audio,
129 myszy oraz klawiatury. Może obsługiwać zarówno okienkowy tryb XFree86
130 jak i DGA. Konstruując ją miano na uwadze przenośność: aplikacje
131 konsolidowane z SDL można również budować w systemach Win32 i BeOS.
132
133 %description -l pt_BR.UTF-8
134 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
135 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
136
137 Essa biblioteca é usada por alguns jogos.
138
139 %description -l ru.UTF-8
140 SDL (Simple DirectMedia Layer) это набор функций, предоставляющий
141 низкоуровневый доступ к звуку, клавиатуре, манипулятору мышь и к
142 буферу экрана на множестве различных платформ.
143
144 %package devel
145 Summary:        SDL - Header files
146 Summary(pl.UTF-8):      SDL - Pliki nagłówkowe
147 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de cabeçalho para aplicações SDL
148 Summary(ru.UTF-8):      Файлы, необходимые для разработки программ, использующих SDL
149 Summary(uk.UTF-8):      Файли, необхідні для розробки програм, що використовують SDL
150 Summary(zh_CN.UTF-8):   SDL (Simple DirectMedia Layer) 开发库
151 Group:          Development/Libraries
152 Requires:       %{name} = %{version}-%{release}
153 %{?with_directfb:Requires:      DirectFB-devel >= 1.0.0}
154 Requires:       xorg-lib-libX11-devel
155 Suggests:       OpenGL-GLU-devel
156
157 %description devel
158 SDL - Header files.
159
160 %description devel -l pl.UTF-8
161 SDL - Pliki nagłówkowe.
162
163 %description devel -l pt_BR.UTF-8
164 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
165 recursos para o desenvolvimento de aplicativos com SDL.
166
167 %description devel -l ru.UTF-8
168 Этот пакет содержит файлы, необходимые для разработки программ,
169 использующих SDL.
170
171 %description devel -l uk.UTF-8
172 Цей пакет містить файли, необхідні для розробки програм, що
173 використовують SDL.
174
175 %package static
176 Summary:        SDL - static libraries
177 Summary(pl.UTF-8):      SDL - biblioteki statyczne
178 Summary(pt_BR.UTF-8):   Biblioteca estática para desenvolvimento de aplicações com a SDL
179 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием SDL
180 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням SDL
181 Group:          Development/Libraries
182 Requires:       %{name}-devel = %{version}-%{release}
183
184 %description static
185 SDL - static libraries.
186
187 %description static -l pl.UTF-8
188 SDL - biblioteki statyczne.
189
190 %description static -l pt_BR.UTF-8
191 Biblioteca estática para desenvolvimento de aplicações com a SDL.
192
193 %description static -l ru.UTF-8
194 Этот пакет содержит статические библиотеки для разработки программ,
195 использующих SDL.
196
197 %description static -l uk.UTF-8
198 Цей пакет містить статичні бібліотеки для розробки програм, що
199 використовують SDL.
200
201 %package examples
202 Summary:        SDL - example programs
203 Summary(pl.UTF-8):      SDL - programy przykładowe
204 License:        Public Domain
205 Group:          Development/Libraries
206 Requires:       %{name}-devel = %{version}-%{release}
207
208 %description examples
209 SDL - example programs.
210
211 %description examples -l pl.UTF-8
212 SDL - przykładowe programy.
213
214 %prep
215 %setup -q
216 %patch0 -p1
217
218 %build
219 %{__libtoolize}
220 %{__aclocal} -I acinclude
221 %{__autoconf}
222 %configure \
223         %{!?with_3dnow:--disable-3dnow} \
224         %{!?with_alsa:--disable-alsa} \
225         %{!?with_altiveca:--disable-altivec} \
226         %{!?with_arts:--disable-arts} \
227         %{!?with_esd:--disable-esd} \
228         %{!?with_fcitx:--disable-fcitx} \
229         %{!?with_jack:--disable-jack} \
230         %{!?with_mmx:--disable-mmx} \
231         %{!?with_nas:--disable-nas} \
232         --enable-pthreads \
233         --enable-pthread-sem \
234         --disable-rpath \
235         %{!?with_sse:--disable-sse --disable-ssemath} \
236         %{!?with_sse2:--disable-sse2} \
237         %{?with_sse:--enable-ssemath} \
238         %{!?with_static_libs:--disable-static} \
239         %{!?with_directfb:--disable-video-directfb} \
240         %{?with_kms:--enable-video-kmsdrm} \
241         --enable-video-opengl%{!?with_opengl:=no} \
242         --enable-video-opengles%{!?with_gles:=no} \
243         --enable-video-vulkan%{!?with_vulkan:=no} \
244         --enable-video-wayland%{!?with_wayland:=no} \
245         --with-x
246
247 %{__make} \
248         V=1
249
250 %install
251 rm -rf $RPM_BUILD_ROOT
252 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
253
254 %{__make} install \
255         DESTDIR=$RPM_BUILD_ROOT \
256         m4datadir=%{_aclocaldir}
257
258 cp -pr test/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
259
260 %clean
261 rm -rf $RPM_BUILD_ROOT
262
263 %post   -p /sbin/ldconfig
264 %postun -p /sbin/ldconfig
265
266 %files
267 %defattr(644,root,root,755)
268 # non-Linux READMEs packaged for portability information
269 %doc BUGS.txt CREDITS.txt LICENSE.txt README*.txt TODO.txt WhatsNew.txt
270 %attr(755,root,root) %{_libdir}/libSDL2-2.0.so.*.*.*
271 %attr(755,root,root) %ghost %{_libdir}/libSDL2-2.0.so.0
272
273 %files devel
274 %defattr(644,root,root,755)
275 %attr(755,root,root) %{_bindir}/sdl2-config
276 %attr(755,root,root) %{_libdir}/libSDL2.so
277 %{_libdir}/libSDL2.la
278 %{_libdir}/libSDL2_test.a
279 %{_libdir}/libSDL2_test.la
280 %{_libdir}/libSDL2main.a
281 %{_libdir}/libSDL2main.la
282 %{_includedir}/SDL2
283 %{_aclocaldir}/sdl2.m4
284 %{_pkgconfigdir}/sdl2.pc
285 %{_libdir}/cmake/SDL2
286
287 %if %{with static_libs}
288 %files static
289 %defattr(644,root,root,755)
290 %{_libdir}/libSDL2.a
291 %endif
292
293 %files examples
294 %defattr(644,root,root,755)
295 %{_examplesdir}/%{name}-%{version}
This page took 0.059515 seconds and 4 git commands to generate.