]> git.pld-linux.org Git - packages/Razor.git/blob - Razor.spec
- perl-Time-HiRes is always BRed
[packages/Razor.git] / Razor.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # don't perform "make test"
5 #
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Collection of files for checking, reporting, and revoking spam
8 Summary(pl):    Zbiór plików do sprawdzania, raportowania i odrzucania spamu
9 Name:           Razor
10 Version:        2.40
11 Release:        1
12 License:        Artistic
13 Group:          Applications/Mail
14 Source0:        http://dl.sourceforge.net/razor/razor-agents-%{version}.tar.gz
15 # Source0-md5:  ca1a340e13464661aa0efebd869fcebc
16 URL:            http://razor.sourceforge.net/
17 %if %{with autodeps}
18 BuildRequires:  perl-Net-DNS
19 BuildRequires:  perl-Class-Fields
20 BuildRequires:  perl-Digest-Nilsimsa
21 BuildRequires:  perl-Digest-SHA1
22 BuildRequires:  perl-URI
23 %endif
24 BuildRequires:  perl-Time-HiRes
25 BuildRequires:  perl-devel >= 1:5.8.0
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 Requires:       perl-Razor = %{version}-%{release}
28 BuildArch:      noarch
29 Obsoletes:      perl-Vipuls-Razor-V1
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Vipul's Razor is a distributed, collaborative, spam detection, reporting,
34 and filtering network.  The primary focus of the system is to identify
35 and remove all email spam from the internet.  Visit the website at
36 <http://razor.sourceforge.net/>.
37
38 %description -l pl
39 Vipul's Razor jest dystrybuowaln±, tworzon± dziêki wspó³pracy sieci±,
40 s³u¿±c± do wykrywania spamu, raportowania i filtrowania.  Podstawowym
41 zadaniem systemu jest identyfikacja spamu z poczty internetowej.
42 Odwied¼ stronê domow±: <http://razor.sourceforge.net/>.
43
44 %package -n perl-Razor
45 Summary:        Perl modules for Razor
46 Summary(pl):    Modu³y Perla dla Razora
47 Group:          Development/Languages/Perl
48
49 %description -n perl-Razor
50 Perl modules for Razor, class Razor2::.
51
52 %description -n perl-Razor -l pl
53 Modu³y Perla dla Razora, klasa Razor2::.
54
55 %prep
56 %setup -q -n razor-agents-%{version}
57
58 %build
59 %{__perl} Makefile.PL \
60         INSTALLDIRS=vendor
61
62 %{__make}
63
64 %{?with_tests:%{__make} test}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT \
71         PERL5LIB=$RPM_BUILD_ROOT%{perl_vendorarch} \
72         INSTALLMAN5DIR=%{_mandir}/man5
73
74 for f in check register report revoke; do
75         ln -sf razor-client $RPM_BUILD_ROOT%{_bindir}/razor-$f
76 done
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc Change* BUGS README INSTALL CREDITS
84 %attr(755,root,root) %{_bindir}/*
85 %{_mandir}/man[15]/*
86
87 %files -n perl-Razor
88 %defattr(644,root,root,755)
89 %{perl_vendorarch}/Razor2
90 %dir %{perl_vendorarch}/auto/Razor2
91 %dir %{perl_vendorarch}/auto/Razor2/Preproc
92 %dir %{perl_vendorarch}/auto/Razor2/Preproc/deHTMLxs
93 %attr(755,root,root) %{perl_vendorarch}/auto/Razor2/Preproc/deHTMLxs/deHTMLxs.so
94 %{perl_vendorarch}/auto/Razor2/Preproc/deHTMLxs/deHTMLxs.bs
95 %{perl_vendorarch}/auto/Razor2/Preproc/deHTMLxs/autosplit.ix
96 %{perl_vendorarch}/auto/Razor2/Syslog
97 %{_mandir}/man3/*
This page took 0.072499 seconds and 3 git commands to generate.