]> git.pld-linux.org Git - packages/Razor.git/blob - Razor.spec
- merged perl BRs from update done on RA-branch
[packages/Razor.git] / Razor.spec
1 #
2 # Conditional build:
3 # _without_autodeps     - don't BR packages needed only for resolving deps
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Collection of files for checking, reporting, and revoking spam
7 Summary(pl):    Zbiór plików do sprawdzania, raportowania i odrzucania spamu
8 Name:           Razor
9 Version:        2.12
10 Release:        4
11 License:        Artistic
12 Group:          Applications/Mail
13 Source0:        http://dl.sourceforge.net/sourceforge/razor/razor-agents-%{version}.tar.gz
14 Patch0:         razor-agents-makefile.patch
15 URL:            http://razor.sourceforge.net/
16 BuildRequires:  perl-devel >= 5.8.0
17 %if 0%{!?_without_autodeps:1}
18 BuildRequires:  perl-Class-Fields
19 BuildRequires:  perl-Digest-Nilsimsa
20 BuildRequires:  perl-Digest-SHA1
21 BuildRequires:  perl-Time-HiRes
22 BuildRequires:  perl-URI
23 %endif
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 Requires:       perl-Razor = %{version}
26 Obsoletes:      perl-Vipuls-Razor-V1
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Vipul's Razor is a distributed, collaborative, spam detection, reporting,
32 and filtering network.  The primary focus of the system is to identify
33 and remove all email spam from the internet.  Visit the website at
34 <http://razor.sourceforge.net/>.
35
36 %description -l pl
37 Vipul's Razor jest dystrybuowaln±, tworzon± dziêki wspó³pracy sieci±,
38 s³u¿±c± do wykrywania spamu, raportowania i filtrowania.  Podstawowym
39 zadaniem systemu jest identyfikacja spamu z poczty internetowej.
40 Odwied¼ stronê domow±: <http://razor.sourceforge.net/>.
41
42 %package -n perl-Razor
43 Summary:        Perl modules for Razor
44 Summary(pl):    Modu³y Perla dla Razora
45 Group:          Development/Languages/Perl
46
47 %description -n perl-Razor
48 Perl modules for Razor, class Razor2::.
49
50 %description -n perl-Razor -l pl
51 Modu³y Perla dla Razora, klasa Razor2::.
52
53 %prep
54 %setup -q -n razor-agents-%{version}
55 %patch -p0
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make}
61
62 #%%{__make} test
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 %{__make} install DESTDIR=$RPM_BUILD_ROOT
67
68 for f in check register report revoke; do
69         ln -sf razor-client $RPM_BUILD_ROOT%{_bindir}/razor-$f
70 done
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc Change* BUGS README INSTALL CREDITS
78 %{_bindir}/*
79 %{_mandir}/man[15]/*
80
81 %files -n perl-Razor
82 %defattr(644,root,root,755)
83 %{perl_vendorlib}/Razor2
84 %{_mandir}/man3/*
This page took 0.063962 seconds and 3 git commands to generate.