]> git.pld-linux.org Git - packages/R.git/blob - R.spec
- lapack-devel requires blas-devel
[packages/R.git] / R.spec
1
2 # Conditional build
3 %bcond_without  tcl             # disable tcl support
4
5 # TODO:
6 # - script for rpm to autoprovides/autorequires R internals
7 #
8 %define KernSmooth_version      2.22r19
9 %define VR_version              7.2r30
10 %define boot_version            1.2r27
11 %define cluster_version         1.11.4
12 %define foreign_version         0.8r18
13 %define lattice_version         0.14r16
14 %define mgcv_version            1.3r22
15 %define nlme_version            3.1r78
16 %define rpart_version           3.1r33
17 %define survival_version        2.30
18
19 %include        /usr/lib/rpm/macros.perl
20 Summary:        A language for data analysis and graphics
21 Summary(pl.UTF-8):      Język do analizy danych oraz grafiki
22 Name:           R
23 Version:        2.5.1
24 Release:        0.2
25 License:        Mixed (distributable), mostly GPL
26 Group:          Development/Languages
27 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
28 Source0:        ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
29 # Source0-md5:  162f6d5a1bd7c60fd652145e050f3f3c
30 Source1:        %{name}.desktop
31 Patch0:         %{name}-asneeded.patch
32 URL:            http://www.r-project.org/
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 BuildRequires:  bzip2-devel
36 BuildRequires:  gcc-c++
37 BuildRequires:  gcc-fortran
38 BuildRequires:  gettext-devel
39 BuildRequires:  lapack-devel >= 3.1.1
40 BuildRequires:  libjpeg-devel >= 6b
41 BuildRequires:  libpng-devel >= 1.0.5
42 BuildRequires:  libstdc++-devel
43 BuildRequires:  libtool
44 BuildRequires:  libxml2-devel >= 2.6.26
45 BuildRequires:  pcre-devel
46 BuildRequires:  perl-base >= 1:5.6
47 BuildRequires:  readline-devel
48 BuildRequires:  rpm-perlprov
49 %{?with_tcl:BuildRequires:      tcl-devel}
50 BuildRequires:  tetex-dvips
51 BuildRequires:  tetex-latex
52 BuildRequires:  tetex-pdftex
53 %{?with_tcl:BuildRequires:      tk-devel}
54 BuildRequires:  xorg-lib-libX11-devel
55 BuildRequires:  zip
56 BuildRequires:  zlib-devel >= 1.1.3
57 #Requires:      lpr
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 A system for statistical computation and graphics. R consists of a
62 language plus a run-time environment with graphics, a debugger, access
63 to certain system functions, and the ability to run programs stored in
64 script files.
65
66 The design of R has been heavily influenced by two existing languages:
67 Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
68 resulting language is very similar in appearance to S, the underlying
69 implementation and semantics are derived from Scheme.
70
71 %description -l pl.UTF-8
72 System do obliczeń statystycznych i grafiki. R składa się z języka
73 oraz środowiska uruchomieniowego z grafiką, debuggerem, dostępem do
74 niektórych funkcji systemowych oraz możliwością uruchamiania programów
75 zapisanych w skryptach.
76
77 Język R był zainspirowany dwoma istniejącymi językami: S (Beckera,
78 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
79 implementacja i semantyka wywodzi się ze Scheme.
80
81 %package base
82 Summary:        The R base distribution
83 Summary(pl.UTF-8):      Podstawowa dystrybucja R
84 License:        GPL v2 / LGPL
85 Group:          Development/Languages
86 Requires(post): perl-base
87 Requires(post): textutils
88 Provides:       R-cran-base
89 Provides:       R-cran-datasets
90 Provides:       R-cran-grDevices
91 Provides:       R-cran-graphics
92 Provides:       R-cran-grid
93 Provides:       R-cran-methods
94 Provides:       R-cran-splines
95 Provides:       R-cran-stats
96 Provides:       R-cran-stats4
97 Provides:       R-cran-tcltk
98 Provides:       R-cran-tools
99 Provides:       R-cran-utils
100
101 %description base
102 R is a language and run-time environment for carrying out interactive
103 statistical data analysis. It is not entirely dissimilar to the S
104 language developed at AT&T Bell Laboratories (and now Lucent
105 Technologies). Indeed, S users will find the environment quite
106 familiar and a good deal of S software will run without change under
107 R.
108
109 %description base -l pl.UTF-8
110 R jest językiem i środowiskiem uruchomieniowym do interaktywnej
111 analizy danych statystycznych. R nie jest całkowicie zgodny z językiem
112 S opracowanym w AT&T Bell Laboratiories (a teraz Lucent Technologies),
113 mimo to użytkownicy S zauważą zbliżone środowisko, a duża część
114 oprogramowania w S będzie działała bez zmian w R.
115
116 %package recommended
117 Summary:        Recommended contributed packages for the R language
118 Summary(pl.UTF-8):      Zalecane dodatkowe pakiety do języka R
119 License:        GPL, free or free for non-commercial use
120 Group:          Development/Languages
121 URL:            http://www.ci.tuwien.ac.at/R/
122 Requires(post,postun):  R-base
123 Requires(post,postun):  perl-base
124 Requires(post,postun):  textutils
125 Requires:       R-base = %{version}-%{release}
126 Provides:       R-cran-KernSmooth = %{KernSmooth_version}
127 Provides:       R-cran-MASS = %{VR_version}
128 Provides:       R-cran-VR = %{VR_version}
129 Provides:       R-cran-boot = %{boot_version}
130 Provides:       R-cran-class = %{VR_version}
131 Provides:       R-cran-cluster = %{cluster_version}
132 Provides:       R-cran-foreign = %{foreign_version}
133 Provides:       R-cran-lattice = %{lattice_version}
134 Provides:       R-cran-mgcv = %{mgcv_version}
135 Provides:       R-cran-nlme = %{nlme_version}
136 Provides:       R-cran-nnet = %{VR_version}
137 Provides:       R-cran-rpart = %{rpart_version}
138 Provides:       R-cran-spatial = %{VR_version}
139 Provides:       R-cran-survival = %{survival_version}
140 Obsoletes:      R-contrib
141 Obsoletes:      R-cran-KernSmooth
142 Obsoletes:      R-cran-MASS
143 Obsoletes:      R-cran-VR
144 Obsoletes:      R-cran-boot
145 Obsoletes:      R-cran-class
146 Obsoletes:      R-cran-cluster
147 Obsoletes:      R-cran-foreign
148 Obsoletes:      R-cran-lattice
149 Obsoletes:      R-cran-mgcv
150 Obsoletes:      R-cran-nlme
151 Obsoletes:      R-cran-nnet
152 Obsoletes:      R-cran-rpart
153 Obsoletes:      R-cran-spatial
154 Obsoletes:      R-cran-survival
155
156 %description recommended
157 Packages which extend the capabilities of the R base distribution and
158 are distributed on the Comprehensive R Archive Network (CRAN).
159
160 %description recommended -l pl.UTF-8
161 Pakiety rozszerzające możliwości podstawowej dystrybucji języka R,
162 dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
163
164 %prep
165 %setup -q
166 %patch0 -p1
167
168 %build
169 %configure \
170         --enable-R-shlib \
171         --enable-linux-lfs \
172         --with-system-zlib \
173         --with-system-bzlib \
174         --with-system-pcre \
175         --with-libpng \
176         --with-jpeglib \
177         --with-blas \
178         --with-lapack \
179         --with-readline \
180         --with%{!?with_tcl:out}-tcltk \
181         --with-recommended-packages
182
183 %{__make}
184 LANG=C LC_ALL=C %{__make} check
185 %{__make} docs
186 %{__make} help
187 %{__make} html
188 %{__make} info
189
190 %install
191 rm -rf $RPM_BUILD_ROOT
192 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
193 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/{R,Text}
194
195 %{__make} install \
196         DESTDIR=${RPM_BUILD_ROOT}
197
198 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
199
200 find $RPM_BUILD_ROOT%{_libdir}/R -name 'Makefile*' -exec rm -f {} \;
201 mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
202 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
203 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
204 rm $RPM_BUILD_ROOT%{_bindir}/%{name}
205 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/%{name}
206 ln -sf %{_libdir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
207
208 (cd $RPM_BUILD_ROOT%{_libdir}/%{name}/share/perl/R/
209 for f in * ; do
210   ln -s %{_libdir}/%{name}/share/perl/R/$f $RPM_BUILD_ROOT%{perl_vendorlib}/R/
211 done)
212 (cd $RPM_BUILD_ROOT%{_libdir}/%{name}/share/perl/Text
213 for f in * ; do
214   ln -s %{_libdir}/%{name}/share/perl/Text/$f $RPM_BUILD_ROOT%{perl_vendorlib}/Text/
215 done)
216
217 %clean
218 rm -rf $RPM_BUILD_ROOT
219
220 %post
221 (cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
222  R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --index)
223 /sbin/ldconfig
224
225 %postun -p /sbin/ldconfig
226
227 %files base
228 %defattr(644,root,root,755)
229 %doc NEWS README doc/{AUTHORS,COPYRIGHTS,FAQ,RESOURCES,THANKS}
230
231 %{_mandir}/man1/R.1*
232 %{_mandir}/man1/Rscript*
233 %attr(755,root,root) %{_bindir}/R
234 %attr(755,root,root) %{_bindir}/Rscript
235 %dir %{_libdir}/R
236 %attr(755,root,root) %{_libdir}/R/bin
237 %attr(755,root,root) %{_libdir}/libR*.so
238 %{_libdir}/R/etc
239 %{_libdir}/R/include
240 %{_includedir}/R
241 %{_libdir}/R/share
242 %{_libdir}/R/COPYING
243 %{_libdir}/R/NEWS
244 %{_libdir}/R/SVN-REVISION
245 %dir %{_libdir}/R/library
246 %{_libdir}/%{name}/library/R.css
247 # %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
248 %dir %{_libdir}/R/doc
249 %{_libdir}/R/doc/[KRm]*
250 %dir %{_libdir}/R/doc/html
251 %{_libdir}/R/doc/html/*.css
252 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
253 %{_libdir}/R/doc/html/packages-head*.html
254 %{_libdir}/R/doc/html/*.jpg
255 %dir %{_libdir}/R/doc/html/search
256 %{_libdir}/R/doc/html/search/[A-Z]*
257 %ghost %{_libdir}/R/doc/html/search/index.txt
258 %ghost %{_libdir}/R/doc/html/packages.html
259 %{_desktopdir}/*.desktop
260
261 %dir %{perl_vendorlib}/R
262 %{perl_vendorlib}/R/*
263 %{perl_vendorlib}/Text/*
264
265 %attr(755,root,root) %{_libdir}/%{name}/modules
266
267 %{_libdir}/%{name}/library/KernSmooth
268 %{_libdir}/%{name}/library/MASS
269 %{_libdir}/%{name}/library/base
270 %{_libdir}/%{name}/library/boot
271 %{_libdir}/%{name}/library/class
272 %{_libdir}/%{name}/library/cluster
273 %{_libdir}/%{name}/library/codetools
274 %{_libdir}/%{name}/library/datasets
275 %{_libdir}/%{name}/library/foreign
276 %{_libdir}/%{name}/library/grDevices
277 %{_libdir}/%{name}/library/graphics
278 %{_libdir}/%{name}/library/grid
279 %{_libdir}/%{name}/library/lattice
280 %{_libdir}/%{name}/library/methods
281 %{_libdir}/%{name}/library/mgcv
282 %{_libdir}/%{name}/library/nlme
283 %{_libdir}/%{name}/library/nnet
284 %{_libdir}/%{name}/library/rcompgen
285 %{_libdir}/%{name}/library/rpart
286 %{_libdir}/%{name}/library/spatial
287 %{_libdir}/%{name}/library/survival
288 %{_libdir}/%{name}/library/splines
289 %{_libdir}/%{name}/library/stats
290 %{_libdir}/%{name}/library/stats4
291 %{_libdir}/%{name}/library/tcltk
292 %{_libdir}/%{name}/library/tools
293 %{_libdir}/%{name}/library/utils
294
295 %files recommended
296 %defattr(644,root,root,755)
This page took 0.23503 seconds and 4 git commands to generate.