]> git.pld-linux.org Git - packages/R.git/blob - R.spec
- ver. 2.15.0
[packages/R.git] / R.spec
1 #
2 # Conditional build
3 %bcond_without  tcl             # disable tcl support
4 %bcond_without  tests           # do not run "make check"
5 #
6 # NOTE:
7 # - /etc/localtime must be present for tests to work
8 #
9 # TODO:
10 # - 755 for %{_libdir}/R/library/*/libs/*.so
11 # - %lang( ) for %{_libdir}/R/library/*/po/* dirs
12 # - script for rpm to autoprovides/autorequires R internals
13 #
14 %include        /usr/lib/rpm/macros.perl
15 Summary:        A language for data analysis and graphics
16 Summary(pl.UTF-8):      Język do analizy danych oraz grafiki
17 Name:           R
18 Version:        2.15.0
19 Release:        1
20 License:        Mixed (distributable), mostly GPL v2+
21 Group:          Development/Languages
22 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
23 Source0:        ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
24 # Source0-md5:  905f638990492618559202cc1e48a867
25 Source1:        %{name}.desktop
26 Source2:        %{name}.xpm
27 URL:            http://www.r-project.org/
28 BuildRequires:  autoconf >= 2.62
29 BuildRequires:  automake
30 BuildRequires:  blas-devel >= 3.2.2-2
31 BuildRequires:  bzip2-devel >= 1.0.6
32 BuildRequires:  cairo-devel >= 1.6
33 BuildRequires:  gcc-fortran
34 BuildRequires:  gettext-devel
35 BuildRequires:  lapack-devel >= 3.2.2-2
36 BuildRequires:  libicu-devel
37 BuildRequires:  libjpeg-devel >= 6b
38 BuildRequires:  libpng-devel >= 1.2.7
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtiff-devel
41 BuildRequires:  libtool >= 2:2.0
42 BuildRequires:  libxml2-devel >= 2.6.26
43 BuildRequires:  pango-devel
44 BuildRequires:  pcre-devel >= 7.6
45 BuildRequires:  perl-base >= 1:5.6
46 BuildRequires:  pkgconfig
47 BuildRequires:  readline-devel
48 BuildRequires:  rpm-perlprov
49 %{?with_tcl:BuildRequires:      tcl-devel >= 8.4}
50 BuildRequires:  tetex-dvips
51 BuildRequires:  tetex-latex
52 BuildRequires:  tetex-pdftex
53 BuildRequires:  texinfo-texi2dvi >= 4.7
54 %{?with_tcl:BuildRequires:      tk-devel >= 8.4}
55 BuildRequires:  xorg-lib-libX11-devel
56 BuildRequires:  xorg-lib-libXmu-devel
57 BuildRequires:  xorg-lib-libXt-devel
58 BuildRequires:  xz-devel >= 4.999
59 BuildRequires:  zip
60 BuildRequires:  zlib-devel >= 1.2.3
61 #Requires:      lpr
62 Requires(post): perl-base
63 Requires(post): textutils
64 Requires:       blas >= 3.2.2-2
65 Suggests:       rkward
66 Obsoletes:      R-base
67 Obsoletes:      R-contrib
68 Obsoletes:      R-recommended
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %description
72 A system for statistical computation and graphics. R consists of a
73 language plus a run-time environment with graphics, a debugger, access
74 to certain system functions, and the ability to run programs stored in
75 script files.
76
77 The design of R has been heavily influenced by two existing languages:
78 Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
79 resulting language is very similar in appearance to S, the underlying
80 implementation and semantics are derived from Scheme.
81
82 %description -l pl.UTF-8
83 System do obliczeń statystycznych i grafiki. R składa się z języka
84 oraz środowiska uruchomieniowego z grafiką, debuggerem, dostępem do
85 niektórych funkcji systemowych oraz możliwością uruchamiania programów
86 zapisanych w skryptach.
87
88 Język R był zainspirowany dwoma istniejącymi językami: S (Beckera,
89 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
90 implementacja i semantyka wywodzi się ze Scheme.
91
92 %prep
93 %setup -q
94
95 %build
96 %{__aclocal} -I m4
97 %{__autoconf}
98 install -d build
99 cd build
100 ../%configure \
101         --enable-R-shlib \
102         --enable-largefile \
103         --with-ICU \
104         --with-blas \
105         --with-cairo \
106         --with-jpeglib \
107         --with-lapack \
108         --with-libpng \
109         --with-readline \
110         --with-recommended-packages \
111         --with-system-bzlib \
112         --with-system-pcre \
113         --with-system-xz \
114         --with-system-zlib \
115         --with%{!?with_tcl:out}-tcltk \
116         --with-x
117
118 %{__make}
119
120 %if %{with tests}
121 %{__make} check
122 %endif
123
124 %{__make} docs pdf info
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir},%{_pixmapsdir}}
129
130 %{__make} -C build -j1 install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
134 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
135
136 ln -sf %{_libdir}/R/lib/libR.so $RPM_BUILD_ROOT%{_libdir}
137
138 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
139 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
140
141 gen_lang() {
142         dir="$1"
143         for d in $RPM_BUILD_ROOT${dir}/* ; do
144                 bd=$(basename $d)
145                 lang="${bd%@*}"
146                 echo "%lang($lang) ${dir}/${bd}"
147         done
148 }
149
150 gen_lang %{_libdir}/R/share/locale > R.files
151 for moddir in $RPM_BUILD_ROOT%{_libdir}/R/library/* ; do
152         module=$(basename $moddir)
153         echo "%dir %{_libdir}/R/library/${module}"
154         for f in $moddir/* ; do
155                 bf=$(basename $f)
156                 case "$bf" in
157                   po)
158                         echo "%dir %{_libdir}/R/library/${module}/po"
159                         gen_lang %{_libdir}/R/library/${module}/po
160                         ;;
161                   libs)
162                         echo "%dir %{_libdir}/R/library/${module}/libs"
163                         echo "%attr(755,root,root) %{_libdir}/R/library/${module}/libs/*.so"
164                         ;;
165                   *)
166                         echo "%{_libdir}/R/library/${module}/${bf}"
167                         ;;
168                 esac
169         done
170 done >> R.files
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post   -p /sbin/ldconfig
176 %postun -p /sbin/ldconfig
177
178 %files -f R.files
179 %defattr(644,root,root,755)
180 %doc NEWS README doc/{AUTHORS,COPYRIGHTS,FAQ,RESOURCES,THANKS}
181 %attr(755,root,root) %{_bindir}/R
182 %attr(755,root,root) %{_bindir}/Rscript
183 %dir %{_libdir}/R
184 %dir %{_libdir}/R/lib
185 %attr(755,root,root) %{_libdir}/R/lib/libR.so
186 %{_libdir}/libR.so
187 %{_libdir}/R/COPYING
188 %{_libdir}/R/NEWS
189 %{_libdir}/R/SVN-REVISION
190 %attr(755,root,root) %{_libdir}/R/bin
191 # %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
192 %dir %{_libdir}/R/doc
193 %{_libdir}/R/doc/[KRm]*
194 %dir %{_libdir}/R/doc/html
195 %{_libdir}/R/doc/html/*.css
196 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
197 %{_libdir}/R/doc/html/packages-head*.html
198 %{_libdir}/R/doc/html/*.jpg
199 %ghost %{_libdir}/R/doc/html/packages.html
200 %{_libdir}/R/etc
201 %{_libdir}/R/include
202 %dir %{_libdir}/R/library
203 # library files list is autogenerated (see R.files above)
204 %attr(755,root,root) %{_libdir}/R/modules
205 %dir %{_libdir}/R/share
206 %{_libdir}/R/share/R
207 %{_libdir}/R/share/encodings
208 %{_libdir}/R/share/java
209 %{_libdir}/R/share/licenses
210 %dir %{_libdir}/R/share/locale
211 # locale files list is autogenerated (see R.files above)
212 %{_libdir}/R/share/make
213 %{_libdir}/R/share/sh
214 %{_libdir}/R/share/texmf
215 %{_desktopdir}/R.desktop
216 %{_pixmapsdir}/R.xpm
217 %{_includedir}/R
218 %{_pkgconfigdir}/libR.pc
219 %{_mandir}/man1/R.1*
220 %{_mandir}/man1/Rscript*
This page took 0.076161 seconds and 3 git commands to generate.