]> git.pld-linux.org Git - packages/R.git/blob - R.spec
- release 2
[packages/R.git] / R.spec
1 # TODO:
2 # - move perl R libraries to standard perl location
3 # - script for rpm to autoprovides/autorequires R internals
4 #
5 # Conditional build:
6 %bcond_without  gnome   # without GNOME support
7 #
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        A language for data analysis and graphics
10 Summary(pl):    Jêzyk do analizy danych oraz grafiki
11 Name:           R
12 Version:        2.2.1
13 Release:        2
14 License:        Mixed (distributable), mostly GPL
15 Group:          Development/Languages
16 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
17 Source0:        ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
18 # Source0-md5:  42542290c6d1585af7ded330f811385c
19 Source1:        %{name}.desktop
20 URL:            http://www.r-project.org/
21 BuildRequires:  XFree86-devel
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  blas-devel
25 BuildRequires:  bzip2-devel
26 BuildRequires:  gcc-c++
27 BuildRequires:  gcc-g77
28 BuildRequires:  gettext-devel
29 BuildRequires:  libjpeg-devel >= 6b
30 BuildRequires:  libpng-devel >= 1.0.5
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtool
33 BuildRequires:  libxml-devel
34 BuildRequires:  perl-base >= 1:5.6
35 BuildRequires:  readline-devel
36 BuildRequires:  rpm-perlprov
37 BuildRequires:  tcl-devel
38 BuildRequires:  tetex-latex
39 BuildRequires:  tetex-dvips
40 BuildRequires:  tetex-pdftex
41 BuildRequires:  tk-devel
42 BuildRequires:  zip
43 BuildRequires:  zlib >= 1.1.3
44 #BuildRequires: lpr
45 #Requires:      lpr
46 %{?with_gnome:BuildRequires:    gnome-libs-devel}
47 %{?with_gnome:BuildRequires:    ORBit-devel}
48 %{?with_gnome:BuildRequires:    libglade-gnome-devel}
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 A system for statistical computation and graphics. R consists of a
53 language plus a run-time environment with graphics, a debugger, access
54 to certain system functions, and the ability to run programs stored in
55 script files.
56
57 The design of R has been heavily influenced by two existing languages:
58 Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
59 resulting language is very similar in appearance to S, the underlying
60 implementation and semantics are derived from Scheme.
61
62 %description -l pl
63 System do obliczeñ statystycznych i grafiki. R sk³ada siê z jêzyka
64 oraz ¶rodowiska uruchomieniowego z grafik±, debuggerem, dostêpem do
65 niektórych funkcji systemowych oraz mo¿liwo¶ci± uruchamiania programów
66 zapisanych w skryptach.
67
68 Jêzyk R by³ zainspirowany dwoma istniej±cymi jêzykami: S (Beckera,
69 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
70 implementacja i semantyka wywodzi siê ze Scheme.
71
72 %package base
73 Summary:        The R base distribution
74 Summary(pl):    Podstawowa dystrybucja R
75 License:        GPL v2 / LGPL
76 Group:          Development/Languages
77 Requires(post): textutils
78 Requires(post): perl-base
79 Provides:       R-cran-base
80 Provides:       R-cran-datasets
81 Provides:       R-cran-grid
82 Provides:       R-cran-graphics
83 Provides:       R-cran-grDevices
84 Provides:       R-cran-methods
85 Provides:       R-cran-utils
86 Provides:       R-cran-tcltk
87 Provides:       R-cran-splines
88 Provides:       R-cran-stats
89 Provides:       R-cran-stats4
90 Provides:       R-cran-tools
91
92 %description base
93 R is a language and run-time environment for carrying out interactive
94 statistical data analysis. It is not entirely dissimilar to the S
95 language developed at AT&T Bell Laboratories (and now Lucent
96 Technologies). Indeed, S users will find the environment quite
97 familiar and a good deal of S software will run without change under
98 R.
99
100 %description base -l pl
101 R jest jêzykiem i ¶rodowiskiem uruchomieniowym do interaktywnej
102 analizy danych statystycznych. R nie jest ca³kowicie zgodny z jêzykiem
103 S opracowanym w AT&T Bell Laboratiories (a teraz Lucent Technologies),
104 mimo to u¿ytkownicy S zauwa¿± zbli¿one ¶rodowisko, a du¿a czê¶æ
105 oprogramowania w S bêdzie dzia³a³a bez zmian w R.
106
107 %package recommended
108 Summary:        Recommended contributed packages for the R language
109 Summary(pl):    Zalecane dodatkowe pakiety do jêzyka R
110 Group:          Development/Languages
111 Requires:       R-cran-KernSmooth
112 Requires:       R-cran-VR
113 Requires:       R-cran-boot
114 Requires:       R-cran-cluster
115 Requires:       R-cran-foreign
116 Requires:       R-cran-lattice
117 Requires:       R-cran-mgcv
118 Requires:       R-cran-nlme
119 Requires:       R-cran-rpart
120 Requires:       R-cran-survival
121 License:        GPL, free or free for non-commercial use
122 URL:            http://www.ci.tuwien.ac.at/R/
123 Requires(post,postun):  R-base
124 Requires(post,postun):  perl-base
125 Requires(post,postun):  textutils
126 Obsoletes:      R-contrib
127 Requires:       R-base = %{version}-%{release}
128
129 %description recommended
130 Packages which extend the capabilities of the R base distribution and
131 are distributed on the Comprehensive R Archive Network (CRAN).
132
133 %description recommended -l pl
134 Pakiety rozszerzaj±ce mo¿liwo¶ci podstawowej dystrybucji jêzyka R,
135 dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
136
137 %prep
138 %setup -q
139
140 # These files have the path for Perl hard-coded as /usr/local/bin/perl
141 # We need to remove them to avoid dependency problems
142 rm -f ./doc/keyword-test.orig ./etc/undoc/R-funs.orig ./etc/undoc/extrExamp.orig
143
144 %build
145 %{__aclocal} -I m4
146 %{__autoconf}
147 cp -f /usr/share/automake/config.* .
148 %configure \
149         --with%{!?with_gnome:out}-gnome \
150         --enable-R-shlib \
151         --enable-linux-lfs \
152         --with-zlib \
153         --with-bzlib \
154         --with-pcre \
155         --without-recommended-packages
156
157 %{__make}
158 %{__make} check
159 %{__make} docs
160 %{__make} help
161 %{__make} html
162 %{__make} info
163
164 %install
165 rm -rf $RPM_BUILD_ROOT
166 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
167
168 %{__make} install \
169         rhome=$RPM_BUILD_ROOT%{_libdir}/R \
170         mandir=$RPM_BUILD_ROOT%{_mandir} \
171         bindir=$RPM_BUILD_ROOT%{_bindir} \
172         
173
174 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
175
176 find $RPM_BUILD_ROOT%{_libdir}/R -name 'Makefile*' -exec rm -f {} \;
177 mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
178 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
179 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
180 rm $RPM_BUILD_ROOT%{_bindir}/%{name}
181 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/%{name}
182 ln -sf %{_libdir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
183
184 %clean
185 rm -rf $RPM_BUILD_ROOT
186
187 %post
188 (cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
189  R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --htmllist)
190 /sbin/ldconfig
191
192 %postun -p /sbin/ldconfig
193
194 %files base
195 %defattr(644,root,root,755)
196 %doc COPYRIGHTS FAQ NEWS README RESOURCES THANKS Y2K
197
198 %{_mandir}/man1/R.1*
199 %attr(755,root,root) %{_bindir}/R
200 %dir %{_libdir}/R
201 %attr(755,root,root) %{_libdir}/R/bin
202 %attr(755,root,root) %{_libdir}/libR*.so
203 %{_libdir}/R/etc
204 %{_libdir}/R/include
205 %{_includedir}/R
206 %{_libdir}/R/share
207 %{_libdir}/R/AUTHORS
208 %dir %{_libdir}/R/library
209 # %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
210 %dir %{_libdir}/R/doc
211 %{_libdir}/R/doc/[KRm]*
212 %dir %{_libdir}/R/doc/html
213 %{_libdir}/R/doc/html/*.css
214 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
215 %{_libdir}/R/doc/html/packages-head.html
216 %{_libdir}/R/doc/html/*.jpg
217 %dir %{_libdir}/R/doc/html/search
218 %{_libdir}/R/doc/html/search/[A-Z]*
219 %ghost %{_libdir}/R/doc/html/search/index.txt
220 %ghost %{_libdir}/R/doc/html/packages.html
221 %{_desktopdir}/*
222
223 %attr(755,root,root) %{_libdir}/%{name}/modules
224
225 %{_libdir}/%{name}/library/base
226 %{_libdir}/%{name}/library/datasets
227 %{_libdir}/%{name}/library/grid
228 %{_libdir}/%{name}/library/graphics
229 %{_libdir}/%{name}/library/grDevices
230 %{_libdir}/%{name}/library/methods
231 %{_libdir}/%{name}/library/utils
232 %{_libdir}/%{name}/library/tcltk
233 %{_libdir}/%{name}/library/splines
234 %{_libdir}/%{name}/library/stats
235 %{_libdir}/%{name}/library/stats4
236 %{_libdir}/%{name}/library/tools
237
238 %files recommended
This page took 1.967285 seconds and 3 git commands to generate.