]> git.pld-linux.org Git - packages/QtSingleApplication.git/blob - QtSingleApplication.spec
update clementine patch against current git (841982ceec9d30a7ab7324979a0fd5c9c36fd121)
[packages/QtSingleApplication.git] / QtSingleApplication.spec
1 # last commit to qtsingleapplication subdir in
2 # https://qt.gitorious.org/qt-solutions/qt-solutions/
3 %define commit  841982ceec9d30a7ab7324979a0fd5c9c36fd121
4 Summary:        Qt library to start applications only once per user
5 Name:           QtSingleApplication
6 Version:        2.6.1
7 Release:        1
8 License:        GPL v3 or LGPL v2 with exceptions
9 Group:          Libraries
10 # git clone git@gitorious.org:qt-solutions/qt-solutions.git
11 # git checkout %{commit}
12 # tar -cjf QtSingleApplication-%{version}.tar.bz2 -C qt-solutions/qtsingleapplication .
13 Source0:        %{name}-%{version}.tar.bz2
14 # Source0-md5:  2442ba5536b99b4b9144bd33ea23cb17
15 Source1:        qtsingleapplication.prf
16 Source2:        qtsinglecoreapplication.prf
17 Patch0:         qtsingleapplication-build.diff
18 Patch1:         qtlockedfile.patch
19 Patch2:         clementine.patch
20 URL:            http://doc.qt.digia.com/solutions/4/qtsingleapplication/qtsingleapplication.html
21 BuildRequires:  QtCore-devel
22 BuildRequires:  QtGui-devel
23 BuildRequires:  QtLockedFile-devel
24 BuildRequires:  QtNetwork-devel
25 BuildRequires:  qt4-build
26 BuildRequires:  qt4-qmake
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         qt4dir  %{_datadir}/qt4
30
31 %description
32 For some applications it is useful or even critical that they are
33 started only once by any user. Future attempts to start the
34 application should activate any already running instance, and possibly
35 perform requested actions, e.g. loading a file, in that instance.
36
37 The QtSingleApplication class provides an interface to detect a
38 running instance, and to send command strings to that instance.
39
40 For console (non-GUI) applications, the QtSingleCoreApplication
41 variant is provided, which avoids dependency on QtGui.
42
43 %package devel
44 Summary:        Development files for QtSingleApplication
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       qt4-build
48 Requires:       qt4-qmake
49
50 %description devel
51 This package contains libraries and header files for developing
52 applications that use QtSingleApplication.
53
54 %prep
55 %setup -qc
56 %patch0 -p0
57 %patch1 -p0
58 %patch2 -p1
59
60 # We already disabled bundling this extrenal library.
61 # But just to make sure:
62 rm src/{QtLocked,qtlocked}*
63
64 %build
65 # Does not use GNU configure
66 ./configure \
67         -library
68 qmake-qt4
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/qt4/QtSolutions,%{qt4dir}/mkspecs/features}
74 cp -a lib/* $RPM_BUILD_ROOT%{_libdir}
75 rm $RPM_BUILD_ROOT%{_libdir}/lib*.so.1.0
76 cp -p src/qtsingle*application.h src/QtSingle*Application $RPM_BUILD_ROOT%{_includedir}/qt4/QtSolutions
77 cp -p %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{qt4dir}/mkspecs/features
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post   -p /sbin/ldconfig
83 %postun -p /sbin/ldconfig
84
85 %files
86 %defattr(644,root,root,755)
87 %doc README.TXT
88 %attr(755,root,root) %{_libdir}/libQtSolutions_SingleApplication-2.6.so.*.*.*
89 %attr(755,root,root) %ghost %{_libdir}/libQtSolutions_SingleApplication-2.6.so.1
90 %attr(755,root,root) %{_libdir}/libQtSolutions_SingleCoreApplication-2.6.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libQtSolutions_SingleCoreApplication-2.6.so.1
92
93 %files devel
94 %defattr(644,root,root,755)
95 %doc doc examples
96 %{_libdir}/libQtSolutions_SingleApplication-2.6.so
97 %{_libdir}/libQtSolutions_SingleCoreApplication-2.6.so
98 # XXX dir shared dir
99 %dir %{_includedir}/qt4/QtSolutions
100 %{_includedir}/qt4/QtSolutions/QtSingleApplication
101 %{_includedir}/qt4/QtSolutions/QtSingleCoreApplication
102 %{_includedir}/qt4/QtSolutions/qtsingleapplication.h
103 %{_includedir}/qt4/QtSolutions/qtsinglecoreapplication.h
104 %{qt4dir}/mkspecs/features/qtsingleapplication.prf
105 %{qt4dir}/mkspecs/features/qtsinglecoreapplication.prf
This page took 0.211465 seconds and 3 git commands to generate.