]> git.pld-linux.org Git - packages/QtLockedFile.git/blob - QtLockedFile.spec
- BR: QtCore-devel, libstdc++-devel, qt4-qmake
[packages/QtLockedFile.git] / QtLockedFile.spec
1 Summary:        QFile extension with advisory locking functions
2 Name:           QtLockedFile
3 Version:        2.4
4 Release:        1
5 License:        GPL v3 or LGPL v2 with exceptions
6 Group:          Libraries
7 URL:            http://qt.nokia.com/products/appdev/add-on-products/catalog/4/Utilities/qtlockedfile
8 Source0:        http://get.qt.nokia.com/qt/solutions/lgpl/qtlockedfile-%{version}_1-opensource.tar.gz
9 # Source0-md5:  ac8f848f59038a414f3ab4f4cc08e99c
10 Source1:        qtlockedfile.prf
11 Patch0:         qtlockedfile-dont-build-example.patch
12 # Remove unnecessary linkage to libQtGui
13 Patch1:         qtlockedfile-dont-link-qtgui.patch
14 BuildRequires:  QtCore-devel
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  qt4-qmake
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _qt4_datadir    %{_datadir}/qt4
20
21 %description
22 This class extends the QFile class with inter-process file locking
23 capabilities. If an application requires that several processes should
24 access the same file, QtLockedFile can be used to easily ensure that
25 only one process at a time is writing to the file, and that no process
26 is writing to it while others are reading it.
27
28 %package        devel
29 Summary:        Development files for QtLockedFile library
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32 Requires:       qt4-build
33 Requires:       qt4-qmake
34
35 %description    devel
36 This package contains libraries and header files for developing
37 applications that use QtLockedFile.
38
39 %prep
40 %setup -q -n qtlockedfile-%{version}_1-opensource
41 %patch0 -p1
42 %patch1 -p1
43
44
45 %build
46 touch .licenseAccepted
47 # Does not use GNU configure
48 ./configure -library
49 qmake-qt4
50 %{__make}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 # libraries
56 install -d $RPM_BUILD_ROOT%{_libdir}
57 cp -a lib/* $RPM_BUILD_ROOT%{_libdir}
58
59 rm $RPM_BUILD_ROOT%{_libdir}/lib*-%{version}.so.1.0
60
61 # headers
62 install -d $RPM_BUILD_ROOT%{_includedir}/QtSolutions
63 cp -a \
64     src/qtlockedfile.h \
65     src/QtLockedFile \
66     $RPM_BUILD_ROOT%{_includedir}/QtSolutions
67
68 install -d $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features
69 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post   -p /sbin/ldconfig
75 %postun -p /sbin/ldconfig
76
77 %files
78 %defattr(644,root,root,755)
79 %doc LGPL_EXCEPTION.txt LICENSE.* README.TXT
80 %attr(755,root,root) %{_libdir}/libQtSolutions_LockedFile-%{version}.so.*.*.*
81 %attr(755,root,root) %ghost %{_libdir}/libQtSolutions_LockedFile-%{version}.so.1
82
83 %files devel
84 %defattr(644,root,root,755)
85 %doc doc example
86 %{_libdir}/libQtSolutions_LockedFile-%{version}.so
87 # XXX shared dir with QtSingleApplication
88 %dir %{_includedir}/QtSolutions
89 %{_includedir}/QtSolutions/QtLockedFile
90 %{_includedir}/QtSolutions/qtlockedfile.h
91 %{_qt4_datadir}/mkspecs/features/qtlockedfile.prf
This page took 0.084517 seconds and 4 git commands to generate.