]> git.pld-linux.org Git - packages/QtLockedFile.git/blob - QtLockedFile.spec
up to latest commit 17b56547d6e0d9a06603231fe2384474f9144829
[packages/QtLockedFile.git] / QtLockedFile.spec
1
2 # last commit to qtlockedfile subdir in
3 # https://qt.gitorious.org/qt-solutions/qt-solutions/
4 %define commit  17b56547d6e0d9a06603231fe2384474f9144829
5 Summary:        QFile extension with advisory locking functions
6 Name:           QtLockedFile
7 Version:        2.4
8 Release:        2
9 License:        GPL v3 or LGPL v2 with exceptions
10 Group:          Libraries
11 # git clone git@gitorious.org:qt-solutions/qt-solutions.git
12 # git checkout %{commit}
13 # tar -cjf QtLockedFile-%{version}.tar.bz2 -C qt-solutions/qtlockedfile .
14 Source0:        %{name}-%{version}.tar.bz2
15 # Source0-md5:  8d0525b7f3dc92ee1464c6a538832535
16 Source1:        qtlockedfile.prf
17 Patch0:         qtlockedfile-dont-build-example.patch
18 Patch1:         qtlockedfile-use-current-version.patch
19 URL:            http://doc.qt.digia.com/solutions/4/qtlockedfile/qtlockedfile.html
20 BuildRequires:  QtCore-devel
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  qt4-qmake
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _qt4_datadir    %{_datadir}/qt4
26
27 %description
28 This class extends the QFile class with inter-process file locking
29 capabilities. If an application requires that several processes should
30 access the same file, QtLockedFile can be used to easily ensure that
31 only one process at a time is writing to the file, and that no process
32 is writing to it while others are reading it.
33
34 %package devel
35 Summary:        Development files for QtLockedFile library
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       qt4-build
39 Requires:       qt4-qmake
40
41 %description devel
42 This package contains libraries and header files for developing
43 applications that use QtLockedFile.
44
45 %prep
46 %setup -qc
47 %patch0 -p1
48 %patch1 -p0
49
50 %build
51 touch .licenseAccepted
52 # Does not use GNU configure
53 ./configure -library
54 qmake-qt4
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 # libraries
61 install -d $RPM_BUILD_ROOT%{_libdir}
62 cp -a lib/* $RPM_BUILD_ROOT%{_libdir}
63
64 rm $RPM_BUILD_ROOT%{_libdir}/lib*-%{version}.so.1.0
65
66 # headers
67 install -d $RPM_BUILD_ROOT%{_includedir}/QtSolutions
68 cp -p \
69     src/qtlockedfile.h \
70     src/QtLockedFile \
71     $RPM_BUILD_ROOT%{_includedir}/QtSolutions
72
73 install -d $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features
74 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %doc README.TXT
85 #%doc LGPL_EXCEPTION.txt LICENSE.*
86 %attr(755,root,root) %{_libdir}/libQtSolutions_LockedFile-%{version}.so.*.*.*
87 %attr(755,root,root) %ghost %{_libdir}/libQtSolutions_LockedFile-%{version}.so.1
88
89 %files devel
90 %defattr(644,root,root,755)
91 %doc doc example
92 %{_libdir}/libQtSolutions_LockedFile-%{version}.so
93 # XXX shared dir with QtSingleApplication
94 %dir %{_includedir}/QtSolutions
95 %{_includedir}/QtSolutions/QtLockedFile
96 %{_includedir}/QtSolutions/qtlockedfile.h
97 %{_qt4_datadir}/mkspecs/features/qtlockedfile.prf
This page took 0.038136 seconds and 4 git commands to generate.