]> git.pld-linux.org Git - packages/QtLockedFile.git/blob - QtLockedFile.spec
- new, based on https://bugzilla.redhat.com/show_bug.cgi?id=582864
[packages/QtLockedFile.git] / QtLockedFile.spec
1 Summary:        QFile extension with advisory locking functions
2 Name:           QtLockedFile
3 Version:        2.4
4 Release:        1
5 License:        GPL v3 or LGPL v2 with exceptions
6 Group:          Libraries
7 URL:            http://qt.nokia.com/products/appdev/add-on-products/catalog/4/Utilities/qtlockedfile
8 Source0:        http://get.qt.nokia.com/qt/solutions/lgpl/qtlockedfile-%{version}_1-opensource.tar.gz
9 # Source0-md5:  ac8f848f59038a414f3ab4f4cc08e99c
10 Source1:        qtlockedfile.prf
11 Patch0:         qtlockedfile-dont-build-example.patch
12 # Remove unnecessary linkage to libQtGui
13 Patch1:         qtlockedfile-dont-link-qtgui.patch
14 BuildRequires:  qt4-build
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _qt4_datadir    %{_datadir}/qt4
18
19 %description
20 This class extends the QFile class with inter-process file locking
21 capabilities. If an application requires that several processes should
22 access the same file, QtLockedFile can be used to easily ensure that
23 only one process at a time is writing to the file, and that no process
24 is writing to it while others are reading it.
25
26 %package        devel
27 Summary:        Development files for QtLockedFile library
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30 Requires:       qt4-build
31 Requires:       qt4-qmake
32
33 %description    devel
34 This package contains libraries and header files for developing
35 applications that use QtLockedFile.
36
37 %prep
38 %setup -q -n qtlockedfile-%{version}_1-opensource
39 %patch0 -p1
40 %patch1 -p1
41
42
43 %build
44 touch .licenseAccepted
45 # Does not use GNU configure
46 ./configure -library
47 qmake-qt4
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 # libraries
54 install -d $RPM_BUILD_ROOT%{_libdir}
55 cp -a lib/* $RPM_BUILD_ROOT%{_libdir}
56
57 rm $RPM_BUILD_ROOT%{_libdir}/lib*-%{version}.so.1.0
58
59 # headers
60 install -d $RPM_BUILD_ROOT%{_includedir}/QtSolutions
61 cp -a \
62     src/qtlockedfile.h \
63     src/QtLockedFile \
64     $RPM_BUILD_ROOT%{_includedir}/QtSolutions
65
66 install -d $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features
67 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post   -p /sbin/ldconfig
73 %postun -p /sbin/ldconfig
74
75 %files
76 %defattr(644,root,root,755)
77 %doc LGPL_EXCEPTION.txt LICENSE.* README.TXT
78 %attr(755,root,root) %{_libdir}/libQtSolutions_LockedFile-%{version}.so.*.*.*
79 %attr(755,root,root) %ghost %{_libdir}/libQtSolutions_LockedFile-%{version}.so.1
80
81 %files devel
82 %defattr(644,root,root,755)
83 %doc doc example
84 %{_libdir}/libQtSolutions_LockedFile-%{version}.so
85 # XXX shared dir with QtSingleApplication
86 %dir %{_includedir}/QtSolutions
87 %{_includedir}/QtSolutions/QtLockedFile
88 %{_includedir}/QtSolutions/qtlockedfile.h
89 %{_qt4_datadir}/mkspecs/features/qtlockedfile.prf
This page took 0.060326 seconds and 4 git commands to generate.