]> git.pld-linux.org Git - packages/QtCurve.git/blob - QtCurve.spec
dd2c689fe9ef36aeb8c3071a793bee15c08e4a5e
[packages/QtCurve.git] / QtCurve.spec
1 #
2 # ToDo:
3 #  - include /usr/share/themes/QtCurve/mozilla somewhere
4 #
5 # Conditional build:
6 %bcond_with     gtk     # build GTK styles
7 %bcond_without  gtk2    # don't build GTK+2 styles
8 #
9 %define         kde_ver         0.46.2
10 %define         gtk2_ver        0.46.2
11 %define         gtk1_ver        0.42.2
12 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
13 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
14 Name:           QtCurve
15 Version:        0.46.2
16 Release:        1
17 License:        GPL
18 Group:          Themes
19 Source0:        http://home.freeuk.com/cpdrummond/%{name}-KDE3-%{kde_ver}.tar.gz
20 # Source0-md5:  928ff52cdb312275ee24363501faa5e2
21 Source1:        http://home.freeuk.com/cpdrummond/%{name}-Gtk2-%{gtk2_ver}.tar.gz
22 # Source1-md5:  ca4827f073ba93d517522d1c65a6d8f5
23 Source2:        http://home.freeuk.com/cpdrummond/%{name}-Gtk1-%{gtk1_ver}.tar.gz
24 # Source2-md5:  8219f58493ca4e65a8fe61ee76eca522
25 Patch0:         %{name}-amd64.patch
26 Patch1:         kde-am110.patch
27 Patch2:         kde-ac260-lt.patch
28 URL:            http://www.kde-look.org/content/show.php?content=40492
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 %{?with_gtk:BuildRequires:      gtk+-devel}
32 %{?with_gtk2:BuildRequires:     gtk+2-devel}
33 BuildRequires:  kdelibs-devel >= 3.1
34 BuildRequires:  libtool
35 BuildRequires:  pkgconfig
36 BuildRequires:  sed > 4.0
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 A free and corrected port of Red Hat's GTK+/Qt theme.
41
42 %description -l pl.UTF-8
43 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
44
45 %package -n kde-style-QtCurve
46 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
47 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
48 Group:          Themes
49 Requires:       kdelibs >= 3.1
50
51 %description -n kde-style-QtCurve
52 A free and corrected port of Red Hat's GTK+/Qt theme. KDE version.
53
54 %description -n kde-style-QtCurve -l pl.UTF-8
55 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
56 Wersja pod KDE.
57
58 %package -n gtk-theme-QtCurve
59 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
60 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
61 Group:          Themes
62 Requires:       theme-QtCurve-common = %{version}-%{release}
63
64 %description -n gtk-theme-QtCurve
65 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+ version.
66
67 %description -n gtk-theme-QtCurve -l pl.UTF-8
68 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
69 Wersja pod GTK+.
70
71 %package -n gtk2-theme-QtCurve
72 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
73 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
74 Group:          Themes
75 Requires:       theme-QtCurve-common = %{version}-%{release}
76
77 %description -n gtk2-theme-QtCurve
78 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+2 version.
79
80 %description -n gtk2-theme-QtCurve -l pl.UTF-8
81 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
82 Wersja pod GTK+2.
83
84 %package -n theme-QtCurve-common
85 Summary:        A free and corrected port of Redhats GTK+/Qt theme - common
86 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata - common
87 Group:          Themes
88 Obsoletes:      theme-bluecurve-common
89 Obsoletes:      gtk2-theme-bluecurve
90 Obsoletes:      gtk-theme-bluecurve
91 Obsoletes:      kde-style-bluecurve
92 Obsoletes:      kde-theme-bluecurve
93
94 %description -n theme-QtCurve-common
95 A free and corrected port of Red Hat's GTK+/Qt theme.
96 Documentation and common files package.
97
98 %description -n theme-QtCurve-common -l pl.UTF-8
99 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
100 Pakiet z dokumentacja i plikami współdzielonymi.
101
102 %prep
103 %setup -q -c -a1 -a2
104 %patch0 -p1
105 cd %{name}-KDE3-%{kde_ver}
106 %patch1 -p1
107 %patch2 -p1
108
109 %build
110 cd %{name}-KDE3-%{kde_ver}
111 cp /usr/share/automake/config.sub admin
112
113 %{__make} -f admin/Makefile.common cvs
114 %configure \
115         --with-qt-libraries=%{_libdir}
116
117 %{__make}
118 cd -
119
120 %if %{with gtk}
121 cd %{name}-Gtk1-%{gtk1_ver}
122 %{__libtoolize}
123 %{__aclocal}
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure
128 %{__make}
129 cd -
130 %endif
131
132 %if %{with gtk2}
133 cd %{name}-Gtk2-%{gtk2_ver}
134 %{__libtoolize}
135 %{__aclocal}
136 %{__autoconf}
137 %{__autoheader}
138 %{__automake}
139 %configure
140 %{__make}
141 cd -
142 %endif
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 %{__make} -C %{name}-KDE3-%{kde_ver} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 %if %{with gtk}
151 %{__make} -C %{name}-Gtk1-%{gtk1_ver} install \
152         DESTDIR=$RPM_BUILD_ROOT
153 %endif
154
155 %if %{with gtk2}
156 %{__make} -C %{name}-Gtk2-%{gtk2_ver} install \
157         DESTDIR=$RPM_BUILD_ROOT
158 %endif
159
160 rm -f $RPM_BUILD_ROOT{%{_libdir}/gtk/themes/engines,%{_libdir}/gtk-2.0/*/*}/*.la
161
162 %clean
163 rm -rf $RPM_BUILD_ROOT
164
165 %files -n kde-style-QtCurve
166 %defattr(644,root,root,755)
167 %{_libdir}/kde3/kstyle_qtcurve_config.la
168 %attr(755,root,root) %{_libdir}/kde3/kstyle_qtcurve_config.so
169 %{_libdir}/kde3/plugins/styles/*.la
170 %attr(755,root,root) %{_libdir}/kde3/plugins/styles/*.so
171 %{_datadir}/apps/kstyle/themes/qtcurve*.themerc
172 %{_datadir}/apps/qtcurve
173
174 %if %{with gtk}
175 %files -n gtk-theme-QtCurve
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_libdir}/gtk/themes/engines/*.so
178 %{_datadir}/themes/QtCurve/gtk
179 %endif
180
181 %if %{with gtk2}
182 %files -n gtk2-theme-QtCurve
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/gtk-2.0/*/*/*.so
185 %{_datadir}/themes/QtCurve/gtk-2.0
186 %endif
187
188 %files -n theme-QtCurve-common
189 %defattr(644,root,root,755)
190 %doc %{name}-KDE3-%{kde_ver}/{ChangeLog,README,TODO}
191 %dir %{_datadir}/themes/QtCurve
This page took 0.058985 seconds and 2 git commands to generate.