]> git.pld-linux.org Git - packages/PyFileServer.git/blob - PyFileServer.spec
- new spec
[packages/PyFileServer.git] / PyFileServer.spec
1 #
2 # TODO:
3 # - check if PyXML is really required during build
4 #
5 Summary:        A WebDAV server in Python
6 Summary(pl):    Serwer WebDAV napisany w Pythonie
7 Name:           PyFileServer
8 Version:        0.2.1
9 Release:        0.1
10 License:        BSD
11 Group:          Networking/Daemons
12 Source0:        http://download.berlios.de/pyfilesync/PyFileServer-0.2.1.zip
13 # Source0-md5:  7a46d3f94e05d81b4110e6d0780c642b
14 URL:            http://pyfilesync.berlios.de/pyfileserver.html
15 BuildRequires:  python >= 2.3
16 BuildRequires:  unzip
17 %pyrequires_eq  python-modules
18 Requires:       python-PyXML
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 PyFileServer  implements up  to  Class 2  of  the WebDAV  specification,
24 including support  for shared and  exclusive write locking,  and setting
25 arbitrary dead  properties. It also implements  HTTP user authentication
26 using both  basic and digest  schemes, HTTP single range  retrievals and
27 conditional processing headers (If_Match, If_Modified_Since, etc).
28
29 PyFileServer also  allows custom  components to  be developed  easily by
30 having clear interfaces for:
31  - Resource Abstraction Layer
32  - Lock Manager
33  - Property Manager
34  - Domain Controllers
35
36 #description -l pl
37
38 %prep
39 %setup -q -n %{name}
40
41 %build
42 %py_comp pyfileserver/
43 %py_ocomp pyfileserver/
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 install -d $RPM_BUILD_ROOT{%{py_sitescriptdir},%{_bindir}}
49
50 cp -r pyfileserver $RPM_BUILD_ROOT%{py_sitescriptdir}
51 echo "#!/usr/bin/python" > $RPM_BUILD_ROOT%{_bindir}/PyFileServer.py
52 cat ext_wsgiutils_server.py >> $RPM_BUILD_ROOT%{_bindir}/PyFileServer.py
53
54 %py_postclean
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc ADDONS.txt DEVELOPERS.txt PyFileServer-example.conf README.txt 
62 %doc THANKS.txt TODO.txt TUTORIAL.txt
63 %attr(755,root,root) %{_bindir}/*
64 %{py_sitescriptdir}/pyfileserver
This page took 0.03406 seconds and 3 git commands to generate.