]> git.pld-linux.org Git - packages/PyFileServer.git/blame - PyFileServer.spec
- new spec
[packages/PyFileServer.git] / PyFileServer.spec
CommitLineData
d6df6cfb 1#
2# TODO:
3# - check if PyXML is really required during build
4#
5Summary: A WebDAV server in Python
6Summary(pl): Serwer WebDAV napisany w Pythonie
7Name: PyFileServer
8Version: 0.2.1
9Release: 0.1
10License: BSD
11Group: Networking/Daemons
12Source0: http://download.berlios.de/pyfilesync/PyFileServer-0.2.1.zip
13# Source0-md5: 7a46d3f94e05d81b4110e6d0780c642b
14URL: http://pyfilesync.berlios.de/pyfileserver.html
15BuildRequires: python >= 2.3
16BuildRequires: unzip
17%pyrequires_eq python-modules
18Requires: python-PyXML
19BuildArch: noarch
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23PyFileServer implements up to Class 2 of the WebDAV specification,
24including support for shared and exclusive write locking, and setting
25arbitrary dead properties. It also implements HTTP user authentication
26using both basic and digest schemes, HTTP single range retrievals and
27conditional processing headers (If_Match, If_Modified_Since, etc).
28
29PyFileServer also allows custom components to be developed easily by
30having clear interfaces for:
31 - Resource Abstraction Layer
32 - Lock Manager
33 - Property Manager
34 - Domain Controllers
35
36#description -l pl
37
38%prep
39%setup -q -n %{name}
40
41%build
42%py_comp pyfileserver/
43%py_ocomp pyfileserver/
44
45%install
46rm -rf $RPM_BUILD_ROOT
47
48install -d $RPM_BUILD_ROOT{%{py_sitescriptdir},%{_bindir}}
49
50cp -r pyfileserver $RPM_BUILD_ROOT%{py_sitescriptdir}
51echo "#!/usr/bin/python" > $RPM_BUILD_ROOT%{_bindir}/PyFileServer.py
52cat ext_wsgiutils_server.py >> $RPM_BUILD_ROOT%{_bindir}/PyFileServer.py
53
54%py_postclean
55
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59%files
60%defattr(644,root,root,755)
61%doc ADDONS.txt DEVELOPERS.txt PyFileServer-example.conf README.txt
62%doc THANKS.txt TODO.txt TUTORIAL.txt
63%attr(755,root,root) %{_bindir}/*
64%{py_sitescriptdir}/pyfileserver
This page took 0.069024 seconds and 4 git commands to generate.