]> git.pld-linux.org Git - packages/PyCXX.git/blob - PyCXX.spec
- Initial version 6.2.3-1.
[packages/PyCXX.git] / PyCXX.spec
1 # TODO: Find out authors idea behind installing it properly and try implement it
2 # Propably it shoud be library thus not marked as noarch.
3
4 Summary:        Set of classes to help create extensions of Python in the C++ language
5 Summary(pl.UTF-8):      Klasy C++ pomocne przy tworzeniu modułów Pythona
6 Name:           PyCXX
7 Version:        6.2.3
8 Release:        1
9 License:        BSD
10 Group:          Development/Libraries
11 # http://prdownloads.sourceforge.net/cxx/pycxx-6.2.3.tar.gz
12 Source0:        http://downloads.sourceforge.net/cxx/pycxx-%{version}.tar.gz
13 # Source0-md5:  4e545ad225df9c14a3b344b1e6224661
14 URL:            http://cxx.sourceforge.net/
15 BuildRequires:  python-modules
16 Requires:       libstdc++-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 PyCXX is a set of classes to help create extensions of Python in the
21 C++ language. The first part encapsulates the Python C API taking care
22 of exceptions and ref counting. The second part supports the building
23 of Python extension modules in C++.
24
25 %description -l pl.UTF-8
26 PyCXX jest zbiorem klas pomagających tworzorzyć moduły rozszerzeń
27 Pythona w języku C++. Pierwsza część hermetyzuje interfejs C Pythona
28 dbając o wyjątki i zliczanie refrencji. Druga wspiera budowanie
29 modułów rozszerzeń Pythona.
30
31 %prep
32 %setup -q -n pycxx-%{version}
33
34 %build
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38
39 install -d $RPM_BUILD_ROOT%{_includedir}/
40 cp -r CXX $RPM_BUILD_ROOT%{_includedir}/
41 install -d $RPM_BUILD_ROOT%{_includedir}/CXX/Src
42 install Src/IndirectPythonInterface.cxx  $RPM_BUILD_ROOT%{_includedir}/CXX/Src
43 install Src/Python2/*  $RPM_BUILD_ROOT%{_includedir}/CXX/Src
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %defattr(644,root,root,755)
51 %{_includedir}/CXX
This page took 0.048108 seconds and 3 git commands to generate.