]> git.pld-linux.org Git - packages/PyCXX.git/blame - PyCXX.spec
- Initial version 6.2.3-1.
[packages/PyCXX.git] / PyCXX.spec
CommitLineData
bbf2b16f
MK
1# TODO: Find out authors idea behind installing it properly and try implement it
2# Propably it shoud be library thus not marked as noarch.
3
4Summary: Set of classes to help create extensions of Python in the C++ language
5Summary(pl.UTF-8): Klasy C++ pomocne przy tworzeniu modułów Pythona
6Name: PyCXX
7Version: 6.2.3
8Release: 1
9License: BSD
10Group: Development/Libraries
11# http://prdownloads.sourceforge.net/cxx/pycxx-6.2.3.tar.gz
12Source0: http://downloads.sourceforge.net/cxx/pycxx-%{version}.tar.gz
13# Source0-md5: 4e545ad225df9c14a3b344b1e6224661
14URL: http://cxx.sourceforge.net/
15BuildRequires: python-modules
16Requires: libstdc++-devel
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%description
20PyCXX is a set of classes to help create extensions of Python in the
21C++ language. The first part encapsulates the Python C API taking care
22of exceptions and ref counting. The second part supports the building
23of Python extension modules in C++.
24
25%description -l pl.UTF-8
26PyCXX jest zbiorem klas pomagających tworzorzyć moduły rozszerzeń
27Pythona w języku C++. Pierwsza część hermetyzuje interfejs C Pythona
28dbając o wyjątki i zliczanie refrencji. Druga wspiera budowanie
29modułów rozszerzeń Pythona.
30
31%prep
32%setup -q -n pycxx-%{version}
33
34%build
35
36%install
37rm -rf $RPM_BUILD_ROOT
38
39install -d $RPM_BUILD_ROOT%{_includedir}/
40cp -r CXX $RPM_BUILD_ROOT%{_includedir}/
41install -d $RPM_BUILD_ROOT%{_includedir}/CXX/Src
42install Src/IndirectPythonInterface.cxx $RPM_BUILD_ROOT%{_includedir}/CXX/Src
43install Src/Python2/* $RPM_BUILD_ROOT%{_includedir}/CXX/Src
44
45%clean
46rm -rf $RPM_BUILD_ROOT
47
48%files
49%defattr(644,root,root,755)
50%defattr(644,root,root,755)
51%{_includedir}/CXX
This page took 0.079751 seconds and 4 git commands to generate.