]> git.pld-linux.org Git - packages/ParaView.git/blobdiff - ParaView.spec
- fix building with current freetype
[packages/ParaView.git] / ParaView.spec
index 1347c48b1df79cb9ad62fce9b5a87caea7f3e772..fb4af0dc7799e761f74356125e10b0eeae0e5970 100644 (file)
@@ -1,7 +1,11 @@
+#
+# Conditional build:
+%bcond_with    system_protobuf         # build with system protobuf library
+#
 Summary:       Parallel visualization application
 Name:          ParaView
 Version:       4.0.1
-Release:       9
+Release:       13
 License:       BSD
 Group:         Applications/Engineering
 URL:           http://www.paraview.org/
@@ -15,6 +19,7 @@ Patch2:               %{name}-system-Protobuf.patch
 Patch3:                %{name}-system-netcdf.patch
 Patch4:                disable-broken-tests.patch
 Patch5:                protobuf.patch
+Patch6:                freetype.patch
 BuildRequires: Mesa-libOSMesa-devel
 BuildRequires: QtDesigner-devel
 BuildRequires: QtHelp-devel
@@ -40,7 +45,7 @@ BuildRequires:        libtiff-devel
 BuildRequires: netcdf-devel
 BuildRequires: netcdf-cxx-devel
 BuildRequires: openssl-devel
-BuildRequires: protobuf-devel
+%{?with_system_protobuf:BuildRequires: protobuf-devel}
 BuildRequires: python-devel
 BuildRequires: qt4-build
 BuildRequires: readline-devel
@@ -55,6 +60,10 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                skip_post_check_so      lib.*Python.*\.so.*
 
+# avoid provide clash with vtk.spec
+%define                _noautoprov             libvtk.*\.so.* vtk.*\.so.*
+%define                _noautoreq              libvtk.*\.so.* vtk.*\.so.*
+
 %description
 ParaView is an application designed with the need to visualize large
 data sets in mind. The goals of the ParaView project include the
@@ -88,14 +97,19 @@ developing applications that use %{name}.
 %setup -q -n %{name}-v%{version}-source
 %patch0 -p0
 %patch1 -p1
-%patch2 -p1
 %patch3 -p0
 %patch4 -p1
+%patch6 -p1
+
+%if %{with system_protobuf}
+%patch2 -p1
 %patch5 -p1
 #Remove included thirdparty sources just to be sure
 for x in protobuf ; do
        rm -r ThirdParty/$x/vtk$x
 done
+%endif
+
 for x in expat freetype gl2ps hdf5 jpeg libxml2 netcdf oggtheora png sqlite tiff zlib ; do
        rm -r VTK/ThirdParty/$x/vtk$x
 done
@@ -140,6 +154,7 @@ cd build
        -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
        -DVTK_USE_SYSTEM_LIBRARIES=ON \
        -DVTK_USE_SYSTEM_PNG:BOOL=ON \
+       -DVTK_USE_SYSTEM_PROTOBUF:BOOL=%{?with_system_protobuf:ON}%{!?with_system_protobuf:OFF} \
        -DVTK_USE_SYSTEM_TIFF:BOOL=ON \
        -DVTK_USE_SYSTEM_ZLIB:BOOL=ON \
        -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
This page took 0.481025 seconds and 4 git commands to generate.