]> git.pld-linux.org Git - packages/ParaView.git/commitdiff
- fix building with current freetype auto/th/ParaView-4.0.1-13
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 18 Jul 2015 14:35:05 +0000 (14:35 +0000)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 18 Jul 2015 14:35:05 +0000 (14:35 +0000)
- rel 13

ParaView.spec
freetype.patch [new file with mode: 0644]

index e643426bfaa511423c0824615d67c635d7c6158e..fb4af0dc7799e761f74356125e10b0eeae0e5970 100644 (file)
@@ -5,7 +5,7 @@
 Summary:       Parallel visualization application
 Name:          ParaView
 Version:       4.0.1
-Release:       12
+Release:       13
 License:       BSD
 Group:         Applications/Engineering
 URL:           http://www.paraview.org/
@@ -19,6 +19,7 @@ Patch2:               %{name}-system-Protobuf.patch
 Patch3:                %{name}-system-netcdf.patch
 Patch4:                disable-broken-tests.patch
 Patch5:                protobuf.patch
+Patch6:                freetype.patch
 BuildRequires: Mesa-libOSMesa-devel
 BuildRequires: QtDesigner-devel
 BuildRequires: QtHelp-devel
@@ -98,6 +99,7 @@ developing applications that use %{name}.
 %patch1 -p1
 %patch3 -p0
 %patch4 -p1
+%patch6 -p1
 
 %if %{with system_protobuf}
 %patch2 -p1
diff --git a/freetype.patch b/freetype.patch
new file mode 100644 (file)
index 0000000..8ebb711
--- /dev/null
@@ -0,0 +1,22 @@
+--- ParaView-v4.0.1-source/VTK/Rendering/FreeType/vtkFreeTypeTools.cxx.orig    2015-07-18 13:23:54.368978722 +0000
++++ ParaView-v4.0.1-source/VTK/Rendering/FreeType/vtkFreeTypeTools.cxx 2015-07-18 13:23:47.992170735 +0000
+@@ -1165,7 +1165,7 @@
+     if (bitmap)
+       {
+       metaData.ascent = std::max(bitmapGlyph->top - 1, metaData.ascent);
+-      metaData.descent = std::min(-(bitmap->rows - (bitmapGlyph->top - 1)),
++      metaData.descent = std::min(-((int)bitmap->rows - (bitmapGlyph->top - 1)),
+                                   metaData.descent);
+       }
+     ++heightString;
+@@ -1930,8 +1930,8 @@
+     if (bitmap)
+       {
+       bbox[0] = std::min(bbox[0], pen[0] + bitmapGlyph->left);
+-      bbox[1] = std::max(bbox[1], pen[0] + bitmapGlyph->left + bitmap->width);
+-      bbox[2] = std::min(bbox[2], pen[1] + bitmapGlyph->top - 1 - bitmap->rows);
++      bbox[1] = std::max(bbox[1], pen[0] + bitmapGlyph->left + (int)bitmap->width);
++      bbox[2] = std::min(bbox[2], pen[1] + bitmapGlyph->top - 1 - (int)bitmap->rows);
+       bbox[3] = std::max(bbox[3], pen[1] + bitmapGlyph->top - 1);
+       }
+     else
This page took 0.072628 seconds and 4 git commands to generate.