]> git.pld-linux.org Git - packages/ParaView.git/blob - ParaView.spec
- added TODO
[packages/ParaView.git] / ParaView.spec
1 #
2 # Conditional build:
3 %bcond_with     system_protobuf         # build with system protobuf library
4 #
5 Summary:        Parallel visualization application
6 Summary(pl.UTF-8):      Aplikacja do równoległej wizualizacji
7 Name:           ParaView
8 Version:        4.0.1
9 Release:        17
10 License:        BSD
11 Group:          Applications/Engineering
12 Source0:        http://www.paraview.org/files/v4.0/%{name}-v%{version}-source.tgz
13 # Source0-md5:  6a300744eaf32676a3a7e1b42eb642c7
14 Source1:        %{name}_22x22.png
15 Source2:        %{name}.xml
16 Patch0:         %{name}-vtk-use-system-libs.patch
17 Patch1:         %{name}-install.patch
18 Patch2:         %{name}-system-Protobuf.patch
19 Patch3:         %{name}-system-netcdf.patch
20 Patch4:         disable-broken-tests.patch
21 Patch5:         protobuf.patch
22 Patch6:         freetype.patch
23 URL:            http://www.paraview.org/
24 BuildRequires:  Mesa-libOSMesa-devel
25 BuildRequires:  QtDesigner-devel
26 BuildRequires:  QtHelp-devel
27 BuildRequires:  QtSql-devel
28 BuildRequires:  QtSql-sqlite3
29 BuildRequires:  QtUiTools-devel
30 BuildRequires:  QtXmlPatterns-devel
31 BuildRequires:  QtWebKit-devel
32 BuildRequires:  boost-devel
33 BuildRequires:  cmake
34 BuildRequires:  desktop-file-utils
35 BuildRequires:  doxygen
36 BuildRequires:  expat-devel
37 BuildRequires:  freetype-devel
38 BuildRequires:  gl2ps-devel
39 BuildRequires:  gnuplot
40 BuildRequires:  graphviz
41 BuildRequires:  hdf5-devel
42 BuildRequires:  libjpeg-devel
43 BuildRequires:  libpng-devel
44 BuildRequires:  libtheora-devel
45 BuildRequires:  libtiff-devel
46 BuildRequires:  netcdf-devel
47 BuildRequires:  netcdf-cxx-devel
48 BuildRequires:  openssl-devel
49 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
50 BuildRequires:  python-devel
51 BuildRequires:  qt4-build
52 BuildRequires:  readline-devel
53 BuildRequires:  tk-devel
54 BuildRequires:  wget
55 BuildRequires:  zlib-devel
56 Requires(post): desktop-file-utils
57 Requires(postun):       desktop-file-utils
58 Requires:       QtSql-sqlite3
59 %requires_eq_to hdf5 hdf5-devel
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %define         skip_post_check_so      lib.*Python.*\.so.*
63
64 # avoid provide clash with vtk.spec
65 %define         _noautoprov             libvtk.*\.so.* vtk.*\.so.*
66 %define         _noautoreq              libvtk.*\.so.* vtk.*\.so.*
67
68 %description
69 ParaView is an application designed with the need to visualize large
70 data sets in mind. The goals of the ParaView project include the
71 following:
72
73 - Develop an open-source, multi-platform visualization application.
74 - Support distributed computation models to process large data sets.
75 - Create an open, flexible, and intuitive user interface.
76 - Develop an extensible architecture based on open standards.
77
78 ParaView runs on distributed and shared memory parallel as well as
79 single processor systems and has been successfully tested on Windows,
80 Linux and various Unix workstations and clusters. Under the hood,
81 ParaView uses the Visualization Toolkit as the data processing and
82 rendering engine and has a user interface written using a unique blend
83 of Tcl/Tk and C++.
84
85 NOTE: The version in this package has NOT been compiled with MPI
86 support.
87
88 %description -l pl.UTF-8
89 ParaView to aplikacja zaprojektowana z myślą o potrzebie wizualizacji
90 dużych zbiorów danych. Cele projektu ParaView obejmują:
91 - rozwijanie mającej otwarte źródła, wieloplatformowej aplikacji do
92   wizualizacji
93 - obsługę rozproszonych modeli obliczeń do przetwarzania dużych
94   zbiorów danych
95 - stworzenie otwartego, elastycznego i intuicyjnego interfejsu
96   użytkownika
97 - rozwijanie rozszerzalnej architektury opartej na otwartych
98   standardach
99
100 ParaView działa równolegle z rozproszoną i współdzieloną pamięcią, jak
101 i na systemach z jednym procesorem; został przetestowany na systemach
102 Windows, Linux, różnych uniksowych stacjach roboczych i klastrach.
103 Wewnętrznie ParaView wykorzystuje VTK (Visualization Toolkit) jako
104 silnik przetwarzania danych i renderowania oraz interfejs użytkownika
105 wykorzystujący unikalne połączenie Tcl/Tk oraz C++.
106
107 Uwaga: ta wersja pakietu została skompilowana bez obsługi MPI.
108
109 %package devel
110 Summary:        Development files for ParaView
111 Summary(pl.UTF-8):      Pliki programistyczne ParaView
112 Group:          Development/Libraries
113 Requires:       %{name} = %{version}-%{release}
114
115 %description devel
116 This package contains the header files for developing applications
117 that use ParaView.
118
119 %description devel -l pl.UTF-8
120 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
121 wykorzystujących ParaView.
122
123 %prep
124 %setup -q -n %{name}-v%{version}-source
125 %patch0 -p0
126 %patch1 -p1
127 %patch3 -p0
128 %patch4 -p1
129 %patch6 -p1
130
131 %if %{with system_protobuf}
132 %patch2 -p1
133 %patch5 -p1
134 #Remove included thirdparty sources just to be sure
135 for x in protobuf ; do
136         %{__rm} -r ThirdParty/$x/vtk$x
137 done
138 %endif
139
140 for x in expat freetype gl2ps hdf5 jpeg libxml2 netcdf oggtheora png sqlite tiff zlib ; do
141         %{__rm} -r VTK/ThirdParty/$x/vtk$x
142 done
143
144 %{__rm} -r ParaViewCore/ServerImplementation/Default/Testing
145
146 %build
147 rm -rf build
148 mkdir build
149 cd build
150 %cmake .. \
151         -DCMAKE_BUILD_TYPE=RelWithDebInfo \
152         -DCMAKE_CXX_COMPILER:FILEPATH=%{__cxx} \
153         -DCMAKE_C_COMPILER:FILEPATH=%{__cc} \
154         -DPV_INSTALL_INCLUDE_DIR:PATH=include/paraview \
155         -DPV_INSTALL_LIBRARY_DIR:PATH=%{_lib}/paraview \
156         -DTCL_LIBRARY:PATH=tcl \
157         -DTK_LIBRARY:PATH=tk \
158         -DPARAVIEW_BUILD_PLUGIN_AdiosReader:BOOL=ON \
159         -DPARAVIEW_BUILD_PLUGIN_CoProcessingScriptGenerator:BOOL=ON \
160         -DPARAVIEW_BUILD_PLUGIN_EyeDomeLighting:BOOL=ON \
161         -DPARAVIEW_BUILD_PLUGIN_ForceTime:BOOL=ON \
162         -DPARAVIEW_ENABLE_PYTHON:BOOL=ON \
163         -DPARAVIEW_INSTALL_THIRD_PARTY_LIBRARIES:BOOL=OFF \
164         -DPARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON \
165         -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/paraview \
166         -DVTK_INSTALL_INCLUDE_DIR:PATH=include/paraview \
167         -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/paraview \
168         -DVTK_INSTALL_PACKAGE_DIR=share/cmake/paraview \
169         -DVTK_USE_BOOST:BOOL=ON \
170         -DVTK_USE_INFOVIS:BOOL=OFF \
171         -DVTK_USE_N_WAY_ARRAYS:BOOL=ON \
172         -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
173         -DVTK_USE_SYSTEM_EXPAT:BOOL=ON \
174         -DVTK_USE_SYSTEM_FREETYPE:BOOL=ON \
175         -DFREETYPE_INCLUDE_DIRS=%{_includedir}/freetype2 \
176         -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
177         -DVTK_USE_SYSTEM_HDF5=ON \
178         -DHDF5_HL_LIBRARY:FILEPATH=%{_libdir}/libhdf5_hl.so \
179         -DVTK_USE_SYSTEM_JPEG:BOOL=ON \
180         -DVTK_USE_SYSTEM_LIBPROJ4=OFF \
181         -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
182         -DVTK_USE_SYSTEM_LIBRARIES=ON \
183         -DVTK_USE_SYSTEM_PNG:BOOL=ON \
184         -DVTK_USE_SYSTEM_PROTOBUF:BOOL=%{?with_system_protobuf:ON}%{!?with_system_protobuf:OFF} \
185         -DVTK_USE_SYSTEM_TIFF:BOOL=ON \
186         -DVTK_USE_SYSTEM_ZLIB:BOOL=ON \
187         -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
188         -DVTK_USE_INFOVIS:BOOL=OFF \
189         -DVTK_USE_SYSTEM_ICET=OFF \
190         -DVTK_USE_SYSTEM_NETCDF=ON \
191         -DVTK_USE_SYSTEM_QTTESTING=OFF \
192         -DVTK_USE_SYSTEM_XDMF2=OFF \
193         -DXDMF_WRAP_PYTHON:BOOL=ON \
194         -DBUILD_DOCUMENTATION:BOOL=ON \
195         -DBUILD_EXAMPLES:BOOL=ON
196
197 # -DVTK_PYTHON_SETUP_ARGS="--prefix=/usr --root=$RPM_BUILD_ROOT" \
198
199 %{__make} VERBOSE=1
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_datadir}/mime/packages}
204
205 install %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}
206 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/mime/packages
207
208 %{__make} -C build install \
209         DESTDIR=$RPM_BUILD_ROOT
210
211 #Create desktop file
212 cat > $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop <<EOF
213 [Desktop Entry]
214 Encoding=UTF-8
215 Name=ParaView Viewer
216 GenericName=Data Viewer
217 Comment=ParaView allows viewing of large data sets
218 Type=Application
219 Terminal=false
220 Icon=ParaView_22x22
221 MimeType=application/x-paraview;
222 Categories=Application;Graphics;
223 Exec=paraview
224 EOF
225
226 # Move python files by hand for now
227 %{__mv} $RPM_BUILD_ROOT%{_bindir}/Python/vtk $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/
228 %{__rm} -r $RPM_BUILD_ROOT%{_bindir}/Python
229
230 # Install vtk*Python.so by hand for now
231 %{__mv} $RPM_BUILD_ROOT%{_libdir}/paraview/vtk*Python.so $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/vtk/
232 %{__mv} $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/vtk/vtkPV*Python.so $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/
233
234 # Cleanup vtk conflicting binaries
235 %{__rm} $RPM_BUILD_ROOT%{_bindir}/vtk{EncodeString,HashSource,Parse{Java,OGLExt},ProcessShader,Wrap{Hierarchy,Java,Python,Tcl,TclInit,PythonInit}}
236
237 %{__rm} $RPM_BUILD_ROOT%{_libdir}/paraview/lib*.a
238
239 %clean
240 rm -rf $RPM_BUILD_ROOT
241
242 %post
243 /sbin/ldconfig
244 %update_desktop_database
245 %update_mime_database
246
247 %postun
248 /sbin/ldconfig
249 %update_desktop_database
250 %update_mime_database
251
252 %files
253 %defattr(644,root,root,755)
254 %doc License_v1.2.txt
255 %attr(755,root,root) %{_bindir}/paraview
256 %attr(755,root,root) %{_bindir}/pvbatch
257 %attr(755,root,root) %{_bindir}/pvdataserver
258 %attr(755,root,root) %{_bindir}/pvpython
259 %attr(755,root,root) %{_bindir}/pvrenderserver
260 %attr(755,root,root) %{_bindir}/pvserver
261 %attr(755,root,root) %{_bindir}/smTestDriver
262 %dir %{_libdir}/paraview
263 %attr(755,root,root) %{_libdir}/paraview/paraview
264 %attr(755,root,root) %{_libdir}/paraview/pvbatch
265 %attr(755,root,root) %{_libdir}/paraview/pvdataserver
266 %attr(755,root,root) %{_libdir}/paraview/pvpython
267 %attr(755,root,root) %{_libdir}/paraview/pvrenderserver
268 %attr(755,root,root) %{_libdir}/paraview/pvserver
269 %attr(755,root,root) %{_libdir}/paraview/smTestDriver
270 %attr(755,root,root) %{_libdir}/paraview/lib*.so*
271 %{_libdir}/paraview/.plugins
272 %dir %{_libdir}/paraview/site-packages
273 %{_libdir}/paraview/site-packages/autobahn
274 %dir %{_libdir}/paraview/site-packages/paraview
275 %{_libdir}/paraview/site-packages/paraview/pv_compile_complete
276 %{_libdir}/paraview/site-packages/paraview/*.py*
277 %attr(755,root,root) %{_libdir}/paraview/site-packages/paraview/*.so
278 %{_libdir}/paraview/site-packages/paraview/demos
279 %{_libdir}/paraview/site-packages/paraview/vtk
280 %{_libdir}/paraview/site-packages/twisted
281 %dir %{_libdir}/paraview/site-packages/vtk
282 %{_libdir}/paraview/site-packages/vtk/*.py*
283 %dir %{_libdir}/paraview/site-packages/vtk/gtk
284 %{_libdir}/paraview/site-packages/vtk/gtk/*.py*
285 %dir %{_libdir}/paraview/site-packages/vtk/qt4
286 %{_libdir}/paraview/site-packages/vtk/qt4/*.py*
287 %dir %{_libdir}/paraview/site-packages/vtk/test
288 %{_libdir}/paraview/site-packages/vtk/test/*.py*
289 %dir %{_libdir}/paraview/site-packages/vtk/tk
290 %{_libdir}/paraview/site-packages/vtk/tk/*.py*
291 %dir %{_libdir}/paraview/site-packages/vtk/util
292 %{_libdir}/paraview/site-packages/vtk/util/*.py*
293 %dir %{_libdir}/paraview/site-packages/vtk/wx
294 %{_libdir}/paraview/site-packages/vtk/wx/*.py*
295 %{_libdir}/paraview/site-packages/zope
296 %{_libdir}/paraview/www
297 %{_desktopdir}/ParaView.desktop
298 %{_pixmapsdir}/ParaView_22x22.png
299 %{_datadir}/mime/packages/ParaView.xml
300 %dir %{_datadir}/doc/paraview-4.0
301 %{_datadir}/doc/paraview-4.0/paraview.qch
302
303 %files devel
304 %defattr(644,root,root,755)
305 %attr(755,root,root) %{_bindir}/vtkkwProcessXML
306 %attr(755,root,root) %{_bindir}/vtkWrapClientServer
307 %{_includedir}/paraview
308 %{_datadir}/cmake/paraview
This page took 0.140986 seconds and 3 git commands to generate.