]> git.pld-linux.org Git - packages/ParaView.git/blob - ParaView.spec
- updated BR
[packages/ParaView.git] / ParaView.spec
1 Summary:        Parallel visualization application
2 Name:           ParaView
3 Version:        3.12.0
4 Release:        0.1
5 License:        BSD
6 Group:          Applications/Engineering
7 URL:            http://www.paraview.org/
8 Source0:        http://www.paraview.org/files/v3.12/%{name}-%{version}.tar.gz
9 # Source0-md5:  8feabc6261e2060648eaac593d85b1de
10 Source1:        %{name}_22x22.png
11 Source2:        %{name}.xml
12 Patch0:         %{name}-3.8.0-include.patch
13 Patch1:         %{name}-3.12.0-boost-1.48.0-bfs.patch
14 Patch2:         %{name}-gcc47.patch
15 Patch3:         %{name}-3.2.2-hdf5.patch
16 BuildRequires:  Mesa-libOSMesa-devel
17 BuildRequires:  QtDesigner-devel
18 BuildRequires:  QtHelp-devel
19 BuildRequires:  QtSql-devel
20 BuildRequires:  QtSql-sqlite
21 BuildRequires:  QtUiTools-devel
22 BuildRequires:  QtWebKit-devel
23 BuildRequires:  boost-devel
24 BuildRequires:  cmake
25 BuildRequires:  desktop-file-utils
26 BuildRequires:  doxygen
27 BuildRequires:  expat-devel
28 BuildRequires:  freetype-devel
29 BuildRequires:  gnuplot
30 BuildRequires:  graphviz
31 BuildRequires:  hdf5-devel
32 BuildRequires:  libjpeg-devel
33 BuildRequires:  libpng-devel
34 BuildRequires:  libtheora-devel
35 BuildRequires:  libtiff-devel
36 BuildRequires:  openssl-devel
37 BuildRequires:  python-devel
38 BuildRequires:  qt4-build
39 BuildRequires:  readline-devel
40 BuildRequires:  tk-devel
41 BuildRequires:  wget
42 BuildRequires:  zlib-devel
43 Requires:       %{name}-data = %{version}-%{release}
44 Requires:       %{name}-doc = %{version}-%{release}
45 Requires(post): desktop-file-utils
46 Requires(postun):       desktop-file-utils
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 ParaView is an application designed with the need to visualize large
51 data sets in mind. The goals of the ParaView project include the
52 following:
53
54     - Develop an open-source, multi-platform visualization application.
55     - Support distributed computation models to process large data sets.
56     - Create an open, flexible, and intuitive user interface.
57     - Develop an extensible architecture based on open standards.
58
59 ParaView runs on distributed and shared memory parallel as well as
60 single processor systems and has been successfully tested on Windows,
61 Linux and various Unix workstations and clusters. Under the hood,
62 ParaView uses the Visualization Toolkit as the data processing and
63 rendering engine and has a user interface written using a unique blend
64 of Tcl/Tk and C++.
65
66 NOTE: The version in this package has NOT been compiled with MPI
67 support.
68
69 %package        data
70 Summary:        Data files for ParaView
71 Group:          Applications/Engineering
72 Requires:       %{name} = %{version}-%{release}
73 BuildArch:      noarch
74
75 %description    data
76 Data files for ParaView.
77
78 %package        devel
79 Summary:        Development files for %{name}
80 Group:          Development/Libraries
81 Requires:       %{name}%{?_isa} = %{version}-%{release}
82
83 %description    devel
84 The %{name}-devel package contains libraries and header files for
85 developing applications that use %{name}.
86
87 %package        doc
88 Summary:        Documentation files for ParaView
89 Group:          Applications/Engineering
90 Requires:       %{name} = %{version}-%{release}
91 BuildArch:      noarch
92
93 %description    doc
94 Documentation files for ParaView.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 # We don't have boot 1.48 yet
100 #%patch1 -p1
101 %patch2 -p1
102 %patch3 -p1
103 #Remove included hdf5 just to be sure
104 rm -r VTK/Utilities/vtkhdf5
105
106 %build
107 mkdir build
108 cd build
109 %cmake .. \
110         -DPV_INSTALL_INCLUDE_DIR:PATH=include/paraview \
111         -DPV_INSTALL_LIB_DIR:PATH=%{_lib}/paraview \
112         -DTCL_LIBRARY:PATH=tcl \
113         -DTK_LIBRARY:PATH=tk \
114         -DPARAVIEW_BUILD_PLUGIN_AdiosReader:BOOL=ON \
115         -DPARAVIEW_BUILD_PLUGIN_CoProcessingScriptGenerator:BOOL=ON \
116         -DPARAVIEW_BUILD_PLUGIN_EyeDomeLighting:BOOL=ON \
117         -DPARAVIEW_BUILD_PLUGIN_ForceTime:BOOL=ON \
118         -DPARAVIEW_ENABLE_PYTHON:BOOL=ON \
119         -DPARAVIEW_INSTALL_THIRD_PARTY_LIBRARIES:BOOL=OFF \
120         -DPARAVIEW_INSTALL_DEVELOPMENT:BOOL=ON \
121         -DVTK_OPENGL_HAS_OSMESA:BOOL=ON \
122         -DVTK_USE_BOOST:BOOL=ON \
123         -DVTK_USE_INFOVIS:BOOL=OFF \
124         -DVTK_USE_N_WAY_ARRAYS:BOOL=ON \
125         -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
126         -DVTK_USE_SYSTEM_EXPAT:BOOL=ON \
127         -DVTK_USE_SYSTEM_FREETYPE:BOOL=ON \
128         -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
129         -DVTK_USE_SYSTEM_JPEG:BOOL=ON \
130         -DVTK_USE_SYSTEM_PNG:BOOL=ON \
131         -DVTK_USE_SYSTEM_TIFF:BOOL=ON \
132         -DVTK_USE_SYSTEM_ZLIB:BOOL=ON \
133         -DXDMF_WRAP_PYTHON:BOOL=ON \
134         -DBUILD_DOCUMENTATION:BOOL=ON \
135         -DBUILD_EXAMPLES:BOOL=ON
136
137 %{__make} VERBOSE=1
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 install -d $RPM_BUILD_ROOT%{_desktopdir}
142 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
143 install -d $RPM_BUILD_ROOT%{_datadir}/mime/packages
144
145 install %SOURCE1 $RPM_BUILD_ROOT%{_pixmapsdir}
146 install %SOURCE2 $RPM_BUILD_ROOT%{_datadir}/mime/packages
147
148 cd build
149 %{__make} install \
150         DESTDIR=$RPM_BUILD_ROOT
151
152 #Create desktop file
153 cat > $RPM_BUILD_ROOT%{_desktopdir}/paraview.desktop <<EOF
154 [Desktop Entry]
155 Encoding=UTF-8
156 Name=ParaView Viewer
157 GenericName=Data Viewer
158 Comment=ParaView allows viewing of large data sets
159 Type=Application
160 Terminal=false
161 Icon=paraview_22x22
162 MimeType=application/x-paraview;
163 Categories=Application;Graphics;
164 Exec=paraview
165 EOF
166
167 #Install vtk*Python.so by hand for now
168 cp -p bin/vtk*Python.so $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/vtk/
169 mv $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/vtk/vtkPV*Python.so $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/
170
171 #Cleanup vtk binaries
172 rm $RPM_BUILD_ROOT%{_bindir}/vtk*
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post
178 /sbin/ldconfig
179 %update_desktop_database
180
181 %postun
182 /sbin/ldconfig
183 %update_desktop_database
184
185 %post data
186 %update_mime_database
187
188 %postun data
189 %update_mime_database
190
191 %files
192 %defattr(644,root,root,755)
193 %doc License_v1.2.txt
194 %attr(755,root,root) %{_bindir}/paraview
195 %attr(755,root,root) %{_bindir}/pvbatch
196 %attr(755,root,root) %{_bindir}/pvblot
197 %attr(755,root,root) %{_bindir}/pvdataserver
198 %attr(755,root,root) %{_bindir}/pvpython
199 %attr(755,root,root) %{_bindir}/pvrenderserver
200 %attr(755,root,root) %{_bindir}/pvserver
201 %attr(755,root,root) %{_bindir}/smTestDriver
202 %{_libdir}/paraview/
203
204 %files data
205 %defattr(644,root,root,755)
206 %{_desktopdir}/fedora-paraview.desktop
207 %{_pixmapsdir}/paraview_22x22.png
208 %{_datadir}/mime/packages/paraview.xml
209
210 %files devel
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_bindir}/kwProcessXML
213 %{_includedir}/paraview/
This page took 0.03737 seconds and 3 git commands to generate.