]> git.pld-linux.org Git - packages/PackageKit.git/blob - PackageKit.spec
Updated to 1.2.4
[packages/PackageKit.git] / PackageKit.spec
1 # TODO:
2 # - BASH command-not-found functionality disabled for now as it needs patched bash
3 #   (details in bash from Fedora Rawhide)
4 #
5 # Conditional build:
6 %bcond_without  apidocs         # API documentation
7 %bcond_without  introspection   # gobject introspection, time to time broken
8 %bcond_without  static_libs     # static library
9 %bcond_without  python          # Python binding (used by entropy and portage backends)
10 %bcond_without  vala            # Vala binding
11 # backends
12 %bcond_with     alpm            # ALPM (Arch Linux package manager) backend
13 %bcond_with     apt             # APT (Debian/Ubuntu) backend using C++ API
14 %bcond_with     dnf             # DNF (Fedora/RHEL/Mageia/OpenMandriva/OpenSUSE/Rosa) backend
15 %bcond_with     entropy         # Entropy (Sabayon) backend (Python)
16 %bcond_with     nix             # Nix (NixOS) backend [broken as of 1.2.0]
17 %bcond_without  poldek          # Poldek (PLD) backend
18 %bcond_with     portage         # portage (Gentoo) backend (Python)
19 %bcond_with     slack           # Slack (Slackware) backend
20 %bcond_with     zypp            # ZYPP (openSUSE/SLE) backend [broken as of 1.2.0]
21
22 %if %{without python}
23 %undefine       with_entropy
24 %undefine       with_portage
25 %endif
26
27 Summary:        System daemon that is a D-Bus abstraction layer for package management
28 Summary(pl.UTF-8):      Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
29 Name:           PackageKit
30 Version:        1.2.4
31 Release:        1
32 License:        GPL v2+
33 Group:          Applications/System
34 Source0:        https://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
35 # Source0-md5:  faeb2ba3340cb3c86776ba8bba5f0361
36 Patch0:         %{name}-poldek.patch
37 Patch2:         %{name}-meson.patch
38 Patch3:         consolekit-fallback.patch
39 URL:            https://www.freedesktop.org/software/PackageKit/
40 %{?with_apt:BuildRequires:      AppStream-devel >= 0.12}
41 BuildRequires:  NetworkManager-devel >= 0.6.5
42 # pkgconfig(libalpm) >= 12.0.0
43 %{?with_alpm:BuildRequires:     alpm-devel >= 5.2}
44 %{?with_dnf:BuildRequires:      appstream-glib-devel}
45 %{?with_apt:BuildRequires:      apt-devel >= 1.9.2}
46 BuildRequires:  bash-completion-devel >= 2.0
47 BuildRequires:  connman-devel
48 %{?with_slack:BuildRequires:    curl-devel}
49 BuildRequires:  dbus-devel >= 1.2.0
50 BuildRequires:  dbus-glib-devel >= 0.76
51 BuildRequires:  docbook-dtd412-xml
52 BuildRequires:  docbook-dtd42-xml
53 BuildRequires:  fontconfig-devel
54 BuildRequires:  gettext-tools
55 BuildRequires:  glib2-devel >= 1:2.54.0
56 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.9.9}
57 BuildRequires:  gstreamer-devel >= 1.0.0
58 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
59 BuildRequires:  gtk+3-devel >= 3.0.0
60 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.11}
61 BuildRequires:  libarchive-devel
62 %{?with_dnf:BuildRequires:      libdnf-devel >= 0.43.1}
63 %if %{with apt} || %{with nix}
64 BuildRequires:  libstdc++-devel >= 6:4.7
65 %endif
66 %{?with_slack:BuildRequires:    libstdc++-devel >= 6:5}
67 BuildRequires:  libxslt-progs
68 %{?with_zypp:BuildRequires:     libzypp-devel >= 15}
69 BuildRequires:  meson >= 0.50
70 BuildRequires:  ninja >= 1.5
71 # nix-expr nix-main nix-store
72 %{?with_nix:BuildRequires:      nix-devel >= 1.12}
73 BuildRequires:  pango-devel
74 BuildRequires:  pkgconfig
75 # just to detect which reboot modes to use (library not linked)
76 #BuildRequires: plymouth-devel >= 0.9.5
77 %{?with_poldek:BuildRequires:   poldek-devel >= 0.30-1.rc6.4}
78 BuildRequires:  polkit-devel >= 0.114
79 # or 1:3.2
80 %{?with_python:BuildRequires:   python-devel >= 1:2.7}
81 BuildRequires:  readline-devel
82 BuildRequires:  rpm-build >= 4.6
83 %{?with_dnf:BuildRequires:      rpm-devel >= 1:4.6}
84 BuildRequires:  rpm-pythonprov
85 BuildRequires:  rpmbuild(macros) >= 1.736
86 BuildRequires:  sed >= 4.0
87 BuildRequires:  sqlite3-devel >= 3
88 BuildRequires:  systemd-devel >= 1:213
89 BuildRequires:  tar >= 1:1.22
90 BuildRequires:  udev-glib-devel
91 %{?with_vala:BuildRequires:     vala >= 2:0.16}
92 BuildRequires:  xz
93 Requires(post,postun):  shared-mime-info
94 Requires:       %{name}-backend
95 Requires:       %{name}-libs = %{version}-%{release}
96 Requires:       crondaemon
97 Requires:       polkit >= 0.114
98 Suggests:       ConsoleKit-x11
99 Obsoletes:      PackageKit-backend-pisi < 1.2
100 Obsoletes:      PackageKit-backend-ports < 1.2
101 Obsoletes:      PackageKit-backend-smart < 1.0
102 Obsoletes:      PackageKit-backend-urpmi < 1.2
103 Obsoletes:      PackageKit-backend-yum < 1.2
104 Obsoletes:      PackageKit-docs < 0.8.4
105 Obsoletes:      pm-utils-packagekit < 0.8.15
106 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108 %description
109 PackageKit is a D-Bus abstraction layer that allows the session user
110 to manage packages in a secure way using a cross-distro,
111 cross-architecture API.
112
113 %description -l pl.UTF-8
114 PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
115 sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
116 zgodnego z wieloma dystrybucjami i architekturami.
117
118 %package libs
119 Summary:        packagekit-glib library
120 Summary(pl.UTF-8):      Biblioteka packagekit-glib
121 Group:          Libraries
122 Requires:       glib2 >= 1:2.54.0
123 Obsoletes:      browser-plugin-packagekit < 1.1.0
124
125 %description libs
126 packagekit-glib library.
127
128 %description libs -l pl.UTF-8
129 Biblioteka packagekit-glib.
130
131 %package devel
132 Summary:        Header files for packagekit-glib library
133 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki packagekit-glib
134 Group:          Development/Libraries
135 Requires:       %{name}-libs = %{version}-%{release}
136 Requires:       dbus-devel >= 1.2.0
137 Requires:       glib2-devel >= 1:2.54.0
138 Requires:       sqlite3-devel
139
140 %description devel
141 Header files for packagekit-glib library.
142
143 %description devel -l pl.UTF-8
144 Pliki nagłówkowe biblioteki packagekit-glib.
145
146 %package static
147 Summary:        Static packagekit-glib library
148 Summary(pl.UTF-8):      Statyczna biblioteka packagekit-glib
149 Group:          Development/Libraries
150 Requires:       %{name}-devel = %{version}-%{release}
151
152 %description static
153 Static packagekit-glib library.
154
155 %description static -l pl.UTF-8
156 Statyczna biblioteka packagekit-glib.
157
158 %package -n vala-packagekit
159 Summary:        Vala API for PackageKit library
160 Summary(pl.UTF-8):      API języka Vala do biblioteki PackageKitu
161 Group:          Development/Libraries
162 Requires:       %{name}-devel = %{version}-%{release}
163 Requires:       vala >= 2:0.16
164 BuildArch:      noarch
165
166 %description -n vala-packagekit
167 Vala API for PackageKit library.
168
169 %description -n vala-packagekit -l pl.UTF-8
170 API języka Vala do biblioteki PackageKitu.
171
172 %package apidocs
173 Summary:        PackageKit library API documentation
174 Summary(pl.UTF-8):      Dokumentacja API biblioteki PackageKit
175 Group:          Documentation
176 Requires:       gtk-doc-common
177 BuildArch:      noarch
178
179 %description apidocs
180 PackageKit library API documentation.
181
182 %description apidocs -l pl.UTF-8
183 Dokumentacja API biblioteki PackageKit.
184
185 %package backend-alpm
186 Summary:        PackageKit ALPM backend
187 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece ALPM
188 Group:          Libraries
189 Requires:       %{name} = %{version}-%{release}
190 Provides:       %{name}-backend = %{version}-%{release}
191
192 %description backend-alpm
193 A backend for PackageKit to enable Arch Linux packages via ALPM
194 library.
195
196 %description backend-alpm -l pl.UTF-8
197 Backend PackageKit dodający obsługę pakietów Arch Linuksa poprzez
198 bibliotekę ALPM.
199
200 %package backend-aptcc
201 Summary:        PackageKit APTcc backend
202 Summary(pl.UTF-8):      Backend PackageKit APTcc
203 Group:          Libraries
204 Requires:       %{name} = %{version}-%{release}
205 Requires:       AppStream >= 0.12
206 Requires:       apt >= 1.9.2
207 Provides:       %{name}-backend = %{version}-%{release}
208
209 %description backend-aptcc
210 A backend for PackageKit to enable APT support via C++ API.
211
212 %description backend-aptcc -l pl.UTF-8
213 Backend PackageKit dodający obsługę zarządcy pakietów APT poprzez API
214 C++.
215
216 %package backend-dnf
217 Summary:        PackageKit dnf backend
218 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece dnfhif
219 Group:          Libraries
220 Requires:       %{name} = %{version}-%{release}
221 Requires:       libdnf >= 0.43.1
222 Requires:       rpm >= 1:4.6
223 Provides:       %{name}-backend = %{version}-%{release}
224 Obsoletes:      PackageKit-backend-hawkey < 1.0
225 Obsoletes:      PackageKit-backend-hif < 1.2
226
227 %description backend-dnf
228 A backend for PackageKit to enable RPM packages support via dnf
229 library (used in Fedora).
230
231 %description backend-dnf -l pl.UTF-8
232 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
233 dnf (używaną w dystrybucji Fedora).
234
235 %package backend-entropy
236 Summary:        PackageKit Entropy backend
237 Summary(pl.UTF-8):      Backend PackageKit Entropy
238 Group:          Libraries
239 Requires:       %{name} = %{version}-%{release}
240 Requires:       python-packagekit = %{version}-%{release}
241 #Requires:      python-entropy
242 Provides:       %{name}-backend = %{version}-%{release}
243
244 %description backend-entropy
245 A backend for PackageKit to enable Sabayon packages support through
246 Entropy package manager.
247
248 %description backend-entropy -l pl.UTF-8
249 Backend PackageKit dodający obsługę pakietów dystrybucji Sabayon przy
250 użyciu zarządcy pakietów Entropy.
251
252 %package backend-nix
253 Summary:        PackageKit Nix backend
254 Summary(pl.UTF-8):      Backend PackageKit oparty na zarządcy pakietów Nix
255 Group:          Libraries
256 Requires:       %{name} = %{version}-%{release}
257 Requires:       nix >= 1.12
258 Provides:       %{name}-backend = %{version}-%{release}
259
260 %description backend-nix
261 A backend for PackageKit to enable Nix packages support (used in
262 NixOS).
263
264 %description backend-nix -l pl.UTF-8
265 Backend PackageKit dodający obsługę pakietów Nix (używanych w NixOS).
266
267 %package backend-poldek
268 Summary:        PackageKit Poldek backend
269 Summary(pl.UTF-8):      Backend PackageKit oparty na Poldku
270 Group:          Libraries
271 Requires:       %{name} = %{version}-%{release}
272 Requires:       poldek >= 0.30-1.rc6.4
273 Provides:       %{name}-backend = %{version}-%{release}
274
275 %description backend-poldek
276 A backend for PackageKit to enable RPM packages support through Poldek
277 - native PLD package manager.
278
279 %description backend-poldek -l pl.UTF-8
280 Backend PackageKit dodający obsługę pakietów RPM poprzez Poldka -
281 natywnego zarządcę pakietów dystrybucji PLD.
282
283 %package backend-portage
284 Summary:        PackageKit Portage backend
285 Summary(pl.UTF-8):      Backend PackageKit Portage
286 Group:          Libraries
287 Requires:       %{name} = %{version}-%{release}
288 Requires:       python-packagekit = %{version}-%{release}
289 #Requires:      python-portage
290 Provides:       %{name}-backend = %{version}-%{release}
291
292 %description backend-portage
293 A backend for PackageKit to enable Gentoo Portage support.
294
295 %description backend-portage -l pl.UTF-8
296 Backend PackageKit dodający obsługę systemu Portage dystrybucji
297 Gentoo.
298
299 %package backend-slack
300 Summary:        PackageKit Slack backend
301 Summary(pl.UTF-8):      Backend PackageKit Slack
302 Group:          Libraries
303 Requires:       %{name} = %{version}-%{release}
304 Provides:       %{name}-backend = %{version}-%{release}
305 Obsoletes:      PackageKit-backend-katja < 1.2
306
307 %description backend-slack
308 Slack backend for PackageKit to enable Slackware repositories support.
309
310 %description backend-slack -l pl.UTF-8
311 Backend PackageKit Slack dodający obsługę repozytoriów Slackware.
312
313 %package backend-zypp
314 Summary:        PackageKit Zypp backend
315 Summary(pl.UTF-8):      Backend PackageKit Zypp
316 Group:          Libraries
317 Requires:       %{name} = %{version}-%{release}
318 Requires:       libzypp >= 15
319 Provides:       %{name}-backend = %{version}-%{release}
320
321 %description backend-zypp
322 A backend for PackageKit to enable RPM packages support through Zypp
323 library (originated in openSUSE/SLE).
324
325 %description backend-zypp -l pl.UTF-8
326 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
327 Zypp (pochodzącą z dystrybucji openSUSE/SLE).
328
329 %package gstreamer-plugin
330 Summary:        GStreamer codecs installer
331 Summary(pl.UTF-8):      Instalator kodeków GStreamera
332 Group:          Applications
333 Requires:       %{name} = %{version}-%{release}
334 Requires:       %{name}-gtk3-module = %{version}-%{release}
335
336 %description gstreamer-plugin
337 The PackageKit GStreamer plugin allows any GStreamer application to
338 install codecs from configured repositories using PackageKit.
339
340 %description gstreamer-plugin -l pl.UTF-8
341 Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
342 zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
343
344 %package gtk3-module
345 Summary:        GTK+ 3.x module to detect and install missing fonts
346 Summary(pl.UTF-8):      Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
347 Group:          X11/Libraries
348 Obsoletes:      PackageKit-gtk-module < 1.2.0
349
350 %description gtk3-module
351 The PackageKit GTK+ 3.x module allows any pango application to install
352 missing fonts from configured repositories using PackageKit.
353
354 %description gtk3-module -l pl.UTF-8
355 Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
356 brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
357
358 %package -n bash-completion-packagekit
359 Summary:        Bash completion for PackageKit console commands
360 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń konsolowych PackageKit
361 Group:          Applications/Shells
362 Requires:       %{name} = %{version}-%{release}
363 Requires:       bash-completion >= 2
364 BuildArch:      noarch
365
366 %description -n bash-completion-packagekit
367 This package provides bash-completion for PackageKit console commands.
368
369 %description -n bash-completion-packagekit -l pl.UTF-8
370 Pakiet ten dostarcza bashowe uzupełnianie parametrów dla poleceń
371 konsolowych PackageKit.
372
373 %package -n python-packagekit
374 Summary:        PackageKit Python bindings
375 Summary(pl.UTF-8):      Wiązania PackageKit dla Pythona
376 Group:          Development/Languages/Python
377 Requires:       python-dbus
378 Requires:       python-pygobject
379
380 %description -n python-packagekit
381 PackageKit Python bindings.
382
383 %description -n python-packagekit -l pl.UTF-8
384 Wiązania PackageKit dla Pythona.
385
386 %prep
387 %setup -q
388 %patch0 -p1
389 %patch2 -p1
390 %patch3 -p1
391
392 %if %{with static_libs}
393 %{__sed} -i -e '/^packagekit_glib2_library =/ s/shared_library/library/' lib/packagekit-glib2/meson.build
394 %endif
395
396 %build
397 %{?with_zypp:CPPFLAGS="%{rpmcppflags} -D_RPM_5 -I/usr/include/rpm"}
398 %meson build \
399         -Dbash_command_not_found=false \
400         %{!?with_introspection:-Dgobject_introspection=false} \
401         %{?with_apidocs:-Dgtk_doc=true} \
402         -Dpackaging_backend=dummy%{?with_alpm:,alpm}%{?with_apt:,aptcc}%{?with_dnf:,dnf}%{?with_entropy:,entropy}%{?with_poldek:,poldek}%{?with_portage:,portage}%{?with_slack:,slack}%{?with_zypp:,zypp}%{?with_nix:,nix} \
403         %{!?with_python:-Dpython_backend=false} \
404         -Dpythonpackagedir=%{py_sitescriptdir} \
405         -Dsystemdsystemunitdir=%{systemdunitdir}
406
407 # TODO:
408 # -Ddnf_vendor=
409 # -Dpackagekit_user=
410
411 %ninja_build -C build
412
413 %install
414 rm -rf $RPM_BUILD_ROOT
415 install -d $RPM_BUILD_ROOT/var/cache/PackageKit/downloads
416
417 %ninja_install -C build
418
419 %{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
420 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/test_spawn
421
422 # use pk-gstreamer-install as codec installer
423 ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libexecdir}/gst-install-plugins-helper
424
425 install -d $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants
426 ln -sf ../packagekit-offline-update.service \
427         $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
428
429 %if %{with python}
430 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
431 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
432
433 %py_postclean
434 %endif
435
436 %find_lang %{name}
437
438 %clean
439 rm -rf $RPM_BUILD_ROOT
440
441 %post
442 %update_mime_database
443
444 %postun
445 %update_mime_database
446
447 %post   libs -p /sbin/ldconfig
448 %postun libs -p /sbin/ldconfig
449
450 %files -f %{name}.lang
451 %defattr(644,root,root,755)
452 %doc AUTHORS HACKING MAINTAINERS NEWS README
453 %attr(755,root,root) %{_bindir}/pkcon
454 %attr(755,root,root) %{_bindir}/pkmon
455 %attr(750,root,root) /etc/cron.daily/packagekit-background.cron
456 %attr(755,root,root) %{_libexecdir}/packagekit-direct
457 %attr(755,root,root) %{_libexecdir}/packagekitd
458 %attr(755,root,root) %{_libexecdir}/pk-offline-update
459 %dir %{_libdir}/packagekit-backend
460 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dummy.so
461 %dir %{_sysconfdir}/PackageKit
462 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
463 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
464 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
465 /etc/dbus-1/system.d/org.freedesktop.PackageKit.conf
466 %dir %{_datadir}/PackageKit
467 %dir %{_datadir}/PackageKit/helpers
468 %attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
469 %{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
470 %{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
471 %{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
472 %{_mandir}/man1/pkcon.1*
473 %{_mandir}/man1/pkmon.1*
474 %{systemdunitdir}/packagekit.service
475 %{systemdunitdir}/packagekit-offline-update.service
476 %{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
477 %dir /var/cache/PackageKit
478 %dir /var/cache/PackageKit/downloads
479 %dir /var/lib/PackageKit
480 %ghost /var/lib/PackageKit/transactions.db
481
482 %files libs
483 %defattr(644,root,root,755)
484 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
485 %attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.18
486 %{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
487 # NOTE: dbus interface xmls are commonly used:
488 # - at runtime by packagekitd
489 # - for development of applications using PK dbus interface
490 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
491 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
492
493 %files devel
494 %defattr(644,root,root,755)
495 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
496 %{_pkgconfigdir}/packagekit-glib2.pc
497 %dir %{_includedir}/PackageKit
498 %{_includedir}/PackageKit/packagekit-glib2
499 %{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
500
501 %if %{with static_libs}
502 %files static
503 %defattr(644,root,root,755)
504 %{_libdir}/libpackagekit-glib2.a
505 %endif
506
507 %if %{with vala}
508 %files -n vala-packagekit
509 %defattr(644,root,root,755)
510 %{_datadir}/vala/vapi/packagekit-glib2.deps
511 %{_datadir}/vala/vapi/packagekit-glib2.vapi
512 %endif
513
514 %if %{with apidocs}
515 %files apidocs
516 %defattr(644,root,root,755)
517 %{_gtkdocdir}/PackageKit
518 %endif
519
520 %if %{with alpm}
521 %files backend-alpm
522 %defattr(644,root,root,755)
523 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_alpm.so
524 %dir %{_sysconfdir}/PackageKit/alpm.d
525 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/groups.list
526 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/pacman.conf
527 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/repos.list
528 %endif
529
530 %if %{with apt}
531 %files backend-aptcc
532 %defattr(644,root,root,755)
533 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_aptcc.so
534 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf.d/20packagekit
535 %dir %{_datadir}/PackageKit/helpers/aptcc
536 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/get-distro-upgrade.py
537 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/pkconffile
538 %{_datadir}/PackageKit/helpers/aptcc/pkconffile.nodiff
539 %endif
540
541 %if %{with dnf}
542 %files backend-dnf
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dnf.so
545 %endif
546
547 %if %{with entropy}
548 %files backend-entropy
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_entropy.so
551 %dir %{_datadir}/PackageKit/helpers/entropy
552 %attr(755,root,root) %{_datadir}/PackageKit/helpers/entropy/entropyBackend.py
553 %endif
554
555 %if %{with nix}
556 %files backend-nix
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_nix.so
559 %endif
560
561 %if %{with poldek}
562 %files backend-poldek
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
565 %endif
566
567 %if %{with portage}
568 %files backend-portage
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_portage.so
571 %dir %{_datadir}/PackageKit/helpers/portage
572 %attr(755,root,root) %{_datadir}/PackageKit/helpers/portage/portageBackend.py
573 %endif
574
575 %if %{with slack}
576 %files backend-slack
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_slack.so
579 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Slackware.conf
580 %dir /var/cache/PackageKit/metadata
581 %ghost /var/cache/PackageKit/metadata/metadata.db
582 %endif
583
584 %if %{with zypp}
585 %files backend-zypp
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_zypp.so
588 %endif
589
590 %files gstreamer-plugin
591 %defattr(644,root,root,755)
592 %doc contrib/gstreamer-plugin/README
593 %attr(755,root,root) %{_libexecdir}/gst-install-plugins-helper
594 %attr(755,root,root) %{_libexecdir}/pk-gstreamer-install
595
596 %files gtk3-module
597 %defattr(644,root,root,755)
598 %doc contrib/gtk-module/{GLASS.txt,README}
599 %attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
600 %{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
601
602 %files -n bash-completion-packagekit
603 %defattr(644,root,root,755)
604 %{bash_compdir}/pkcon
605
606 %if %{with python}
607 %files -n python-packagekit
608 %defattr(644,root,root,755)
609 %dir %{py_sitescriptdir}/packagekit
610 %{py_sitescriptdir}/packagekit/*.py[co]
611 %endif
This page took 0.585683 seconds and 4 git commands to generate.