]> git.pld-linux.org Git - packages/PackageKit.git/blob - PackageKit.spec
- up to 1.1.13
[packages/PackageKit.git] / PackageKit.spec
1 # TODO:
2 # - BASH command-not-found functionality disabled for now as it needs patched bash
3 #   (details in bash from Fedora Rawhide)
4 #
5 # Conditional build:
6 %bcond_without  doc             # build without docs
7 %bcond_without  introspection   # gobject introspection, time to time broken
8 %bcond_with     alpm            # ALPM (Arch Linux package manager) backend
9 %bcond_with     apt             # APT (Debian/Ubuntu) backend using C++ API
10 %bcond_with     entropy         # Entropy (Sabayon) backend (Python)
11 %bcond_with     hif             # HIF (Fedora/RHEL) backend
12 %bcond_with     katja           # Katja (Slackware) backend
13 %bcond_with     pisi            # PiSi (Pardus) backend (Python)
14 %bcond_without  poldek          # Poldek (PLD) backend
15 %bcond_with     portage         # portage (Gentoo) backend (Python)
16 %bcond_with     ports           # ports (FreeBSD) backend (Ruby)
17 %bcond_with     urpmi           # urpmi (Mandriva/Mageia) backend (Perl)
18 %bcond_with     zypp            # ZYPP (openSUSE/SLE) backend
19 %bcond_without  python          # Python binding (only for a few backends)
20 %bcond_without  vala            # Vala binding
21 %bcond_with     browser         # browser plugin (patrys says: it's flawed by concept)
22
23 # Python binding is built when building any python binding
24 %if %{without entropy} && %{without pisi} && %{without ports}
25 %undefine       with_python
26 %endif
27
28 Summary:        System daemon that is a D-Bus abstraction layer for package management
29 Summary(pl.UTF-8):      Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
30 Name:           PackageKit
31 Version:        1.1.13
32 Release:        1
33 License:        GPL v2+
34 Group:          Applications/System
35 Source0:        https://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
36 # Source0-md5:  7635892baa047639cf5590d6f57324c1
37 Patch0:         %{name}-poldek.patch
38 Patch1:         %{name}-bashcomp.patch
39
40 Patch3:         consolekit-fallback.patch
41 URL:            https://www.freedesktop.org/software/PackageKit/
42 BuildRequires:  NetworkManager-devel >= 0.6.5
43 # pkgconfig(libalpm) >= 8.2.0
44 %{?with_alpm:BuildRequires:     alpm-devel >= 4}
45 %{?with_hif:BuildRequires:      appstream-glib-devel}
46 %{?with_apt:BuildRequires:      apt-devel >= 0.7}
47 BuildRequires:  autoconf >= 2.65
48 BuildRequires:  automake >= 1:1.11
49 BuildRequires:  connman-devel
50 %{?with_katja:BuildRequires:    curl-devel}
51 BuildRequires:  dbus-devel >= 1.2.0
52 BuildRequires:  dbus-glib-devel >= 0.76
53 BuildRequires:  docbook-dtd412-xml
54 BuildRequires:  docbook-dtd42-xml
55 BuildRequires:  fontconfig-devel
56 BuildRequires:  gettext-tools
57 BuildRequires:  glib2-devel >= 1:2.32.0
58 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.9.9}
59 BuildRequires:  gstreamer-devel >= 1.0.0
60 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
61 BuildRequires:  gtk+2-devel >= 2:2.14.0
62 BuildRequires:  gtk+3-devel >= 3.0.0
63 %{?with_doc:BuildRequires:      gtk-doc >= 1.11}
64 BuildRequires:  intltool >= 0.35.0
65 BuildRequires:  libarchive-devel
66 %{?with_hif:BuildRequires:      libhif-devel >= 0.1.7}
67 BuildRequires:  libtool
68 BuildRequires:  libxslt-progs
69 %{?with_zypp:BuildRequires:     libzypp-devel >= 15}
70 BuildRequires:  pango-devel
71 BuildRequires:  pkgconfig
72 %{?with_poldek:BuildRequires:   poldek-devel >= 0.30-1.rc6.4}
73 BuildRequires:  polkit-devel >= 0.98
74 %{?with_python:BuildRequires:   python-devel >= 1:2.7}
75 BuildRequires:  readline-devel
76 BuildRequires:  rpm-pythonprov
77 BuildRequires:  rpmbuild(macros) >= 1.311
78 BuildRequires:  sqlite3-devel >= 3
79 BuildRequires:  systemd-devel >= 1:209
80 BuildRequires:  tar >= 1:1.22
81 BuildRequires:  udev-glib-devel
82 %{?with_vala:BuildRequires:     vala >= 2:0.16}
83 BuildRequires:  xz
84 %if %{with browser}
85 BuildRequires:  cairo-devel
86 BuildRequires:  nspr-devel >= 4.8
87 BuildRequires:  pango-devel
88 BuildRequires:  xulrunner-devel >= 8.0
89 %endif
90 Requires(post,postun):  shared-mime-info
91 Requires:       %{name}-backend
92 Requires:       %{name}-libs = %{version}-%{release}
93 Requires:       crondaemon
94 Requires:       polkit >= 0.98
95 Suggests:       ConsoleKit-x11
96 Obsoletes:      PackageKit-backend-smart
97 Obsoletes:      PackageKit-backend-yum
98 Obsoletes:      PackageKit-docs < 0.8.4
99 Obsoletes:      pm-utils-packagekit
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %description
103 PackageKit is a D-Bus abstraction layer that allows the session user
104 to manage packages in a secure way using a cross-distro,
105 cross-architecture API.
106
107 %description -l pl.UTF-8
108 PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
109 sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
110 zgodnego z wieloma dystrybucjami i architekturami.
111
112 %package libs
113 Summary:        packagekit-glib library
114 Summary(pl.UTF-8):      Biblioteka packagekit-glib
115 Group:          Libraries
116 Requires:       glib2 >= 1:2.32.0
117
118 %description libs
119 packagekit-glib library.
120
121 %description libs -l pl.UTF-8
122 Biblioteka packagekit-glib.
123
124 %package devel
125 Summary:        Header files for packagekit-glib library
126 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki packagekit-glib
127 Group:          Development/Libraries
128 Requires:       %{name}-libs = %{version}-%{release}
129 Requires:       dbus-devel >= 1.2.0
130 Requires:       glib2-devel >= 1:2.32.0
131 Requires:       sqlite3-devel
132
133 %description devel
134 Header files for packagekit-glib library.
135
136 %description devel -l pl.UTF-8
137 Pliki nagłówkowe biblioteki packagekit-glib.
138
139 %package static
140 Summary:        Static packagekit-glib library
141 Summary(pl.UTF-8):      Statyczna biblioteka packagekit-glib
142 Group:          Development/Libraries
143 Requires:       %{name}-devel = %{version}-%{release}
144
145 %description static
146 Static packagekit-glib library.
147
148 %description static -l pl.UTF-8
149 Statyczna biblioteka packagekit-glib.
150
151 %package -n vala-packagekit
152 Summary:        Vala API for PackageKit library
153 Summary(pl.UTF-8):      API języka Vala do biblioteki PackageKitu
154 Group:          Development/Libraries
155 Requires:       %{name}-devel = %{version}-%{release}
156 Requires:       vala >= 2:0.16
157 %if "%{_rpmversion}" >= "5"
158 BuildArch:      noarch
159 %endif
160
161 %description -n vala-packagekit
162 Vala API for PackageKit library.
163
164 %description -n vala-packagekit -l pl.UTF-8
165 API języka Vala do biblioteki PackageKitu.
166
167 %package apidocs
168 Summary:        PackageKit library API documentation
169 Summary(pl.UTF-8):      Dokumentacja API biblioteki PackageKit
170 Group:          Documentation
171 Requires:       gtk-doc-common
172 %if "%{_rpmversion}" >= "5"
173 BuildArch:      noarch
174 %endif
175
176 %description apidocs
177 PackageKit library API documentation.
178
179 %description apidocs -l pl.UTF-8
180 Dokumentacja API biblioteki PackageKit.
181
182 %package backend-alpm
183 Summary:        PackageKit ALPM backend
184 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece ALPM
185 Group:          Libraries
186 Requires:       %{name} = %{version}-%{release}
187 Provides:       %{name}-backend = %{version}-%{release}
188
189 %description backend-alpm
190 A backend for PackageKit to enable Arch Linux packages via ALPM
191 library.
192
193 %description backend-alpm -l pl.UTF-8
194 Backend PackageKit dodający obsługę pakietów Arch Linuksa poprzez
195 bibliotekę ALPM.
196
197 %package backend-aptcc
198 Summary:        PackageKit APTcc backend
199 Summary(pl.UTF-8):      Backend PackageKit APTcc
200 Group:          Libraries
201 Requires:       %{name} = %{version}-%{release}
202 Provides:       %{name}-backend = %{version}-%{release}
203
204 %description backend-aptcc
205 A backend for PackageKit to enable APT support via C++ API.
206
207 %description backend-aptcc -l pl.UTF-8
208 Backend PackageKit dodający obsługę zarządcy pakietów APT poprzez API
209 C++.
210
211 %package backend-entropy
212 Summary:        PackageKit Entropy backend
213 Summary(pl.UTF-8):      Backend PackageKit Entropy
214 Group:          Libraries
215 Requires:       %{name} = %{version}-%{release}
216 Requires:       python-packagekit = %{version}-%{release}
217 #Requires:      python-entropy
218 Provides:       %{name}-backend = %{version}-%{release}
219
220 %description backend-entropy
221 A backend for PackageKit to enable Sabayon packages support through
222 Entropy package manager.
223
224 %description backend-entropy -l pl.UTF-8
225 Backend PackageKit dodający obsługę pakietów dystrybucji Sabayon przy
226 użyciu zarządcy pakietów Entropy.
227
228 %package backend-hif
229 Summary:        PackageKit hif backend
230 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece hif
231 Group:          Libraries
232 Requires:       %{name} = %{version}-%{release}
233 Requires:       libhif >= 0.1.7
234 Provides:       %{name}-backend = %{version}-%{release}
235 Obsoletes:      PackageKit-backend-hawkey
236
237 %description backend-hif
238 A backend for PackageKit to enable RPM packages support via hif
239 library (used in Fedora).
240
241 %description backend-hif -l pl.UTF-8
242 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
243 hif (używaną w dystrybucji Fedora).
244
245 %package backend-katja
246 Summary:        PackageKit Katja backend
247 Summary(pl.UTF-8):      Backend PackageKit Katja
248 Group:          Libraries
249 Requires:       %{name} = %{version}-%{release}
250 Provides:       %{name}-backend = %{version}-%{release}
251
252 %description backend-katja
253 Katja backend for PackageKit to enable Slackware repositories support.
254
255 %description backend-katja -l pl.UTF-8
256 Backend PackageKit Katja dodający obsługę repozytoriów Slackware.
257
258 %package backend-pisi
259 Summary:        PackageKit PiSi backend
260 Summary(pl.UTF-8):      Backend PackageKit PiSi
261 Group:          Libraries
262 Requires:       %{name} = %{version}-%{release}
263 Requires:       python-packagekit = %{version}-%{release}
264 #Requires:      python-piksemel
265 #Requires:      python-pisi
266 Provides:       %{name}-backend = %{version}-%{release}
267
268 %description backend-pisi
269 A backend for PackageKit to enable PiSi packages support. PiSi
270 packages are originated in Pardus distribution.
271
272 %description backend-pisi -l pl.UTF-8
273 Backend PackageKit dodający obsługę pakietów PiSi. Pakiety PiSi
274 wywodzą się z dystrybucji Pardus.
275
276 %package backend-poldek
277 Summary:        PackageKit Poldek backend
278 Summary(pl.UTF-8):      Backend PackageKit oparty na Poldku
279 Group:          Libraries
280 Requires:       %{name} = %{version}-%{release}
281 Requires:       poldek >= 0.30-1.rc6.4
282 Provides:       %{name}-backend = %{version}-%{release}
283
284 %description backend-poldek
285 A backend for PackageKit to enable RPM packages support through Poldek
286 - native PLD package manager.
287
288 %description backend-poldek -l pl.UTF-8
289 Backend PackageKit dodający obsługę pakietów RPM poprzez Poldka -
290 natywnego zarządcę pakietów dystrybucji PLD.
291
292 %package backend-portage
293 Summary:        PackageKit Portage backend
294 Summary(pl.UTF-8):      Backend PackageKit Portage
295 Group:          Libraries
296 Requires:       %{name} = %{version}-%{release}
297 Requires:       python-packagekit = %{version}-%{release}
298 #Requires:      python-portage
299 Provides:       %{name}-backend = %{version}-%{release}
300
301 %description backend-portage
302 A backend for PackageKit to enable Gentoo Portage support.
303
304 %description backend-portage -l pl.UTF-8
305 Backend PackageKit dodający obsługę systemu Portage dystrybucji
306 Gentoo.
307
308 %package backend-ports
309 Summary:        PackageKit Ports backend
310 Summary(pl.UTF-8):      Backend PackageKit Ports
311 Group:          Libraries
312 Requires:       %{name} = %{version}-%{release}
313 #Requires:      ruby-pkgtools
314 Provides:       %{name}-backend = %{version}-%{release}
315
316 %description backend-ports
317 A backend for PackageKit to enable FreeBSD Ports support.
318
319 %description backend-ports -l pl.UTF-8
320 Backend PackageKit dodający obsługę portów systemu FreeBSD.
321
322 %package backend-urpmi
323 Summary:        PackageKit URPMI backend
324 Summary(pl.UTF-8):      Backend PackageKit URPMI
325 Group:          Libraries
326 Requires:       %{name} = %{version}-%{release}
327 #Requires:      perl-URPM
328 Provides:       %{name}-backend = %{version}-%{release}
329
330 %description backend-urpmi
331 A backend for PackageKit to enable RPM packages support through URPMI
332 package manager (originated in Mandriva).
333
334 %description backend-urpmi -l pl.UTF-8
335 Backend PackageKit dodający obsługę pakietów RPM poprzez zarządcę
336 URPMI (pochodzącego z dystrybucji Mandriva).
337
338 %package backend-zypp
339 Summary:        PackageKit Zypp backend
340 Summary(pl.UTF-8):      Backend PackageKit Zypp
341 Group:          Libraries
342 Requires:       %{name} = %{version}-%{release}
343 Requires:       libzypp >= 15
344 Provides:       %{name}-backend = %{version}-%{release}
345
346 %description backend-zypp
347 A backend for PackageKit to enable RPM packages support through Zypp
348 library (originated in openSUSE/SLE).
349
350 %description backend-zypp -l pl.UTF-8
351 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
352 Zypp (pochodzącą z dystrybucji openSUSE/SLE).
353
354 %package gstreamer-plugin
355 Summary:        GStreamer codecs installer
356 Summary(pl.UTF-8):      Instalator kodeków GStreamera
357 Group:          Applications
358 Requires:       %{name} = %{version}-%{release}
359 Requires:       %{name}-gtk-module = %{version}-%{release}
360
361 %description gstreamer-plugin
362 The PackageKit GStreamer plugin allows any GStreamer application to
363 install codecs from configured repositories using PackageKit.
364
365 %description gstreamer-plugin -l pl.UTF-8
366 Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
367 zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
368
369 %package gtk-module
370 Summary:        GTK+ module to detect and install missing fonts
371 Summary(pl.UTF-8):      Moduł GTK+ do wykrywania i instalowania brakujących czcionek
372 Group:          X11/Libraries
373
374 %description gtk-module
375 The PackageKit GTK+ module allows any pango application to install
376 missing fonts from configured repositories using PackageKit.
377
378 %description gtk-module -l pl.UTF-8
379 Moduł GTK+ pozwala każdej aplikacji używającej pango zainstalować
380 brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
381
382 %package gtk3-module
383 Summary:        GTK+ 3.x module to detect and install missing fonts
384 Summary(pl.UTF-8):      Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
385 Group:          X11/Libraries
386
387 %description gtk3-module
388 The PackageKit GTK+ 3.x module allows any pango application to install
389 missing fonts from configured repositories using PackageKit.
390
391 %description gtk3-module -l pl.UTF-8
392 Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
393 brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
394
395 %package -n bash-completion-packagekit
396 Summary:        Bash completion for PackageKit console commands
397 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń konsolowych PackageKit
398 Group:          Applications/Shells
399 Requires:       %{name} = %{version}-%{release}
400 Requires:       bash-completion >= 2
401 %if "%{_rpmversion}" >= "5"
402 BuildArch:      noarch
403 %endif
404
405 %description -n bash-completion-packagekit
406 This package provides bash-completion for PackageKit console commands.
407
408 %description -n bash-completion-packagekit -l pl.UTF-8
409 Pakiet ten dostarcza bashowe uzupełnianie parametrów dla poleceń
410 konsolowych PackageKit.
411
412 %package -n python-packagekit
413 Summary:        PackageKit Python bindings
414 Summary(pl.UTF-8):      Wiązania PackageKit dla Pythona
415 Group:          Development/Languages/Python
416 Requires:       python-dbus
417 Requires:       python-pygobject
418
419 %description -n python-packagekit
420 PackageKit Python bindings.
421
422 %description -n python-packagekit -l pl.UTF-8
423 Wiązania PackageKit dla Pythona.
424
425 %package -n browser-plugin-packagekit
426 Summary:        PackageKit's browser plugin
427 Summary(pl.UTF-8):      Wtyczka PackageKit do przeglądarek WWW
428 Group:          X11/Libraries
429 Requires:       %{name} = %{version}-%{release}
430 Requires:       browser-plugins >= 2.0
431 Requires:       browser-plugins(%{_target_base_arch})
432
433 %description -n browser-plugin-packagekit
434 PackageKit's plugin for browsers.
435
436 %description -n browser-plugin-packagekit -l pl.UTF-8
437 Wtyczka PackageKit do przeglądarek WWW.
438
439 %prep
440 %setup -q
441 %patch0 -p1
442 %patch1 -p1
443
444 %patch3 -p1
445
446 %build
447 %if %{with doc}
448 %{__gtkdocize}
449 %endif
450 %{__intltoolize}
451 %{__libtoolize}
452 %{__aclocal} -I m4
453 %{__autoconf}
454 %{__autoheader}
455 %{__automake}
456 %{?with_zypp:CPPFLAGS="%{rpmcppflags} -D_RPM_5 -I/usr/include/rpm"}
457 %configure \
458         --disable-command-not-found \
459         --disable-dummy \
460         %{!?with_doc:--disable-gtk-doc} \
461         %{!?with_introspection:--disable-introspection} \
462         --disable-silent-rules \
463         --enable-bash-completion=%{bash_compdir} \
464         %{__enable_disable alpm} \
465         %{__enable_disable apt aptcc} \
466         %{__enable_disable browser browser-plugin} \
467         %{__enable_disable entropy} \
468         %{__enable_disable hif} \
469         %{__enable_disable katja} \
470         %{__enable_disable pisi} \
471         %{__enable_disable poldek} \
472         %{__enable_disable portage} \
473         %{__enable_disable ports} \
474         %{__enable_disable urpmi} \
475         %{__enable_disable zypp} \
476         --with-html-dir=%{_gtkdocdir} \
477         --with-mozilla-plugin-dir=%{_browserpluginsdir} \
478         --with-security-framework=polkit
479 %{__make}
480
481 %install
482 rm -rf $RPM_BUILD_ROOT
483
484 %{__make} install \
485         DESTDIR=$RPM_BUILD_ROOT
486
487 # use pk-gstreamer-install as codec installer
488 ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libdir}/gst-install-plugins-helper
489
490 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gtk-{2,3}.0/modules/*.{la,a}
491 %{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/*.{la,a}
492 %{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
493 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
494 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/test_spawn
495
496 %if %{with browser}
497 %{__rm} $RPM_BUILD_ROOT%{_browserpluginsdir}/*.{la,a}
498 %endif
499
500 %py_postclean
501
502 %find_lang %{name}
503
504 %clean
505 rm -rf $RPM_BUILD_ROOT
506
507 %post
508 %update_mime_database
509
510 %postun
511 %update_mime_database
512
513 %post   libs -p /sbin/ldconfig
514 %postun libs -p /sbin/ldconfig
515
516 %post -n browser-plugin-packagekit
517 %update_browser_plugins
518
519 %postun -n browser-plugin-packagekit
520 if [ "$1" = 0 ]; then
521         %update_browser_plugins
522 fi
523
524 %files -f %{name}.lang
525 %defattr(644,root,root,755)
526 %doc AUTHORS HACKING MAINTAINERS NEWS README
527 %attr(755,root,root) %{_bindir}/pkcon
528 %attr(755,root,root) %{_bindir}/pkmon
529 %attr(750,root,root) /etc/cron.daily/packagekit-background.cron
530 %attr(755,root,root) %{_libexecdir}/packagekit-direct
531 %attr(755,root,root) %{_libexecdir}/packagekitd
532 %attr(755,root,root) %{_libexecdir}/pk-offline-update
533 %dir %{_libdir}/packagekit-backend
534 %dir %{_sysconfdir}/PackageKit
535 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
536 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
537 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
538 /etc/dbus-1/system.d/org.freedesktop.PackageKit.conf
539 %dir %{_datadir}/PackageKit
540 %dir %{_datadir}/PackageKit/helpers
541 %attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
542 %{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
543 %{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
544 %{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
545 %{_mandir}/man1/pkcon.1*
546 %{_mandir}/man1/pkmon.1*
547 %{systemdunitdir}/packagekit.service
548 %{systemdunitdir}/packagekit-offline-update.service
549 %{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
550 %dir /var/cache/PackageKit
551 %dir /var/cache/PackageKit/downloads
552 %dir /var/lib/PackageKit
553 %ghost /var/lib/PackageKit/transactions.db
554
555 %files libs
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
558 %attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.18
559 %{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
560 # NOTE: dbus interface xmls are commonly used:
561 # - at runtime by packagekitd
562 # - for development of applications using PK dbus interface
563 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
564 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
565
566 %files devel
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
569 %{_pkgconfigdir}/packagekit-glib2.pc
570 %dir %{_includedir}/PackageKit
571 %{_includedir}/PackageKit/packagekit-glib2
572 %{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
573
574 %files static
575 %defattr(644,root,root,755)
576 %{_libdir}/libpackagekit-glib2.a
577
578 %if %{with vala}
579 %files -n vala-packagekit
580 %defattr(644,root,root,755)
581 %{_datadir}/vala/vapi/packagekit-glib2.vapi
582 %endif
583
584 %files apidocs
585 %defattr(644,root,root,755)
586 %{_gtkdocdir}/PackageKit
587
588 %if %{with alpm}
589 %files backend-alpm
590 %defattr(644,root,root,755)
591 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_alpm.so
592 %dir %{_sysconfdir}/PackageKit/alpm.d
593 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/groups.list
594 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/pacman.conf
595 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/repos.list
596 %endif
597
598 %if %{with apt}
599 %files backend-aptcc
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_aptcc.so
602 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf.d/20packagekit
603 %dir %{_datadir}/PackageKit/helpers/aptcc
604 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/get-distro-upgrade.py
605 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/pkconffile
606 %{_datadir}/PackageKit/helpers/aptcc/pkconffile.nodiff
607 %endif
608
609 %if %{with entropy}
610 %files backend-entropy
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_entropy.so
613 %dir %{_datadir}/PackageKit/helpers/entropy
614 %attr(755,root,root) %{_datadir}/PackageKit/helpers/entropy/entropyBackend.py
615 %endif
616
617 %if %{with hif}
618 %files backend-hif
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_hif.so
621 %endif
622
623 %if %{with katja}
624 %files backend-katja
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_katja.so
627 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Katja.conf
628 %dir /var/cache/PackageKit/metadata
629 %ghost /var/cache/PackageKit/metadata/metadata.db
630 %endif
631
632 %if %{with pisi}
633 %files backend-pisi
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_pisi.so
636 %dir %{_datadir}/PackageKit/helpers/pisi
637 %attr(755,root,root) %{_datadir}/PackageKit/helpers/pisi/pisiBackend.py
638 %endif
639
640 %if %{with poldek}
641 %files backend-poldek
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
644 %endif
645
646 %if %{with portage}
647 %files backend-portage
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_portage.so
650 %dir %{_datadir}/PackageKit/helpers/portage
651 %attr(755,root,root) %{_datadir}/PackageKit/helpers/portage/portageBackend.py
652 %endif
653
654 %if %{with ports}
655 %files backend-ports
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_ports.so
658 %dir %{_datadir}/PackageKit/helpers/ports
659 %attr(755,root,root) %{_datadir}/PackageKit/helpers/ports/portsBackend.rb
660 %{_datadir}/PackageKit/helpers/ports/ruby_packagekit
661 %endif
662
663 %if %{with urpmi}
664 %files backend-urpmi
665 %defattr(644,root,root,755)
666 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_urpmi.so
667 %dir %{_datadir}/PackageKit/helpers/urpmi
668 %attr(755,root,root) %{_datadir}/PackageKit/helpers/urpmi/urpmi-dispatched-backend.pl
669 %{_datadir}/PackageKit/helpers/urpmi/perl_packagekit
670 %{_datadir}/PackageKit/helpers/urpmi/urpmi_backend
671 %endif
672
673 %if %{with zypp}
674 %files backend-zypp
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_zypp.so
677 %endif
678
679 %files gstreamer-plugin
680 %defattr(644,root,root,755)
681 %doc contrib/gstreamer-plugin/README
682 %attr(755,root,root) %{_libdir}/gst-install-plugins-helper
683 %attr(755,root,root) %{_libexecdir}/pk-gstreamer-install
684
685 %files gtk-module
686 %defattr(644,root,root,755)
687 %doc contrib/gtk-module/{GLASS.txt,README}
688 %attr(755,root,root) %{_libdir}/gtk-2.0/modules/libpk-gtk-module.so
689
690 %files gtk3-module
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
693 %{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
694
695 %files -n bash-completion-packagekit
696 %defattr(644,root,root,755)
697 %{bash_compdir}/pkcon
698
699 %if %{with python}
700 %files -n python-packagekit
701 %defattr(644,root,root,755)
702 %dir %{py_sitescriptdir}/packagekit
703 %{py_sitescriptdir}/packagekit/*.py[co]
704 %endif
705
706 %if %{with browser}
707 %files -n browser-plugin-packagekit
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_browserpluginsdir}/packagekit-plugin.so
710 %endif
This page took 0.133593 seconds and 4 git commands to generate.