]> git.pld-linux.org Git - packages/PackageKit.git/blob - PackageKit.spec
- updated BRs and foreign backends, dropped browser plugin (removed finally in 1...
[packages/PackageKit.git] / PackageKit.spec
1 # TODO:
2 # - BASH command-not-found functionality disabled for now as it needs patched bash
3 #   (details in bash from Fedora Rawhide)
4 #
5 # Conditional build:
6 %bcond_without  doc             # build without docs
7 %bcond_without  introspection   # gobject introspection, time to time broken
8 %bcond_with     alpm            # ALPM (Arch Linux package manager) backend
9 %bcond_with     apt             # APT (Debian/Ubuntu) backend using C++ API
10 %bcond_with     dnf             # DNF (Fedora/RHEL) backend
11 %bcond_with     entropy         # Entropy (Sabayon) backend (Python)
12 %bcond_with     nix             # Nix (NixOS) backend
13 %bcond_with     pisi            # PiSi (Pardus) backend (Python)
14 %bcond_without  poldek          # Poldek (PLD) backend
15 %bcond_with     portage         # portage (Gentoo) backend (Python)
16 %bcond_with     ports           # ports (FreeBSD) backend (Ruby)
17 %bcond_with     slack           # Slack (Slackware) backend
18 %bcond_with     urpmi           # urpmi (Mandriva/Mageia) backend (Perl)
19 %bcond_with     yum             # YUM (Fedora) backend (Python)
20 %bcond_with     zypp            # ZYPP (openSUSE/SLE) backend
21 %bcond_without  python          # Python binding (only for a few backends)
22 %bcond_without  vala            # Vala binding
23
24 # Python binding is built when building any python binding
25 %if %{without entropy} && %{without pisi} && %{without ports} && %{without yum}
26 %undefine       with_python
27 %endif
28
29 Summary:        System daemon that is a D-Bus abstraction layer for package management
30 Summary(pl.UTF-8):      Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
31 Name:           PackageKit
32 Version:        1.1.13
33 Release:        1
34 License:        GPL v2+
35 Group:          Applications/System
36 Source0:        https://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
37 # Source0-md5:  7635892baa047639cf5590d6f57324c1
38 Patch0:         %{name}-poldek.patch
39 Patch1:         %{name}-bashcomp.patch
40
41 Patch3:         consolekit-fallback.patch
42 URL:            https://www.freedesktop.org/software/PackageKit/
43 %{?with_apt:BuildRequires:      AppStream-devel >= 0.11}
44 BuildRequires:  NetworkManager-devel >= 0.6.5
45 # pkgconfig(libalpm) >= 12.0.0
46 %{?with_alpm:BuildRequires:     alpm-devel >= 5.2}
47 %{?with_dnf:BuildRequires:      appstream-glib-devel}
48 %{?with_apt:BuildRequires:      apt-devel >= 1.7}
49 BuildRequires:  autoconf >= 2.65
50 BuildRequires:  automake >= 1:1.11
51 BuildRequires:  connman-devel
52 %{?with_slack:BuildRequires:    curl-devel}
53 BuildRequires:  dbus-devel >= 1.2.0
54 BuildRequires:  dbus-glib-devel >= 0.76
55 BuildRequires:  docbook-dtd412-xml
56 BuildRequires:  docbook-dtd42-xml
57 BuildRequires:  fontconfig-devel
58 BuildRequires:  gettext-tools
59 BuildRequires:  glib2-devel >= 1:2.54.0
60 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.9.9}
61 BuildRequires:  gstreamer-devel >= 1.0.0
62 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
63 BuildRequires:  gtk+2-devel >= 2:2.14.0
64 BuildRequires:  gtk+3-devel >= 3.0.0
65 %{?with_doc:BuildRequires:      gtk-doc >= 1.11}
66 BuildRequires:  intltool >= 0.35.0
67 BuildRequires:  libarchive-devel
68 %{?with_dnf:BuildRequires:      libdnf-devel >= 0.22.0}
69 %if %{with apt} || %{with nix}
70 BuildRequires:  libstdc++-devel >= 6:4.7
71 %endif
72 %{?with_slack:BuildRequires:    libstdc++-devel >= 6:5}
73 BuildRequires:  libtool >= 2:2
74 BuildRequires:  libxslt-progs
75 %{?with_zypp:BuildRequires:     libzypp-devel >= 15}
76 # nix-expr nix-main nix-store
77 %{?with_nix:BuildRequires:      nix-devel >= 1.12}
78 BuildRequires:  pango-devel
79 BuildRequires:  pkgconfig
80 # when released; just to detect which reboot modes to use (library not linked)
81 #BuildRequires: plymouth-devel >= 0.9.5
82 %{?with_poldek:BuildRequires:   poldek-devel >= 0.30-1.rc6.4}
83 BuildRequires:  polkit-devel >= 0.114
84 # or 1:3.2
85 %{?with_python:BuildRequires:   python-devel >= 1:2.7}
86 BuildRequires:  readline-devel
87 %{?with_dnf:BuildRequires:      rpm-devel >= 4.?}
88 BuildRequires:  rpm-pythonprov
89 BuildRequires:  rpmbuild(macros) >= 1.311
90 BuildRequires:  sqlite3-devel >= 3
91 BuildRequires:  systemd-devel >= 1:213
92 BuildRequires:  tar >= 1:1.22
93 BuildRequires:  udev-glib-devel
94 %{?with_vala:BuildRequires:     vala >= 2:0.16}
95 BuildRequires:  xz
96 Requires(post,postun):  shared-mime-info
97 Requires:       %{name}-backend
98 Requires:       %{name}-libs = %{version}-%{release}
99 Requires:       crondaemon
100 Requires:       polkit >= 0.114
101 Suggests:       ConsoleKit-x11
102 Obsoletes:      PackageKit-backend-smart
103 Obsoletes:      PackageKit-backend-yum
104 Obsoletes:      PackageKit-docs < 0.8.4
105 Obsoletes:      pm-utils-packagekit
106 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108 %description
109 PackageKit is a D-Bus abstraction layer that allows the session user
110 to manage packages in a secure way using a cross-distro,
111 cross-architecture API.
112
113 %description -l pl.UTF-8
114 PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
115 sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
116 zgodnego z wieloma dystrybucjami i architekturami.
117
118 %package libs
119 Summary:        packagekit-glib library
120 Summary(pl.UTF-8):      Biblioteka packagekit-glib
121 Group:          Libraries
122 Requires:       glib2 >= 1:2.54.0
123 Obsoletes:      browser-plugin-packagekit < 1.1.0
124
125 %description libs
126 packagekit-glib library.
127
128 %description libs -l pl.UTF-8
129 Biblioteka packagekit-glib.
130
131 %package devel
132 Summary:        Header files for packagekit-glib library
133 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki packagekit-glib
134 Group:          Development/Libraries
135 Requires:       %{name}-libs = %{version}-%{release}
136 Requires:       dbus-devel >= 1.2.0
137 Requires:       glib2-devel >= 1:2.54.0
138 Requires:       sqlite3-devel
139
140 %description devel
141 Header files for packagekit-glib library.
142
143 %description devel -l pl.UTF-8
144 Pliki nagłówkowe biblioteki packagekit-glib.
145
146 %package static
147 Summary:        Static packagekit-glib library
148 Summary(pl.UTF-8):      Statyczna biblioteka packagekit-glib
149 Group:          Development/Libraries
150 Requires:       %{name}-devel = %{version}-%{release}
151
152 %description static
153 Static packagekit-glib library.
154
155 %description static -l pl.UTF-8
156 Statyczna biblioteka packagekit-glib.
157
158 %package -n vala-packagekit
159 Summary:        Vala API for PackageKit library
160 Summary(pl.UTF-8):      API języka Vala do biblioteki PackageKitu
161 Group:          Development/Libraries
162 Requires:       %{name}-devel = %{version}-%{release}
163 Requires:       vala >= 2:0.16
164 %if "%{_rpmversion}" >= "4.6"
165 BuildArch:      noarch
166 %endif
167
168 %description -n vala-packagekit
169 Vala API for PackageKit library.
170
171 %description -n vala-packagekit -l pl.UTF-8
172 API języka Vala do biblioteki PackageKitu.
173
174 %package apidocs
175 Summary:        PackageKit library API documentation
176 Summary(pl.UTF-8):      Dokumentacja API biblioteki PackageKit
177 Group:          Documentation
178 Requires:       gtk-doc-common
179 %if "%{_rpmversion}" >= "4.6"
180 BuildArch:      noarch
181 %endif
182
183 %description apidocs
184 PackageKit library API documentation.
185
186 %description apidocs -l pl.UTF-8
187 Dokumentacja API biblioteki PackageKit.
188
189 %package backend-alpm
190 Summary:        PackageKit ALPM backend
191 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece ALPM
192 Group:          Libraries
193 Requires:       %{name} = %{version}-%{release}
194 Provides:       %{name}-backend = %{version}-%{release}
195
196 %description backend-alpm
197 A backend for PackageKit to enable Arch Linux packages via ALPM
198 library.
199
200 %description backend-alpm -l pl.UTF-8
201 Backend PackageKit dodający obsługę pakietów Arch Linuksa poprzez
202 bibliotekę ALPM.
203
204 %package backend-aptcc
205 Summary:        PackageKit APTcc backend
206 Summary(pl.UTF-8):      Backend PackageKit APTcc
207 Group:          Libraries
208 Requires:       %{name} = %{version}-%{release}
209 Requires:       AppStream >= 0.11
210 Provides:       %{name}-backend = %{version}-%{release}
211
212 %description backend-aptcc
213 A backend for PackageKit to enable APT support via C++ API.
214
215 %description backend-aptcc -l pl.UTF-8
216 Backend PackageKit dodający obsługę zarządcy pakietów APT poprzez API
217 C++.
218
219 %package backend-dnf
220 Summary:        PackageKit dnf backend
221 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece dnfhif
222 Group:          Libraries
223 Requires:       %{name} = %{version}-%{release}
224 Provides:       %{name}-backend = %{version}-%{release}
225 Obsoletes:      PackageKit-backend-hawkey
226 Obsoletes:      PackageKit-backend-hif
227
228 %description backend-dnf
229 A backend for PackageKit to enable RPM packages support via dnf
230 library (used in Fedora).
231
232 %description backend-dnf -l pl.UTF-8
233 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
234 dnf (używaną w dystrybucji Fedora).
235
236 %package backend-entropy
237 Summary:        PackageKit Entropy backend
238 Summary(pl.UTF-8):      Backend PackageKit Entropy
239 Group:          Libraries
240 Requires:       %{name} = %{version}-%{release}
241 Requires:       python-packagekit = %{version}-%{release}
242 #Requires:      python-entropy
243 Provides:       %{name}-backend = %{version}-%{release}
244
245 %description backend-entropy
246 A backend for PackageKit to enable Sabayon packages support through
247 Entropy package manager.
248
249 %description backend-entropy -l pl.UTF-8
250 Backend PackageKit dodający obsługę pakietów dystrybucji Sabayon przy
251 użyciu zarządcy pakietów Entropy.
252
253 %package backend-nix
254 Summary:        PackageKit Nix backend
255 Summary(pl.UTF-8):      Backend PackageKit oparty na zarządcy pakietów Nix
256 Group:          Libraries
257 Requires:       %{name} = %{version}-%{release}
258 Requires:       nix >= 1.12
259 Provides:       %{name}-backend = %{version}-%{release}
260
261 %description backend-nix
262 A backend for PackageKit to enable Nix packages support (used in
263 NixOS).
264
265 %description backend-nix -l pl.UTF-8
266 Backend PackageKit dodający obsługę pakietów Nix (używanych w NixOS).
267
268 %package backend-pisi
269 Summary:        PackageKit PiSi backend
270 Summary(pl.UTF-8):      Backend PackageKit PiSi
271 Group:          Libraries
272 Requires:       %{name} = %{version}-%{release}
273 Requires:       python-packagekit = %{version}-%{release}
274 #Requires:      python-piksemel
275 #Requires:      python-pisi
276 Provides:       %{name}-backend = %{version}-%{release}
277
278 %description backend-pisi
279 A backend for PackageKit to enable PiSi packages support. PiSi
280 packages are originated in Pardus distribution.
281
282 %description backend-pisi -l pl.UTF-8
283 Backend PackageKit dodający obsługę pakietów PiSi. Pakiety PiSi
284 wywodzą się z dystrybucji Pardus.
285
286 %package backend-poldek
287 Summary:        PackageKit Poldek backend
288 Summary(pl.UTF-8):      Backend PackageKit oparty na Poldku
289 Group:          Libraries
290 Requires:       %{name} = %{version}-%{release}
291 Requires:       poldek >= 0.30-1.rc6.4
292 Provides:       %{name}-backend = %{version}-%{release}
293
294 %description backend-poldek
295 A backend for PackageKit to enable RPM packages support through Poldek
296 - native PLD package manager.
297
298 %description backend-poldek -l pl.UTF-8
299 Backend PackageKit dodający obsługę pakietów RPM poprzez Poldka -
300 natywnego zarządcę pakietów dystrybucji PLD.
301
302 %package backend-portage
303 Summary:        PackageKit Portage backend
304 Summary(pl.UTF-8):      Backend PackageKit Portage
305 Group:          Libraries
306 Requires:       %{name} = %{version}-%{release}
307 Requires:       python-packagekit = %{version}-%{release}
308 #Requires:      python-portage
309 Provides:       %{name}-backend = %{version}-%{release}
310
311 %description backend-portage
312 A backend for PackageKit to enable Gentoo Portage support.
313
314 %description backend-portage -l pl.UTF-8
315 Backend PackageKit dodający obsługę systemu Portage dystrybucji
316 Gentoo.
317
318 %package backend-ports
319 Summary:        PackageKit Ports backend
320 Summary(pl.UTF-8):      Backend PackageKit Ports
321 Group:          Libraries
322 Requires:       %{name} = %{version}-%{release}
323 #Requires:      ruby-pkgtools
324 Provides:       %{name}-backend = %{version}-%{release}
325
326 %description backend-ports
327 A backend for PackageKit to enable FreeBSD Ports support.
328
329 %description backend-ports -l pl.UTF-8
330 Backend PackageKit dodający obsługę portów systemu FreeBSD.
331
332 %package backend-slack
333 Summary:        PackageKit Slack backend
334 Summary(pl.UTF-8):      Backend PackageKit Slack
335 Group:          Libraries
336 Requires:       %{name} = %{version}-%{release}
337 Provides:       %{name}-backend = %{version}-%{release}
338 Obsoletes:      PackageKit-backend-katja
339
340 %description backend-slack
341 Slack backend for PackageKit to enable Slackware repositories support.
342
343 %description backend-slack -l pl.UTF-8
344 Backend PackageKit Slack dodający obsługę repozytoriów Slackware.
345
346 %package backend-urpmi
347 Summary:        PackageKit URPMI backend
348 Summary(pl.UTF-8):      Backend PackageKit URPMI
349 Group:          Libraries
350 Requires:       %{name} = %{version}-%{release}
351 #Requires:      perl-URPM
352 Provides:       %{name}-backend = %{version}-%{release}
353
354 %description backend-urpmi
355 A backend for PackageKit to enable RPM packages support through URPMI
356 package manager (originated in Mandriva).
357
358 %description backend-urpmi -l pl.UTF-8
359 Backend PackageKit dodający obsługę pakietów RPM poprzez zarządcę
360 URPMI (pochodzącego z dystrybucji Mandriva).
361
362 %package backend-yum
363 Summary:        PackageKit YUM backend
364 Summary(pl.UTF-8):      Backend PackageKit YUM
365 Group:          Libraries
366 Requires:       %{name} = %{version}-%{release}
367 Requires:       python-packagekit = %{version}-%{release}
368 #Requires:      python-urlgrabber
369 #Requires:      python-rpm # ? import rpmUtils
370 #Requires:      python-sqlite3
371 #Requires:      python-yum
372 Provides:       %{name}-backend = %{version}-%{release}
373
374 %description backend-yum
375 A backend for PackageKit to enable RPM packages support using Yum.
376
377 %description backend-yum -l pl.UTF-8
378 Backend PackageKit dodający obsługę pakietów RPM przy użyciu Yuma.
379
380 %package backend-zypp
381 Summary:        PackageKit Zypp backend
382 Summary(pl.UTF-8):      Backend PackageKit Zypp
383 Group:          Libraries
384 Requires:       %{name} = %{version}-%{release}
385 Requires:       libzypp >= 15
386 Provides:       %{name}-backend = %{version}-%{release}
387
388 %description backend-zypp
389 A backend for PackageKit to enable RPM packages support through Zypp
390 library (originated in openSUSE/SLE).
391
392 %description backend-zypp -l pl.UTF-8
393 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
394 Zypp (pochodzącą z dystrybucji openSUSE/SLE).
395
396 %package gstreamer-plugin
397 Summary:        GStreamer codecs installer
398 Summary(pl.UTF-8):      Instalator kodeków GStreamera
399 Group:          Applications
400 Requires:       %{name} = %{version}-%{release}
401 Requires:       %{name}-gtk-module = %{version}-%{release}
402
403 %description gstreamer-plugin
404 The PackageKit GStreamer plugin allows any GStreamer application to
405 install codecs from configured repositories using PackageKit.
406
407 %description gstreamer-plugin -l pl.UTF-8
408 Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
409 zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
410
411 %package gtk-module
412 Summary:        GTK+ module to detect and install missing fonts
413 Summary(pl.UTF-8):      Moduł GTK+ do wykrywania i instalowania brakujących czcionek
414 Group:          X11/Libraries
415
416 %description gtk-module
417 The PackageKit GTK+ module allows any pango application to install
418 missing fonts from configured repositories using PackageKit.
419
420 %description gtk-module -l pl.UTF-8
421 Moduł GTK+ pozwala każdej aplikacji używającej pango zainstalować
422 brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
423
424 %package gtk3-module
425 Summary:        GTK+ 3.x module to detect and install missing fonts
426 Summary(pl.UTF-8):      Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
427 Group:          X11/Libraries
428
429 %description gtk3-module
430 The PackageKit GTK+ 3.x module allows any pango application to install
431 missing fonts from configured repositories using PackageKit.
432
433 %description gtk3-module -l pl.UTF-8
434 Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
435 brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
436
437 %package -n bash-completion-packagekit
438 Summary:        Bash completion for PackageKit console commands
439 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń konsolowych PackageKit
440 Group:          Applications/Shells
441 Requires:       %{name} = %{version}-%{release}
442 Requires:       bash-completion >= 2
443 %if "%{_rpmversion}" >= "4.6"
444 BuildArch:      noarch
445 %endif
446
447 %description -n bash-completion-packagekit
448 This package provides bash-completion for PackageKit console commands.
449
450 %description -n bash-completion-packagekit -l pl.UTF-8
451 Pakiet ten dostarcza bashowe uzupełnianie parametrów dla poleceń
452 konsolowych PackageKit.
453
454 %package -n python-packagekit
455 Summary:        PackageKit Python bindings
456 Summary(pl.UTF-8):      Wiązania PackageKit dla Pythona
457 Group:          Development/Languages/Python
458 Requires:       python-dbus
459 Requires:       python-pygobject
460
461 %description -n python-packagekit
462 PackageKit Python bindings.
463
464 %description -n python-packagekit -l pl.UTF-8
465 Wiązania PackageKit dla Pythona.
466
467 %prep
468 %setup -q
469 %patch0 -p1
470 %patch1 -p1
471
472 %patch3 -p1
473
474 %build
475 %if %{with doc}
476 %{__gtkdocize}
477 %endif
478 %{__intltoolize}
479 %{__libtoolize}
480 %{__aclocal} -I m4
481 %{__autoconf}
482 %{__autoheader}
483 %{__automake}
484 %{?with_zypp:CPPFLAGS="%{rpmcppflags} -D_RPM_5 -I/usr/include/rpm"}
485 %configure \
486         --disable-command-not-found \
487         --disable-dummy \
488         %{!?with_doc:--disable-gtk-doc} \
489         %{!?with_introspection:--disable-introspection} \
490         --disable-silent-rules \
491         --enable-bash-completion=%{bash_compdir} \
492         %{__enable_disable alpm} \
493         %{__enable_disable apt aptcc} \
494         %{__enable_disable dnf} \
495         %{__enable_disable entropy} \
496         %{__enable_disable nix} \
497         %{__enable_disable pisi} \
498         %{__enable_disable poldek} \
499         %{__enable_disable portage} \
500         %{__enable_disable ports} \
501         %{__enable_disable slack} \
502         %{__enable_disable urpmi} \
503         %{__enable_disable yum} \
504         %{__enable_disable zypp} \
505         --with-html-dir=%{_gtkdocdir}
506
507 %{__make}
508
509 %install
510 rm -rf $RPM_BUILD_ROOT
511
512 %{__make} install \
513         DESTDIR=$RPM_BUILD_ROOT
514
515 # use pk-gstreamer-install as codec installer
516 ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libdir}/gst-install-plugins-helper
517
518 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gtk-{2,3}.0/modules/*.{la,a}
519 %{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/*.{la,a}
520 %{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
521 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
522 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/test_spawn
523
524 %py_postclean
525
526 %find_lang %{name}
527
528 %clean
529 rm -rf $RPM_BUILD_ROOT
530
531 %post
532 %update_mime_database
533
534 %postun
535 %update_mime_database
536
537 %post   libs -p /sbin/ldconfig
538 %postun libs -p /sbin/ldconfig
539
540 %files -f %{name}.lang
541 %defattr(644,root,root,755)
542 %doc AUTHORS HACKING MAINTAINERS NEWS README
543 %attr(755,root,root) %{_bindir}/pkcon
544 %attr(755,root,root) %{_bindir}/pkmon
545 %attr(750,root,root) /etc/cron.daily/packagekit-background.cron
546 %attr(755,root,root) %{_libexecdir}/packagekit-direct
547 %attr(755,root,root) %{_libexecdir}/packagekitd
548 %attr(755,root,root) %{_libexecdir}/pk-offline-update
549 %dir %{_libdir}/packagekit-backend
550 %dir %{_sysconfdir}/PackageKit
551 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
552 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
553 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
554 /etc/dbus-1/system.d/org.freedesktop.PackageKit.conf
555 %dir %{_datadir}/PackageKit
556 %dir %{_datadir}/PackageKit/helpers
557 %attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
558 %{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
559 %{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
560 %{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
561 %{_mandir}/man1/pkcon.1*
562 %{_mandir}/man1/pkmon.1*
563 %{systemdunitdir}/packagekit.service
564 %{systemdunitdir}/packagekit-offline-update.service
565 %{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
566 %dir /var/cache/PackageKit
567 %dir /var/cache/PackageKit/downloads
568 %dir /var/lib/PackageKit
569 %ghost /var/lib/PackageKit/transactions.db
570
571 %files libs
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
574 %attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.18
575 %{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
576 # NOTE: dbus interface xmls are commonly used:
577 # - at runtime by packagekitd
578 # - for development of applications using PK dbus interface
579 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
580 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
581
582 %files devel
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
585 %{_pkgconfigdir}/packagekit-glib2.pc
586 %dir %{_includedir}/PackageKit
587 %{_includedir}/PackageKit/packagekit-glib2
588 %{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
589
590 %files static
591 %defattr(644,root,root,755)
592 %{_libdir}/libpackagekit-glib2.a
593
594 %if %{with vala}
595 %files -n vala-packagekit
596 %defattr(644,root,root,755)
597 %{_datadir}/vala/vapi/packagekit-glib2.vapi
598 %endif
599
600 %files apidocs
601 %defattr(644,root,root,755)
602 %{_gtkdocdir}/PackageKit
603
604 %if %{with alpm}
605 %files backend-alpm
606 %defattr(644,root,root,755)
607 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_alpm.so
608 %dir %{_sysconfdir}/PackageKit/alpm.d
609 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/groups.list
610 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/pacman.conf
611 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/repos.list
612 %endif
613
614 %if %{with apt}
615 %files backend-aptcc
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_aptcc.so
618 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf.d/20packagekit
619 %dir %{_datadir}/PackageKit/helpers/aptcc
620 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/get-distro-upgrade.py
621 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/pkconffile
622 %{_datadir}/PackageKit/helpers/aptcc/pkconffile.nodiff
623 %endif
624
625 %if %{with dnf}
626 %files backend-dnf
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dnf.so
629 %endif
630
631 %if %{with entropy}
632 %files backend-entropy
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_entropy.so
635 %dir %{_datadir}/PackageKit/helpers/entropy
636 %attr(755,root,root) %{_datadir}/PackageKit/helpers/entropy/entropyBackend.py
637 %endif
638
639 %if %{with nix}
640 %files backend-nix
641 %defattr(644,root,root,755)
642 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_nix.so
643 %endif
644
645 %if %{with pisi}
646 %files backend-pisi
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_pisi.so
649 %dir %{_datadir}/PackageKit/helpers/pisi
650 %attr(755,root,root) %{_datadir}/PackageKit/helpers/pisi/pisiBackend.py
651 %endif
652
653 %if %{with poldek}
654 %files backend-poldek
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
657 %endif
658
659 %if %{with portage}
660 %files backend-portage
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_portage.so
663 %dir %{_datadir}/PackageKit/helpers/portage
664 %attr(755,root,root) %{_datadir}/PackageKit/helpers/portage/portageBackend.py
665 %endif
666
667 %if %{with ports}
668 %files backend-ports
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_ports.so
671 %dir %{_datadir}/PackageKit/helpers/ports
672 %attr(755,root,root) %{_datadir}/PackageKit/helpers/ports/portsBackend.rb
673 %{_datadir}/PackageKit/helpers/ports/ruby_packagekit
674 %endif
675
676 %if %{with slack}
677 %files backend-slack
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_slack.so
680 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Slackware.conf
681 %dir /var/cache/PackageKit/metadata
682 %ghost /var/cache/PackageKit/metadata/metadata.db
683 %endif
684
685 %if %{with urpmi}
686 %files backend-urpmi
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_urpmi.so
689 %dir %{_datadir}/PackageKit/helpers/urpmi
690 %attr(755,root,root) %{_datadir}/PackageKit/helpers/urpmi/urpmi-dispatched-backend.pl
691 %{_datadir}/PackageKit/helpers/urpmi/perl_packagekit
692 %{_datadir}/PackageKit/helpers/urpmi/urpmi_backend
693 %endif
694
695 %if %{with yum}
696 %files backend-yum
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_yum.so
699 %{_datadir}/PackageKit/helpers/yum
700 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Yum.conf
701 %endif
702
703 %if %{with zypp}
704 %files backend-zypp
705 %defattr(644,root,root,755)
706 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_zypp.so
707 %endif
708
709 %files gstreamer-plugin
710 %defattr(644,root,root,755)
711 %doc contrib/gstreamer-plugin/README
712 %attr(755,root,root) %{_libdir}/gst-install-plugins-helper
713 %attr(755,root,root) %{_libexecdir}/pk-gstreamer-install
714
715 %files gtk-module
716 %defattr(644,root,root,755)
717 %doc contrib/gtk-module/{GLASS.txt,README}
718 %attr(755,root,root) %{_libdir}/gtk-2.0/modules/libpk-gtk-module.so
719
720 %files gtk3-module
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
723 %{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
724
725 %files -n bash-completion-packagekit
726 %defattr(644,root,root,755)
727 %{bash_compdir}/pkcon
728
729 %if %{with python}
730 %files -n python-packagekit
731 %defattr(644,root,root,755)
732 %dir %{py_sitescriptdir}/packagekit
733 %{py_sitescriptdir}/packagekit/*.py[co]
734 %endif
This page took 0.08807 seconds and 4 git commands to generate.