]> git.pld-linux.org Git - packages/PackageKit.git/blob - PackageKit.spec
BR: docbook-style-xsl-nons
[packages/PackageKit.git] / PackageKit.spec
1 # TODO:
2 # - BASH command-not-found functionality disabled for now as it needs patched bash
3 #   (details in bash from Fedora Rawhide)
4 # - setup dnf vendor properly? (see meson command)
5 # - daemon user (see meson command)
6 #
7 # Conditional build:
8 %bcond_without  apidocs         # API documentation
9 %bcond_without  introspection   # gobject introspection, time to time broken
10 %bcond_without  static_libs     # static library
11 %bcond_without  python          # Python binding (used by entropy and portage backends)
12 %bcond_without  vala            # Vala binding
13 # backends
14 %bcond_with     alpm            # ALPM (Arch Linux package manager) backend
15 %bcond_with     apt             # APT (Debian/Ubuntu) backend using C++ API
16 %bcond_without  dnf             # DNF (Fedora/RHEL/Mageia/OpenMandriva/OpenSUSE/Rosa) backend
17 %bcond_with     entropy         # Entropy (Sabayon) backend (Python)
18 %bcond_with     nix             # Nix (NixOS) backend [broken as of 1.2.0-1.2.5]
19 %bcond_without  poldek          # Poldek (PLD) backend
20 %bcond_with     portage         # portage (Gentoo) backend (Python)
21 %bcond_with     slack           # Slack (Slackware) backend
22 %bcond_with     zypp            # ZYPP (openSUSE/SLE) backend
23
24 %if %{without python}
25 %undefine       with_entropy
26 %undefine       with_portage
27 %endif
28
29 Summary:        System daemon that is a D-Bus abstraction layer for package management
30 Summary(pl.UTF-8):      Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
31 Name:           PackageKit
32 Version:        1.2.7
33 Release:        1
34 License:        GPL v2+
35 Group:          Applications/System
36 Source0:        https://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
37 # Source0-md5:  3bca1b66bff0267515ff0761df2701cf
38 Patch0:         %{name}-poldek.patch
39 Patch2:         %{name}-meson.patch
40 Patch3:         consolekit-fallback.patch
41 URL:            https://www.freedesktop.org/software/PackageKit/
42 %{?with_apt:BuildRequires:      AppStream-devel >= 0.12}
43 BuildRequires:  NetworkManager-devel >= 0.6.5
44 # pkgconfig(libalpm) >= 13.0.0
45 %{?with_alpm:BuildRequires:     alpm-devel >= 6.0}
46 %{?with_dnf:BuildRequires:      appstream-glib-devel}
47 %{?with_apt:BuildRequires:      apt-devel >= 1.9.2}
48 BuildRequires:  bash-completion-devel >= 1:2.0
49 BuildRequires:  connman-devel
50 %{?with_slack:BuildRequires:    curl-devel}
51 BuildRequires:  dbus-devel >= 1.2.0
52 BuildRequires:  dbus-glib-devel >= 0.76
53 BuildRequires:  docbook-dtd412-xml
54 BuildRequires:  docbook-dtd42-xml
55 BuildRequires:  docbook-style-xsl-nons
56 BuildRequires:  fontconfig-devel
57 BuildRequires:  gettext-tools
58 BuildRequires:  glib2-devel >= 1:2.62
59 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.9.9}
60 BuildRequires:  gstreamer-devel >= 1.0.0
61 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
62 BuildRequires:  gtk+3-devel >= 3.0.0
63 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.11}
64 BuildRequires:  libarchive-devel
65 %{?with_dnf:BuildRequires:      libdnf-devel >= 0.43.1}
66 %if %{with apt} || %{with nix}
67 BuildRequires:  libstdc++-devel >= 6:4.7
68 %endif
69 %{?with_slack:BuildRequires:    libstdc++-devel >= 6:5}
70 BuildRequires:  libxslt-progs
71 %{?with_zypp:BuildRequires:     libzypp-devel >= 17.31.0}
72 BuildRequires:  meson >= 0.50
73 BuildRequires:  ninja >= 1.5
74 # nix-expr nix-main nix-store
75 %{?with_nix:BuildRequires:      nix-devel >= 2.9}
76 BuildRequires:  pango-devel
77 BuildRequires:  pkgconfig
78 # just to detect which reboot modes to use (library not linked)
79 #BuildRequires: plymouth-devel >= 0.9.5
80 %{?with_poldek:BuildRequires:   poldek-devel >= 0.30-1.rc6.4}
81 BuildRequires:  polkit-devel >= 0.114
82 %{?with_python:BuildRequires:   python3-devel >= 1:3.2}
83 BuildRequires:  readline-devel
84 BuildRequires:  rpm-build >= 4.6
85 %{?with_dnf:BuildRequires:      rpm-devel >= 1:4.6}
86 BuildRequires:  rpm-pythonprov
87 BuildRequires:  rpmbuild(macros) >= 1.736
88 BuildRequires:  sed >= 4.0
89 BuildRequires:  sqlite3-devel >= 3
90 # or elogind >= 229.4
91 BuildRequires:  systemd-devel >= 1:213
92 BuildRequires:  tar >= 1:1.22
93 BuildRequires:  udev-glib-devel
94 %{?with_vala:BuildRequires:     vala >= 2:0.16}
95 BuildRequires:  xz
96 Requires(post,postun):  shared-mime-info
97 Requires:       %{name}-backend
98 Requires:       %{name}-libs = %{version}-%{release}
99 Requires:       crondaemon
100 Requires:       polkit >= 0.114
101 Suggests:       ConsoleKit-x11
102 Obsoletes:      PackageKit-backend-pisi < 1.2
103 Obsoletes:      PackageKit-backend-ports < 1.2
104 Obsoletes:      PackageKit-backend-smart < 1.0
105 Obsoletes:      PackageKit-backend-urpmi < 1.2
106 Obsoletes:      PackageKit-backend-yum < 1.2
107 Obsoletes:      PackageKit-docs < 0.8.4
108 Obsoletes:      pm-utils-packagekit < 0.8.15
109 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
110
111 %description
112 PackageKit is a D-Bus abstraction layer that allows the session user
113 to manage packages in a secure way using a cross-distro,
114 cross-architecture API.
115
116 %description -l pl.UTF-8
117 PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
118 sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
119 zgodnego z wieloma dystrybucjami i architekturami.
120
121 %package libs
122 Summary:        packagekit-glib library
123 Summary(pl.UTF-8):      Biblioteka packagekit-glib
124 Group:          Libraries
125 Requires:       glib2 >= 1:2.62
126 Obsoletes:      browser-plugin-packagekit < 1.1.0
127
128 %description libs
129 packagekit-glib library.
130
131 %description libs -l pl.UTF-8
132 Biblioteka packagekit-glib.
133
134 %package devel
135 Summary:        Header files for packagekit-glib library
136 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki packagekit-glib
137 Group:          Development/Libraries
138 Requires:       %{name}-libs = %{version}-%{release}
139 Requires:       dbus-devel >= 1.2.0
140 Requires:       glib2-devel >= 1:2.62
141 Requires:       sqlite3-devel
142
143 %description devel
144 Header files for packagekit-glib library.
145
146 %description devel -l pl.UTF-8
147 Pliki nagłówkowe biblioteki packagekit-glib.
148
149 %package static
150 Summary:        Static packagekit-glib library
151 Summary(pl.UTF-8):      Statyczna biblioteka packagekit-glib
152 Group:          Development/Libraries
153 Requires:       %{name}-devel = %{version}-%{release}
154
155 %description static
156 Static packagekit-glib library.
157
158 %description static -l pl.UTF-8
159 Statyczna biblioteka packagekit-glib.
160
161 %package -n vala-packagekit
162 Summary:        Vala API for PackageKit library
163 Summary(pl.UTF-8):      API języka Vala do biblioteki PackageKitu
164 Group:          Development/Libraries
165 Requires:       %{name}-devel = %{version}-%{release}
166 Requires:       vala >= 2:0.16
167 BuildArch:      noarch
168
169 %description -n vala-packagekit
170 Vala API for PackageKit library.
171
172 %description -n vala-packagekit -l pl.UTF-8
173 API języka Vala do biblioteki PackageKitu.
174
175 %package apidocs
176 Summary:        PackageKit library API documentation
177 Summary(pl.UTF-8):      Dokumentacja API biblioteki PackageKit
178 Group:          Documentation
179 Requires:       gtk-doc-common
180 BuildArch:      noarch
181
182 %description apidocs
183 PackageKit library API documentation.
184
185 %description apidocs -l pl.UTF-8
186 Dokumentacja API biblioteki PackageKit.
187
188 %package backend-alpm
189 Summary:        PackageKit ALPM backend
190 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece ALPM
191 Group:          Libraries
192 Requires:       %{name} = %{version}-%{release}
193 Provides:       %{name}-backend = %{version}-%{release}
194
195 %description backend-alpm
196 A backend for PackageKit to enable Arch Linux packages via ALPM
197 library.
198
199 %description backend-alpm -l pl.UTF-8
200 Backend PackageKit dodający obsługę pakietów Arch Linuksa poprzez
201 bibliotekę ALPM.
202
203 %package backend-aptcc
204 Summary:        PackageKit APTcc backend
205 Summary(pl.UTF-8):      Backend PackageKit APTcc
206 Group:          Libraries
207 Requires:       %{name} = %{version}-%{release}
208 Requires:       AppStream >= 0.12
209 Requires:       apt >= 1.9.2
210 Provides:       %{name}-backend = %{version}-%{release}
211
212 %description backend-aptcc
213 A backend for PackageKit to enable APT support via C++ API.
214
215 %description backend-aptcc -l pl.UTF-8
216 Backend PackageKit dodający obsługę zarządcy pakietów APT poprzez API
217 C++.
218
219 %package backend-dnf
220 Summary:        PackageKit dnf backend
221 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece dnfhif
222 Group:          Libraries
223 Requires:       %{name} = %{version}-%{release}
224 Requires:       libdnf >= 0.43.1
225 Requires:       rpm >= 1:4.6
226 Provides:       %{name}-backend = %{version}-%{release}
227 Obsoletes:      PackageKit-backend-hawkey < 1.0
228 Obsoletes:      PackageKit-backend-hif < 1.2
229
230 %description backend-dnf
231 A backend for PackageKit to enable RPM packages support via dnf
232 library (used in Fedora).
233
234 %description backend-dnf -l pl.UTF-8
235 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
236 dnf (używaną w dystrybucji Fedora).
237
238 %package backend-entropy
239 Summary:        PackageKit Entropy backend
240 Summary(pl.UTF-8):      Backend PackageKit Entropy
241 Group:          Libraries
242 Requires:       %{name} = %{version}-%{release}
243 Requires:       python3-packagekit = %{version}-%{release}
244 #Requires:      python3-entropy
245 Provides:       %{name}-backend = %{version}-%{release}
246
247 %description backend-entropy
248 A backend for PackageKit to enable Sabayon packages support through
249 Entropy package manager.
250
251 %description backend-entropy -l pl.UTF-8
252 Backend PackageKit dodający obsługę pakietów dystrybucji Sabayon przy
253 użyciu zarządcy pakietów Entropy.
254
255 %package backend-nix
256 Summary:        PackageKit Nix backend
257 Summary(pl.UTF-8):      Backend PackageKit oparty na zarządcy pakietów Nix
258 Group:          Libraries
259 Requires:       %{name} = %{version}-%{release}
260 Requires:       nix >= 2.9
261 Provides:       %{name}-backend = %{version}-%{release}
262
263 %description backend-nix
264 A backend for PackageKit to enable Nix packages support (used in
265 NixOS).
266
267 %description backend-nix -l pl.UTF-8
268 Backend PackageKit dodający obsługę pakietów Nix (używanych w NixOS).
269
270 %package backend-poldek
271 Summary:        PackageKit Poldek backend
272 Summary(pl.UTF-8):      Backend PackageKit oparty na Poldku
273 Group:          Libraries
274 Requires:       %{name} = %{version}-%{release}
275 Requires:       poldek >= 0.30-1.rc6.4
276 Provides:       %{name}-backend = %{version}-%{release}
277
278 %description backend-poldek
279 A backend for PackageKit to enable RPM packages support through Poldek
280 - native PLD package manager.
281
282 %description backend-poldek -l pl.UTF-8
283 Backend PackageKit dodający obsługę pakietów RPM poprzez Poldka -
284 natywnego zarządcę pakietów dystrybucji PLD.
285
286 %package backend-portage
287 Summary:        PackageKit Portage backend
288 Summary(pl.UTF-8):      Backend PackageKit Portage
289 Group:          Libraries
290 Requires:       %{name} = %{version}-%{release}
291 Requires:       python3-packagekit = %{version}-%{release}
292 #Requires:      python3-portage
293 Provides:       %{name}-backend = %{version}-%{release}
294
295 %description backend-portage
296 A backend for PackageKit to enable Gentoo Portage support.
297
298 %description backend-portage -l pl.UTF-8
299 Backend PackageKit dodający obsługę systemu Portage dystrybucji
300 Gentoo.
301
302 %package backend-slack
303 Summary:        PackageKit Slack backend
304 Summary(pl.UTF-8):      Backend PackageKit Slack
305 Group:          Libraries
306 Requires:       %{name} = %{version}-%{release}
307 Provides:       %{name}-backend = %{version}-%{release}
308 Obsoletes:      PackageKit-backend-katja < 1.2
309
310 %description backend-slack
311 Slack backend for PackageKit to enable Slackware repositories support.
312
313 %description backend-slack -l pl.UTF-8
314 Backend PackageKit Slack dodający obsługę repozytoriów Slackware.
315
316 %package backend-zypp
317 Summary:        PackageKit Zypp backend
318 Summary(pl.UTF-8):      Backend PackageKit Zypp
319 Group:          Libraries
320 Requires:       %{name} = %{version}-%{release}
321 Requires:       libzypp >= 17.31.0
322 Provides:       %{name}-backend = %{version}-%{release}
323
324 %description backend-zypp
325 A backend for PackageKit to enable RPM packages support through Zypp
326 library (originated in openSUSE/SLE).
327
328 %description backend-zypp -l pl.UTF-8
329 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
330 Zypp (pochodzącą z dystrybucji openSUSE/SLE).
331
332 %package gstreamer-plugin
333 Summary:        GStreamer codecs installer
334 Summary(pl.UTF-8):      Instalator kodeków GStreamera
335 Group:          Applications
336 Requires:       %{name} = %{version}-%{release}
337 Requires:       %{name}-gtk3-module = %{version}-%{release}
338
339 %description gstreamer-plugin
340 The PackageKit GStreamer plugin allows any GStreamer application to
341 install codecs from configured repositories using PackageKit.
342
343 %description gstreamer-plugin -l pl.UTF-8
344 Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
345 zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
346
347 %package gtk3-module
348 Summary:        GTK+ 3.x module to detect and install missing fonts
349 Summary(pl.UTF-8):      Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
350 Group:          X11/Libraries
351 Obsoletes:      PackageKit-gtk-module < 1.2.0
352
353 %description gtk3-module
354 The PackageKit GTK+ 3.x module allows any pango application to install
355 missing fonts from configured repositories using PackageKit.
356
357 %description gtk3-module -l pl.UTF-8
358 Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
359 brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
360
361 %package -n bash-completion-packagekit
362 Summary:        Bash completion for PackageKit console commands
363 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń konsolowych PackageKit
364 Group:          Applications/Shells
365 Requires:       %{name} = %{version}-%{release}
366 Requires:       bash-completion >= 1:2.0
367 BuildArch:      noarch
368
369 %description -n bash-completion-packagekit
370 This package provides bash-completion for PackageKit console commands.
371
372 %description -n bash-completion-packagekit -l pl.UTF-8
373 Pakiet ten dostarcza bashowe uzupełnianie parametrów dla poleceń
374 konsolowych PackageKit.
375
376 %package -n python3-packagekit
377 Summary:        PackageKit Python bindings
378 Summary(pl.UTF-8):      Wiązania PackageKit dla Pythona
379 Group:          Development/Languages/Python
380 Obsoletes:      python-packagekit < 1.2.7
381
382 %description -n python3-packagekit
383 PackageKit Python bindings.
384
385 %description -n python3-packagekit -l pl.UTF-8
386 Wiązania PackageKit dla Pythona.
387
388 %prep
389 %setup -q
390 %patch0 -p1
391 %patch2 -p1
392 %patch3 -p1
393
394 %if %{with static_libs}
395 %{__sed} -i -e '/^packagekit_glib2_library =/ s/shared_library/library/' lib/packagekit-glib2/meson.build
396 %endif
397
398 %build
399 %meson build \
400         --python.bytecompile=2 \
401         -Dbash_command_not_found=false \
402         %{!?with_introspection:-Dgobject_introspection=false} \
403         %{?with_apidocs:-Dgtk_doc=true} \
404         -Dpackaging_backend=dummy%{?with_alpm:,alpm}%{?with_apt:,aptcc}%{?with_dnf:,dnf}%{?with_entropy:,entropy}%{?with_poldek:,poldek}%{?with_portage:,portage}%{?with_slack:,slack}%{?with_zypp:,zypp}%{?with_nix:,nix} \
405         %{!?with_python:-Dpython_backend=false} \
406         -Dsystemdsystemunitdir=%{systemdunitdir}
407
408 # TODO:
409 # -Ddnf_vendor=
410 # -Dpackagekit_user=
411
412 %ninja_build -C build
413
414 %install
415 rm -rf $RPM_BUILD_ROOT
416 install -d $RPM_BUILD_ROOT/var/cache/PackageKit/downloads
417
418 %ninja_install -C build
419
420 %{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
421 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/test_spawn
422
423 # use pk-gstreamer-install as codec installer
424 ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libexecdir}/gst-install-plugins-helper
425
426 install -d $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants
427 ln -sf ../packagekit-offline-update.service \
428         $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
429
430 %find_lang %{name}
431
432 %clean
433 rm -rf $RPM_BUILD_ROOT
434
435 %post
436 %update_mime_database
437
438 %postun
439 %update_mime_database
440
441 %post   libs -p /sbin/ldconfig
442 %postun libs -p /sbin/ldconfig
443
444 %files -f %{name}.lang
445 %defattr(644,root,root,755)
446 %doc AUTHORS HACKING MAINTAINERS NEWS README
447 %attr(755,root,root) %{_bindir}/pkcon
448 %attr(755,root,root) %{_bindir}/pkmon
449 %attr(750,root,root) /etc/cron.daily/packagekit-background.cron
450 %attr(755,root,root) %{_libexecdir}/packagekit-direct
451 %attr(755,root,root) %{_libexecdir}/packagekitd
452 %attr(755,root,root) %{_libexecdir}/pk-offline-update
453 %dir %{_libdir}/packagekit-backend
454 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dummy.so
455 %dir %{_sysconfdir}/PackageKit
456 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
457 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
458 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
459 %dir %{_datadir}/PackageKit
460 %dir %{_datadir}/PackageKit/helpers
461 %attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
462 %{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
463 %{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
464 %{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
465 %{_datadir}/dbus-1/system.d/org.freedesktop.PackageKit.conf
466 %{_mandir}/man1/pkcon.1*
467 %{_mandir}/man1/pkmon.1*
468 %{systemdunitdir}/packagekit.service
469 %{systemdunitdir}/packagekit-offline-update.service
470 %{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
471 %dir /var/cache/PackageKit
472 %dir /var/cache/PackageKit/downloads
473 %dir /var/lib/PackageKit
474 %ghost /var/lib/PackageKit/transactions.db
475
476 %files libs
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
479 %attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.18
480 %{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
481 # NOTE: dbus interface xmls are commonly used:
482 # - at runtime by packagekitd
483 # - for development of applications using PK dbus interface
484 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
485 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
486
487 %files devel
488 %defattr(644,root,root,755)
489 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
490 %{_pkgconfigdir}/packagekit-glib2.pc
491 %dir %{_includedir}/PackageKit
492 %{_includedir}/PackageKit/packagekit-glib2
493 %{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
494
495 %if %{with static_libs}
496 %files static
497 %defattr(644,root,root,755)
498 %{_libdir}/libpackagekit-glib2.a
499 %endif
500
501 %if %{with vala}
502 %files -n vala-packagekit
503 %defattr(644,root,root,755)
504 %{_datadir}/vala/vapi/packagekit-glib2.deps
505 %{_datadir}/vala/vapi/packagekit-glib2.vapi
506 %endif
507
508 %if %{with apidocs}
509 %files apidocs
510 %defattr(644,root,root,755)
511 %{_gtkdocdir}/PackageKit
512 %endif
513
514 %if %{with alpm}
515 %files backend-alpm
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_alpm.so
518 %dir %{_sysconfdir}/PackageKit/alpm.d
519 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/groups.list
520 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/pacman.conf
521 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/repos.list
522 # FIXME: dirs should be owned by alpm?
523 %dir %{_datadir}/libalpm
524 %dir %{_datadir}/libalpm/hooks
525 %{_datadir}/libalpm/hooks/90-packagekit-refresh.hook
526 %endif
527
528 %if %{with apt}
529 %files backend-aptcc
530 %defattr(644,root,root,755)
531 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_aptcc.so
532 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf.d/20packagekit
533 %dir %{_datadir}/PackageKit/helpers/aptcc
534 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/get-distro-upgrade.py
535 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/pkconffile
536 %{_datadir}/PackageKit/helpers/aptcc/pkconffile.nodiff
537 %endif
538
539 %if %{with dnf}
540 %files backend-dnf
541 %defattr(644,root,root,755)
542 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dnf.so
543 %attr(755,root,root) %{_libexecdir}/packagekit-dnf-refresh-repo
544 %{py3_sitescriptdir}/dnf-plugins/notify_packagekit.py
545 %{py3_sitescriptdir}/dnf-plugins/__pycache__/notify_packagekit.cpython-*.py[co]
546 %endif
547
548 %if %{with entropy}
549 %files backend-entropy
550 %defattr(644,root,root,755)
551 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_entropy.so
552 %dir %{_datadir}/PackageKit/helpers/entropy
553 %attr(755,root,root) %{_datadir}/PackageKit/helpers/entropy/entropyBackend.py
554 %endif
555
556 %if %{with nix}
557 %files backend-nix
558 %defattr(644,root,root,755)
559 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_nix.so
560 %endif
561
562 %if %{with poldek}
563 %files backend-poldek
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
566 %endif
567
568 %if %{with portage}
569 %files backend-portage
570 %defattr(644,root,root,755)
571 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_portage.so
572 %dir %{_datadir}/PackageKit/helpers/portage
573 %attr(755,root,root) %{_datadir}/PackageKit/helpers/portage/portageBackend.py
574 %endif
575
576 %if %{with slack}
577 %files backend-slack
578 %defattr(644,root,root,755)
579 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_slack.so
580 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Slackware.conf
581 %dir /var/cache/PackageKit/metadata
582 %ghost /var/cache/PackageKit/metadata/metadata.db
583 %endif
584
585 %if %{with zypp}
586 %files backend-zypp
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_zypp.so
589 %endif
590
591 %files gstreamer-plugin
592 %defattr(644,root,root,755)
593 %doc contrib/gstreamer-plugin/README
594 %attr(755,root,root) %{_libexecdir}/gst-install-plugins-helper
595 %attr(755,root,root) %{_libexecdir}/pk-gstreamer-install
596
597 %files gtk3-module
598 %defattr(644,root,root,755)
599 %doc contrib/gtk-module/{GLASS.txt,README}
600 %attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
601 %{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
602
603 %files -n bash-completion-packagekit
604 %defattr(644,root,root,755)
605 %{bash_compdir}/pkcon
606
607 %if %{with python}
608 %files -n python3-packagekit
609 %defattr(644,root,root,755)
610 %{py3_sitescriptdir}/packagekit
611 %endif
This page took 0.16267 seconds and 4 git commands to generate.