]> git.pld-linux.org Git - packages/PackageKit.git/blob - PackageKit.spec
- updated to 1.2.7; switched to python3
[packages/PackageKit.git] / PackageKit.spec
1 # TODO:
2 # - BASH command-not-found functionality disabled for now as it needs patched bash
3 #   (details in bash from Fedora Rawhide)
4 # - setup dnf vendor properly? (see meson command)
5 # - daemon user (see meson command)
6 #
7 # Conditional build:
8 %bcond_without  apidocs         # API documentation
9 %bcond_without  introspection   # gobject introspection, time to time broken
10 %bcond_without  static_libs     # static library
11 %bcond_without  python          # Python binding (used by entropy and portage backends)
12 %bcond_without  vala            # Vala binding
13 # backends
14 %bcond_with     alpm            # ALPM (Arch Linux package manager) backend
15 %bcond_with     apt             # APT (Debian/Ubuntu) backend using C++ API
16 %bcond_without  dnf             # DNF (Fedora/RHEL/Mageia/OpenMandriva/OpenSUSE/Rosa) backend
17 %bcond_with     entropy         # Entropy (Sabayon) backend (Python)
18 %bcond_with     nix             # Nix (NixOS) backend [broken as of 1.2.0-1.2.5]
19 %bcond_without  poldek          # Poldek (PLD) backend
20 %bcond_with     portage         # portage (Gentoo) backend (Python)
21 %bcond_with     slack           # Slack (Slackware) backend
22 %bcond_with     zypp            # ZYPP (openSUSE/SLE) backend
23
24 %if %{without python}
25 %undefine       with_entropy
26 %undefine       with_portage
27 %endif
28
29 Summary:        System daemon that is a D-Bus abstraction layer for package management
30 Summary(pl.UTF-8):      Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
31 Name:           PackageKit
32 Version:        1.2.7
33 Release:        1
34 License:        GPL v2+
35 Group:          Applications/System
36 Source0:        https://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
37 # Source0-md5:  3bca1b66bff0267515ff0761df2701cf
38 Patch0:         %{name}-poldek.patch
39 Patch2:         %{name}-meson.patch
40 Patch3:         consolekit-fallback.patch
41 URL:            https://www.freedesktop.org/software/PackageKit/
42 %{?with_apt:BuildRequires:      AppStream-devel >= 0.12}
43 BuildRequires:  NetworkManager-devel >= 0.6.5
44 # pkgconfig(libalpm) >= 13.0.0
45 %{?with_alpm:BuildRequires:     alpm-devel >= 6.0}
46 %{?with_dnf:BuildRequires:      appstream-glib-devel}
47 %{?with_apt:BuildRequires:      apt-devel >= 1.9.2}
48 BuildRequires:  bash-completion-devel >= 1:2.0
49 BuildRequires:  connman-devel
50 %{?with_slack:BuildRequires:    curl-devel}
51 BuildRequires:  dbus-devel >= 1.2.0
52 BuildRequires:  dbus-glib-devel >= 0.76
53 BuildRequires:  docbook-dtd412-xml
54 BuildRequires:  docbook-dtd42-xml
55 BuildRequires:  fontconfig-devel
56 BuildRequires:  gettext-tools
57 BuildRequires:  glib2-devel >= 1:2.62
58 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.9.9}
59 BuildRequires:  gstreamer-devel >= 1.0.0
60 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
61 BuildRequires:  gtk+3-devel >= 3.0.0
62 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.11}
63 BuildRequires:  libarchive-devel
64 %{?with_dnf:BuildRequires:      libdnf-devel >= 0.43.1}
65 %if %{with apt} || %{with nix}
66 BuildRequires:  libstdc++-devel >= 6:4.7
67 %endif
68 %{?with_slack:BuildRequires:    libstdc++-devel >= 6:5}
69 BuildRequires:  libxslt-progs
70 %{?with_zypp:BuildRequires:     libzypp-devel >= 17.31.0}
71 BuildRequires:  meson >= 0.50
72 BuildRequires:  ninja >= 1.5
73 # nix-expr nix-main nix-store
74 %{?with_nix:BuildRequires:      nix-devel >= 2.9}
75 BuildRequires:  pango-devel
76 BuildRequires:  pkgconfig
77 # just to detect which reboot modes to use (library not linked)
78 #BuildRequires: plymouth-devel >= 0.9.5
79 %{?with_poldek:BuildRequires:   poldek-devel >= 0.30-1.rc6.4}
80 BuildRequires:  polkit-devel >= 0.114
81 %{?with_python:BuildRequires:   python3-devel >= 1:3.2}
82 BuildRequires:  readline-devel
83 BuildRequires:  rpm-build >= 4.6
84 %{?with_dnf:BuildRequires:      rpm-devel >= 1:4.6}
85 BuildRequires:  rpm-pythonprov
86 BuildRequires:  rpmbuild(macros) >= 1.736
87 BuildRequires:  sed >= 4.0
88 BuildRequires:  sqlite3-devel >= 3
89 # or elogind >= 229.4
90 BuildRequires:  systemd-devel >= 1:213
91 BuildRequires:  tar >= 1:1.22
92 BuildRequires:  udev-glib-devel
93 %{?with_vala:BuildRequires:     vala >= 2:0.16}
94 BuildRequires:  xz
95 Requires(post,postun):  shared-mime-info
96 Requires:       %{name}-backend
97 Requires:       %{name}-libs = %{version}-%{release}
98 Requires:       crondaemon
99 Requires:       polkit >= 0.114
100 Suggests:       ConsoleKit-x11
101 Obsoletes:      PackageKit-backend-pisi < 1.2
102 Obsoletes:      PackageKit-backend-ports < 1.2
103 Obsoletes:      PackageKit-backend-smart < 1.0
104 Obsoletes:      PackageKit-backend-urpmi < 1.2
105 Obsoletes:      PackageKit-backend-yum < 1.2
106 Obsoletes:      PackageKit-docs < 0.8.4
107 Obsoletes:      pm-utils-packagekit < 0.8.15
108 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
109
110 %description
111 PackageKit is a D-Bus abstraction layer that allows the session user
112 to manage packages in a secure way using a cross-distro,
113 cross-architecture API.
114
115 %description -l pl.UTF-8
116 PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
117 sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
118 zgodnego z wieloma dystrybucjami i architekturami.
119
120 %package libs
121 Summary:        packagekit-glib library
122 Summary(pl.UTF-8):      Biblioteka packagekit-glib
123 Group:          Libraries
124 Requires:       glib2 >= 1:2.62
125 Obsoletes:      browser-plugin-packagekit < 1.1.0
126
127 %description libs
128 packagekit-glib library.
129
130 %description libs -l pl.UTF-8
131 Biblioteka packagekit-glib.
132
133 %package devel
134 Summary:        Header files for packagekit-glib library
135 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki packagekit-glib
136 Group:          Development/Libraries
137 Requires:       %{name}-libs = %{version}-%{release}
138 Requires:       dbus-devel >= 1.2.0
139 Requires:       glib2-devel >= 1:2.62
140 Requires:       sqlite3-devel
141
142 %description devel
143 Header files for packagekit-glib library.
144
145 %description devel -l pl.UTF-8
146 Pliki nagłówkowe biblioteki packagekit-glib.
147
148 %package static
149 Summary:        Static packagekit-glib library
150 Summary(pl.UTF-8):      Statyczna biblioteka packagekit-glib
151 Group:          Development/Libraries
152 Requires:       %{name}-devel = %{version}-%{release}
153
154 %description static
155 Static packagekit-glib library.
156
157 %description static -l pl.UTF-8
158 Statyczna biblioteka packagekit-glib.
159
160 %package -n vala-packagekit
161 Summary:        Vala API for PackageKit library
162 Summary(pl.UTF-8):      API języka Vala do biblioteki PackageKitu
163 Group:          Development/Libraries
164 Requires:       %{name}-devel = %{version}-%{release}
165 Requires:       vala >= 2:0.16
166 BuildArch:      noarch
167
168 %description -n vala-packagekit
169 Vala API for PackageKit library.
170
171 %description -n vala-packagekit -l pl.UTF-8
172 API języka Vala do biblioteki PackageKitu.
173
174 %package apidocs
175 Summary:        PackageKit library API documentation
176 Summary(pl.UTF-8):      Dokumentacja API biblioteki PackageKit
177 Group:          Documentation
178 Requires:       gtk-doc-common
179 BuildArch:      noarch
180
181 %description apidocs
182 PackageKit library API documentation.
183
184 %description apidocs -l pl.UTF-8
185 Dokumentacja API biblioteki PackageKit.
186
187 %package backend-alpm
188 Summary:        PackageKit ALPM backend
189 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece ALPM
190 Group:          Libraries
191 Requires:       %{name} = %{version}-%{release}
192 Provides:       %{name}-backend = %{version}-%{release}
193
194 %description backend-alpm
195 A backend for PackageKit to enable Arch Linux packages via ALPM
196 library.
197
198 %description backend-alpm -l pl.UTF-8
199 Backend PackageKit dodający obsługę pakietów Arch Linuksa poprzez
200 bibliotekę ALPM.
201
202 %package backend-aptcc
203 Summary:        PackageKit APTcc backend
204 Summary(pl.UTF-8):      Backend PackageKit APTcc
205 Group:          Libraries
206 Requires:       %{name} = %{version}-%{release}
207 Requires:       AppStream >= 0.12
208 Requires:       apt >= 1.9.2
209 Provides:       %{name}-backend = %{version}-%{release}
210
211 %description backend-aptcc
212 A backend for PackageKit to enable APT support via C++ API.
213
214 %description backend-aptcc -l pl.UTF-8
215 Backend PackageKit dodający obsługę zarządcy pakietów APT poprzez API
216 C++.
217
218 %package backend-dnf
219 Summary:        PackageKit dnf backend
220 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece dnfhif
221 Group:          Libraries
222 Requires:       %{name} = %{version}-%{release}
223 Requires:       libdnf >= 0.43.1
224 Requires:       rpm >= 1:4.6
225 Provides:       %{name}-backend = %{version}-%{release}
226 Obsoletes:      PackageKit-backend-hawkey < 1.0
227 Obsoletes:      PackageKit-backend-hif < 1.2
228
229 %description backend-dnf
230 A backend for PackageKit to enable RPM packages support via dnf
231 library (used in Fedora).
232
233 %description backend-dnf -l pl.UTF-8
234 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
235 dnf (używaną w dystrybucji Fedora).
236
237 %package backend-entropy
238 Summary:        PackageKit Entropy backend
239 Summary(pl.UTF-8):      Backend PackageKit Entropy
240 Group:          Libraries
241 Requires:       %{name} = %{version}-%{release}
242 Requires:       python3-packagekit = %{version}-%{release}
243 #Requires:      python3-entropy
244 Provides:       %{name}-backend = %{version}-%{release}
245
246 %description backend-entropy
247 A backend for PackageKit to enable Sabayon packages support through
248 Entropy package manager.
249
250 %description backend-entropy -l pl.UTF-8
251 Backend PackageKit dodający obsługę pakietów dystrybucji Sabayon przy
252 użyciu zarządcy pakietów Entropy.
253
254 %package backend-nix
255 Summary:        PackageKit Nix backend
256 Summary(pl.UTF-8):      Backend PackageKit oparty na zarządcy pakietów Nix
257 Group:          Libraries
258 Requires:       %{name} = %{version}-%{release}
259 Requires:       nix >= 2.9
260 Provides:       %{name}-backend = %{version}-%{release}
261
262 %description backend-nix
263 A backend for PackageKit to enable Nix packages support (used in
264 NixOS).
265
266 %description backend-nix -l pl.UTF-8
267 Backend PackageKit dodający obsługę pakietów Nix (używanych w NixOS).
268
269 %package backend-poldek
270 Summary:        PackageKit Poldek backend
271 Summary(pl.UTF-8):      Backend PackageKit oparty na Poldku
272 Group:          Libraries
273 Requires:       %{name} = %{version}-%{release}
274 Requires:       poldek >= 0.30-1.rc6.4
275 Provides:       %{name}-backend = %{version}-%{release}
276
277 %description backend-poldek
278 A backend for PackageKit to enable RPM packages support through Poldek
279 - native PLD package manager.
280
281 %description backend-poldek -l pl.UTF-8
282 Backend PackageKit dodający obsługę pakietów RPM poprzez Poldka -
283 natywnego zarządcę pakietów dystrybucji PLD.
284
285 %package backend-portage
286 Summary:        PackageKit Portage backend
287 Summary(pl.UTF-8):      Backend PackageKit Portage
288 Group:          Libraries
289 Requires:       %{name} = %{version}-%{release}
290 Requires:       python3-packagekit = %{version}-%{release}
291 #Requires:      python3-portage
292 Provides:       %{name}-backend = %{version}-%{release}
293
294 %description backend-portage
295 A backend for PackageKit to enable Gentoo Portage support.
296
297 %description backend-portage -l pl.UTF-8
298 Backend PackageKit dodający obsługę systemu Portage dystrybucji
299 Gentoo.
300
301 %package backend-slack
302 Summary:        PackageKit Slack backend
303 Summary(pl.UTF-8):      Backend PackageKit Slack
304 Group:          Libraries
305 Requires:       %{name} = %{version}-%{release}
306 Provides:       %{name}-backend = %{version}-%{release}
307 Obsoletes:      PackageKit-backend-katja < 1.2
308
309 %description backend-slack
310 Slack backend for PackageKit to enable Slackware repositories support.
311
312 %description backend-slack -l pl.UTF-8
313 Backend PackageKit Slack dodający obsługę repozytoriów Slackware.
314
315 %package backend-zypp
316 Summary:        PackageKit Zypp backend
317 Summary(pl.UTF-8):      Backend PackageKit Zypp
318 Group:          Libraries
319 Requires:       %{name} = %{version}-%{release}
320 Requires:       libzypp >= 17.31.0
321 Provides:       %{name}-backend = %{version}-%{release}
322
323 %description backend-zypp
324 A backend for PackageKit to enable RPM packages support through Zypp
325 library (originated in openSUSE/SLE).
326
327 %description backend-zypp -l pl.UTF-8
328 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
329 Zypp (pochodzącą z dystrybucji openSUSE/SLE).
330
331 %package gstreamer-plugin
332 Summary:        GStreamer codecs installer
333 Summary(pl.UTF-8):      Instalator kodeków GStreamera
334 Group:          Applications
335 Requires:       %{name} = %{version}-%{release}
336 Requires:       %{name}-gtk3-module = %{version}-%{release}
337
338 %description gstreamer-plugin
339 The PackageKit GStreamer plugin allows any GStreamer application to
340 install codecs from configured repositories using PackageKit.
341
342 %description gstreamer-plugin -l pl.UTF-8
343 Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
344 zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
345
346 %package gtk3-module
347 Summary:        GTK+ 3.x module to detect and install missing fonts
348 Summary(pl.UTF-8):      Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
349 Group:          X11/Libraries
350 Obsoletes:      PackageKit-gtk-module < 1.2.0
351
352 %description gtk3-module
353 The PackageKit GTK+ 3.x module allows any pango application to install
354 missing fonts from configured repositories using PackageKit.
355
356 %description gtk3-module -l pl.UTF-8
357 Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
358 brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
359
360 %package -n bash-completion-packagekit
361 Summary:        Bash completion for PackageKit console commands
362 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń konsolowych PackageKit
363 Group:          Applications/Shells
364 Requires:       %{name} = %{version}-%{release}
365 Requires:       bash-completion >= 1:2.0
366 BuildArch:      noarch
367
368 %description -n bash-completion-packagekit
369 This package provides bash-completion for PackageKit console commands.
370
371 %description -n bash-completion-packagekit -l pl.UTF-8
372 Pakiet ten dostarcza bashowe uzupełnianie parametrów dla poleceń
373 konsolowych PackageKit.
374
375 %package -n python3-packagekit
376 Summary:        PackageKit Python bindings
377 Summary(pl.UTF-8):      Wiązania PackageKit dla Pythona
378 Group:          Development/Languages/Python
379 Obsoletes:      python-packagekit < 1.2.7
380
381 %description -n python3-packagekit
382 PackageKit Python bindings.
383
384 %description -n python3-packagekit -l pl.UTF-8
385 Wiązania PackageKit dla Pythona.
386
387 %prep
388 %setup -q
389 %patch0 -p1
390 %patch2 -p1
391 %patch3 -p1
392
393 %if %{with static_libs}
394 %{__sed} -i -e '/^packagekit_glib2_library =/ s/shared_library/library/' lib/packagekit-glib2/meson.build
395 %endif
396
397 %build
398 %meson build \
399         --python.bytecompile=2 \
400         -Dbash_command_not_found=false \
401         %{!?with_introspection:-Dgobject_introspection=false} \
402         %{?with_apidocs:-Dgtk_doc=true} \
403         -Dpackaging_backend=dummy%{?with_alpm:,alpm}%{?with_apt:,aptcc}%{?with_dnf:,dnf}%{?with_entropy:,entropy}%{?with_poldek:,poldek}%{?with_portage:,portage}%{?with_slack:,slack}%{?with_zypp:,zypp}%{?with_nix:,nix} \
404         %{!?with_python:-Dpython_backend=false} \
405         -Dsystemdsystemunitdir=%{systemdunitdir}
406
407 # TODO:
408 # -Ddnf_vendor=
409 # -Dpackagekit_user=
410
411 %ninja_build -C build
412
413 %install
414 rm -rf $RPM_BUILD_ROOT
415 install -d $RPM_BUILD_ROOT/var/cache/PackageKit/downloads
416
417 %ninja_install -C build
418
419 %{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
420 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/test_spawn
421
422 # use pk-gstreamer-install as codec installer
423 ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libexecdir}/gst-install-plugins-helper
424
425 install -d $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants
426 ln -sf ../packagekit-offline-update.service \
427         $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
428
429 %find_lang %{name}
430
431 %clean
432 rm -rf $RPM_BUILD_ROOT
433
434 %post
435 %update_mime_database
436
437 %postun
438 %update_mime_database
439
440 %post   libs -p /sbin/ldconfig
441 %postun libs -p /sbin/ldconfig
442
443 %files -f %{name}.lang
444 %defattr(644,root,root,755)
445 %doc AUTHORS HACKING MAINTAINERS NEWS README
446 %attr(755,root,root) %{_bindir}/pkcon
447 %attr(755,root,root) %{_bindir}/pkmon
448 %attr(750,root,root) /etc/cron.daily/packagekit-background.cron
449 %attr(755,root,root) %{_libexecdir}/packagekit-direct
450 %attr(755,root,root) %{_libexecdir}/packagekitd
451 %attr(755,root,root) %{_libexecdir}/pk-offline-update
452 %dir %{_libdir}/packagekit-backend
453 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dummy.so
454 %dir %{_sysconfdir}/PackageKit
455 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
456 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
457 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
458 %dir %{_datadir}/PackageKit
459 %dir %{_datadir}/PackageKit/helpers
460 %attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
461 %{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
462 %{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
463 %{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
464 %{_datadir}/dbus-1/system.d/org.freedesktop.PackageKit.conf
465 %{_mandir}/man1/pkcon.1*
466 %{_mandir}/man1/pkmon.1*
467 %{systemdunitdir}/packagekit.service
468 %{systemdunitdir}/packagekit-offline-update.service
469 %{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
470 %dir /var/cache/PackageKit
471 %dir /var/cache/PackageKit/downloads
472 %dir /var/lib/PackageKit
473 %ghost /var/lib/PackageKit/transactions.db
474
475 %files libs
476 %defattr(644,root,root,755)
477 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
478 %attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.18
479 %{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
480 # NOTE: dbus interface xmls are commonly used:
481 # - at runtime by packagekitd
482 # - for development of applications using PK dbus interface
483 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
484 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
485
486 %files devel
487 %defattr(644,root,root,755)
488 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
489 %{_pkgconfigdir}/packagekit-glib2.pc
490 %dir %{_includedir}/PackageKit
491 %{_includedir}/PackageKit/packagekit-glib2
492 %{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
493
494 %if %{with static_libs}
495 %files static
496 %defattr(644,root,root,755)
497 %{_libdir}/libpackagekit-glib2.a
498 %endif
499
500 %if %{with vala}
501 %files -n vala-packagekit
502 %defattr(644,root,root,755)
503 %{_datadir}/vala/vapi/packagekit-glib2.deps
504 %{_datadir}/vala/vapi/packagekit-glib2.vapi
505 %endif
506
507 %if %{with apidocs}
508 %files apidocs
509 %defattr(644,root,root,755)
510 %{_gtkdocdir}/PackageKit
511 %endif
512
513 %if %{with alpm}
514 %files backend-alpm
515 %defattr(644,root,root,755)
516 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_alpm.so
517 %dir %{_sysconfdir}/PackageKit/alpm.d
518 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/groups.list
519 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/pacman.conf
520 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/repos.list
521 # FIXME: dirs should be owned by alpm?
522 %dir %{_datadir}/libalpm
523 %dir %{_datadir}/libalpm/hooks
524 %{_datadir}/libalpm/hooks/90-packagekit-refresh.hook
525 %endif
526
527 %if %{with apt}
528 %files backend-aptcc
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_aptcc.so
531 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf.d/20packagekit
532 %dir %{_datadir}/PackageKit/helpers/aptcc
533 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/get-distro-upgrade.py
534 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/pkconffile
535 %{_datadir}/PackageKit/helpers/aptcc/pkconffile.nodiff
536 %endif
537
538 %if %{with dnf}
539 %files backend-dnf
540 %defattr(644,root,root,755)
541 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dnf.so
542 %attr(755,root,root) %{_libexecdir}/packagekit-dnf-refresh-repo
543 %{py3_sitescriptdir}/dnf-plugins/notify_packagekit.py
544 %{py3_sitescriptdir}/dnf-plugins/__pycache__/notify_packagekit.cpython-*.py[co]
545 %endif
546
547 %if %{with entropy}
548 %files backend-entropy
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_entropy.so
551 %dir %{_datadir}/PackageKit/helpers/entropy
552 %attr(755,root,root) %{_datadir}/PackageKit/helpers/entropy/entropyBackend.py
553 %endif
554
555 %if %{with nix}
556 %files backend-nix
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_nix.so
559 %endif
560
561 %if %{with poldek}
562 %files backend-poldek
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
565 %endif
566
567 %if %{with portage}
568 %files backend-portage
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_portage.so
571 %dir %{_datadir}/PackageKit/helpers/portage
572 %attr(755,root,root) %{_datadir}/PackageKit/helpers/portage/portageBackend.py
573 %endif
574
575 %if %{with slack}
576 %files backend-slack
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_slack.so
579 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Slackware.conf
580 %dir /var/cache/PackageKit/metadata
581 %ghost /var/cache/PackageKit/metadata/metadata.db
582 %endif
583
584 %if %{with zypp}
585 %files backend-zypp
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_zypp.so
588 %endif
589
590 %files gstreamer-plugin
591 %defattr(644,root,root,755)
592 %doc contrib/gstreamer-plugin/README
593 %attr(755,root,root) %{_libexecdir}/gst-install-plugins-helper
594 %attr(755,root,root) %{_libexecdir}/pk-gstreamer-install
595
596 %files gtk3-module
597 %defattr(644,root,root,755)
598 %doc contrib/gtk-module/{GLASS.txt,README}
599 %attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
600 %{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
601
602 %files -n bash-completion-packagekit
603 %defattr(644,root,root,755)
604 %{bash_compdir}/pkcon
605
606 %if %{with python}
607 %files -n python3-packagekit
608 %defattr(644,root,root,755)
609 %{py3_sitescriptdir}/packagekit
610 %endif
This page took 0.092704 seconds and 3 git commands to generate.