]> git.pld-linux.org Git - packages/OpenColorIO.git/blob - OpenColorIO.spec
- release 2 (by relup.sh)
[packages/OpenColorIO.git] / OpenColorIO.spec
1 # TODO (proprietary?):
2 # - truelight http://www.filmlight.ltd.uk/products/truelight/overview_tl.php
3 # - nuke: http://docs.thefoundry.co.uk/products/nuke/
4 #
5 # Conditional build:
6 %bcond_without  oiio    # OpenImageIO-dependent apps (ocioconvert,ociodisplay)
7 %bcond_without  opengl  # OpenGL-dependent app (ociodisplay)
8 %bcond_without  java    # JNI glue
9 %bcond_without  docs    # documentation
10 %bcond_with     sse2    # use SSE2 instructions
11 #
12 %ifarch %{x8664} pentrium4
13 %define with_sse2       1
14 %endif
15 Summary:        Complete color management solution
16 Summary(pl.UTF-8):      Kompletny pakiet do zarządzania kolorami
17 Name:           OpenColorIO
18 Version:        1.0.8
19 Release:        2
20 License:        BSD
21 Group:          Libraries
22 Source0:        https://github.com/imageworks/OpenColorIO/tarball/v%{version}/%{name}-%{version}.tar.gz
23 # Source0-md5:  9838f5f1cf624a3d1253241f22e2179a
24 Patch0:         %{name}-system-libs.patch
25 Patch1:         %{name}-java.patch
26 Patch2:         %{name}-libsuffix.patch
27 # for yaml-cpp 0.5.0 (unfinished)
28 Patch3:         %{name}-yaml-cpp.patch
29 URL:            http://opencolorio.org/
30 # g++ with tr1 support or...
31 #BuildRequires: boost-devel >= 1.34
32 BuildRequires:  cmake >= 2.8
33 %{?with_java:BuildRequires:     jdk}
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  python-devel
37 %{?with_docs:BuildRequires:     sphinx-pdg >= 1.1}
38 BuildRequires:  tinyxml-devel >= 2.6.1
39 BuildRequires:  yaml-cpp-devel >= 0.2.6
40 BuildRequires:  yaml-cpp-devel < 0.4.0
41 %if %{with opengl}
42 BuildRequires:  OpenGL-devel
43 BuildRequires:  OpenGL-glut-devel
44 BuildRequires:  glew-devel >= 1.5.1
45 %endif
46 %if %{with oiio}
47 BuildRequires:  OpenImageIO-devel
48 BuildRequires:  lcms2-devel >= 2.1
49 %endif
50 Requires:       tinyxml >= 2.6.1
51 Requires:       yaml-cpp >= 0.2.6
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 OpenColorIO (OCIO) is a complete color management solution geared
56 towards motion picture production with an emphasis on visual effects
57 and computer animation. OCIO provides a straightforward and consistent
58 user experience across all supporting applications while allowing for
59 sophisticated back-end configuration options suitable for high-end
60 production usage. OCIO is compatible with the Academy Color Encoding
61 Specification (ACES) and is LUT-format agnostic, supporting many
62 popular formats.
63
64 %description -l pl.UTF-8
65 OpenColorIO (OCIO) to kompletne rozwiązanie zarządzania kolorami
66 przeznaczone do tworzenia obrazów ruchomych, w szczególności efektów
67 wizualnych i animacji komputerowej. OCIO zapewnia proste i spójne
68 elementy we wszystkich współpracujących aplikacjach, pozwalając na
69 wyszukane opcje konfiguracyjne backendu, nadające się do zastosowań
70 produkcyjnych wysokiej jakości. OCIO jest zgodne ze specyfikacją ACES
71 (Academy Color Encoding Specification) i jest niezależne od formatu
72 LUT dzięki obsłudze wielu popularnych formatów.
73
74 %package convert
75 Summary:        OpenColorIO convert tool
76 Summary(pl.UTF-8):      Narzędzie OpenColorIO do konwersji
77 Group:          Applications/Graphics
78 Requires:       %{name} = %{version}-%{release}
79
80 %description convert
81 OpenColorIO convert tool.
82
83 %description convert -l pl.UTF-8
84 Narzędzie OpenColorIO do konwersji.
85
86 %package display
87 Summary:        OpenColorIO viewer based on OpenGL
88 Summary(pl.UTF-8):      Przeglądarka OpenColorIO oparta na OpenGL-u
89 Group:          X11/Applications/Graphics
90 Requires:       %{name} = %{version}-%{release}
91
92 %description display
93 OpenColorIO viewer based on OpenGL.
94
95 %description display -l pl.UTF-8
96 Przeglądarka OpenColorIO oparta na OpenGL-u.
97
98 %package devel
99 Summary:        Header files for OpenColorIO library
100 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenColorIO
101 Group:          Development/Libraries
102 Requires:       %{name} = %{version}-%{release}
103 Requires:       libstdc++-devel
104
105 %description devel
106 Header files for OpenColorIO library.
107
108 %description devel -l pl.UTF-8
109 Pliki nagłówkowe biblioteki OpenColorIO.
110
111 %package static
112 Summary:        Static OpenColorIO library
113 Summary(pl.UTF-8):      Statyczna biblioteka OpenColorIO
114 Group:          Development/Libraries
115 Requires:       %{name}-devel = %{version}-%{release}
116
117 %description static
118 Static OpenColorIO library.
119
120 %description static -l pl.UTF-8
121 Statyczna biblioteka OpenColorIO.
122
123 %package -n java-OpenColorIO
124 Summary:        Java binding for OpenColorIO library
125 Summary(pl.UTF-8):      Wiązanie Javy do biblioteki OpenColorIO
126 Group:          Libraries/Java
127 Requires:       %{name} = %{version}-%{release}
128
129 %description -n java-OpenColorIO
130 Java binding for OpenColorIO library.
131
132 %description -n java-OpenColorIO -l pl.UTF-8
133 Wiązanie Javy do biblioteki OpenColorIO.
134
135 %package -n python-OpenColorIO
136 Summary:        Python binding for OpenColorIO library
137 Summary(pl.UTF-8):      Wiązanie Pythona do biblioteki OpenColorIO
138 Group:          Libraries/Python
139 Requires:       %{name} = %{version}-%{release}
140
141 %description -n python-OpenColorIO
142 Python binding for OpenColorIO library.
143
144 %description -n python-OpenColorIO -l pl.UTF-8
145 Wiązanie Pythona do biblioteki OpenColorIO.
146
147 %package -n python-OpenColorIO-devel
148 Summary:        Header file for PyOpenColorIO API
149 Summary(pl.UTF-8):      Plik nagłówkowy API PyOpenColorIO
150 Group:          Development/Libraries
151 Requires:       %{name}-devel = %{version}-%{release}
152 Requires:       python-OpenColorIO = %{version}-%{release}
153
154 %description -n python-OpenColorIO-devel
155 Header file for PyOpenColorIO API.
156
157 %description -n python-OpenColorIO-devel -l pl.UTF-8
158 Plik nagłówkowy API PyOpenColorIO.
159
160 %prep
161 %setup -q -n imageworks-OpenColorIO-8883824
162 %patch0 -p1
163 %patch1 -p1
164 %patch2 -p1
165
166 %build
167 # required for cmake to find JNI headers/libs when lib64 is in use
168 %{?with_java:export JAVA_HOME=%{_jvmlibdir}/java}
169
170 install -d build
171 cd build
172 %cmake .. \
173         -DOCIO_BUILD_DOCS=ON \
174 %if %{with java}
175         -DOCIO_BUILD_JNIGLUE=ON \
176         -DOCIO_STATIC_JNIGLUE=OFF \
177 %endif
178         %{!?with_sse2:-DOCIO_USE_SSE=OFF} \
179         -DUSE_EXTERNAL_TINYXML=ON \
180         -DUSE_EXTERNAL_YAML=ON
181
182 %{__make}
183
184 %install
185 rm -rf $RPM_BUILD_ROOT
186
187 %{__make} -C build install \
188         DESTDIR=$RPM_BUILD_ROOT
189
190 # not needed when installing to /usr
191 %{__rm} $RPM_BUILD_ROOT%{_datadir}/ocio/setup_ocio.sh
192 # packaged as %doc
193 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/OpenColorIO
194
195 %clean
196 rm -rf $RPM_BUILD_ROOT
197
198 %post   -p /sbin/ldconfig
199 %postun -p /sbin/ldconfig
200
201 %post   -n java-OpenColorIO -p /sbin/ldconfig
202 %postun -n java-OpenColorIO -p /sbin/ldconfig
203
204 %post   -n python-OpenColorIO -p /sbin/ldconfig
205 %postun -n python-OpenColorIO -p /sbin/ldconfig
206
207 %files
208 %defattr(644,root,root,755)
209 %doc ChangeLog LICENSE README
210 %attr(755,root,root) %{_bindir}/ociobakelut
211 %attr(755,root,root) %{_bindir}/ociocheck
212 %attr(755,root,root) %{_libdir}/libOpenColorIO.so.*.*.*
213 %attr(755,root,root) %ghost %{_libdir}/libOpenColorIO.so.1
214
215 %if %{with oiio}
216 %files convert
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{_bindir}/ocioconvert
219 %endif
220
221 %if %{with oiio} && %{with opengl}
222 %files display
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_bindir}/ociodisplay
225 %endif
226
227 %files devel
228 %defattr(644,root,root,755)
229 %doc build/docs/build-html/*
230 %attr(755,root,root) %{_libdir}/libOpenColorIO.so
231 %{_includedir}/OpenColorIO
232 %{_pkgconfigdir}/OpenColorIO.pc
233
234 %files static
235 %defattr(644,root,root,755)
236 %{_libdir}/libOpenColorIO.a
237
238 %if %{with java}
239 %files -n java-OpenColorIO
240 %defattr(644,root,root,755)
241 %attr(755,root,root) %{_libdir}/libOpenColorIO-JNI.so.*.*.*
242 %attr(755,root,root) %ghost %{_libdir}/libOpenColorIO-JNI.so.1
243 %attr(755,root,root) %{_libdir}/libOpenColorIO-JNI.so
244 %dir %{_datadir}/ocio
245 %{_datadir}/ocio/OpenColorIO-%{version}.jar
246 %endif
247
248 %files -n python-OpenColorIO
249 %defattr(644,root,root,755)
250 %attr(755,root,root) %{py_sitedir}/PyOpenColorIO.so
251
252 %files -n python-OpenColorIO-devel
253 %defattr(644,root,root,755)
254 %{_includedir}/PyOpenColorIO
This page took 0.079604 seconds and 4 git commands to generate.