]> git.pld-linux.org Git - packages/OpenColorIO.git/blob - OpenColorIO.spec
- updated to 1.0.9
[packages/OpenColorIO.git] / OpenColorIO.spec
1 # TODO (proprietary?):
2 # - truelight http://www.filmlight.ltd.uk/products/truelight/overview_tl.php
3 # - nuke: http://docs.thefoundry.co.uk/products/nuke/
4 #
5 # Conditional build:
6 %bcond_without  oiio    # OpenImageIO-dependent apps (ocioconvert,ociodisplay)
7 %bcond_without  opengl  # OpenGL-dependent app (ociodisplay)
8 %bcond_without  java    # JNI glue
9 %bcond_without  docs    # documentation
10 %bcond_with     sse2    # use SSE2 instructions
11 #
12 %ifarch %{x8664} pentrium4
13 %define with_sse2       1
14 %endif
15 Summary:        Complete color management solution
16 Summary(pl.UTF-8):      Kompletny pakiet do zarządzania kolorami
17 Name:           OpenColorIO
18 Version:        1.0.9
19 Release:        1
20 License:        BSD
21 Group:          Libraries
22 Source0:        https://github.com/imageworks/OpenColorIO/tarball/v%{version}/%{name}-%{version}.tar.gz
23 # Source0-md5:  ad3c4ea59c010a18d79276ab9d83af95
24 Patch0:         %{name}-system-libs.patch
25 Patch1:         %{name}-java.patch
26 Patch2:         %{name}-libsuffix.patch
27 Patch3:         %{name}-missing.patch
28 # for yaml-cpp 0.5.0 (unfinished)
29 Patch4:         %{name}-yaml-cpp.patch
30 URL:            http://opencolorio.org/
31 # g++ with tr1 support or...
32 #BuildRequires: boost-devel >= 1.34
33 BuildRequires:  cmake >= 2.8
34 %{?with_java:BuildRequires:     jdk}
35 BuildRequires:  libstdc++-devel
36 BuildRequires:  pkgconfig
37 BuildRequires:  python-devel
38 %if %{with docs}
39 BuildRequires:  sphinx-pdg >= 1.1
40 BuildRequires:  texlive-latex-ams
41 %endif
42 BuildRequires:  tinyxml-devel >= 2.6.1
43 BuildRequires:  yaml-cpp-devel >= 0.2.6
44 BuildRequires:  yaml-cpp-devel < 0.4.0
45 %if %{with opengl}
46 BuildRequires:  OpenGL-devel
47 BuildRequires:  OpenGL-glut-devel
48 BuildRequires:  glew-devel >= 1.5.1
49 %endif
50 %if %{with oiio}
51 BuildRequires:  OpenImageIO-devel
52 BuildRequires:  lcms2-devel >= 2.1
53 %endif
54 Requires:       tinyxml >= 2.6.1
55 Requires:       yaml-cpp >= 0.2.6
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 OpenColorIO (OCIO) is a complete color management solution geared
60 towards motion picture production with an emphasis on visual effects
61 and computer animation. OCIO provides a straightforward and consistent
62 user experience across all supporting applications while allowing for
63 sophisticated back-end configuration options suitable for high-end
64 production usage. OCIO is compatible with the Academy Color Encoding
65 Specification (ACES) and is LUT-format agnostic, supporting many
66 popular formats.
67
68 %description -l pl.UTF-8
69 OpenColorIO (OCIO) to kompletne rozwiązanie zarządzania kolorami
70 przeznaczone do tworzenia obrazów ruchomych, w szczególności efektów
71 wizualnych i animacji komputerowej. OCIO zapewnia proste i spójne
72 elementy we wszystkich współpracujących aplikacjach, pozwalając na
73 wyszukane opcje konfiguracyjne backendu, nadające się do zastosowań
74 produkcyjnych wysokiej jakości. OCIO jest zgodne ze specyfikacją ACES
75 (Academy Color Encoding Specification) i jest niezależne od formatu
76 LUT dzięki obsłudze wielu popularnych formatów.
77
78 %package convert
79 Summary:        OpenColorIO convert tool
80 Summary(pl.UTF-8):      Narzędzie OpenColorIO do konwersji
81 Group:          Applications/Graphics
82 Requires:       %{name} = %{version}-%{release}
83
84 %description convert
85 OpenColorIO convert tool.
86
87 %description convert -l pl.UTF-8
88 Narzędzie OpenColorIO do konwersji.
89
90 %package display
91 Summary:        OpenColorIO viewer based on OpenGL
92 Summary(pl.UTF-8):      Przeglądarka OpenColorIO oparta na OpenGL-u
93 Group:          X11/Applications/Graphics
94 Requires:       %{name} = %{version}-%{release}
95
96 %description display
97 OpenColorIO viewer based on OpenGL.
98
99 %description display -l pl.UTF-8
100 Przeglądarka OpenColorIO oparta na OpenGL-u.
101
102 %package devel
103 Summary:        Header files for OpenColorIO library
104 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenColorIO
105 Group:          Development/Libraries
106 Requires:       %{name} = %{version}-%{release}
107 Requires:       libstdc++-devel
108
109 %description devel
110 Header files for OpenColorIO library.
111
112 %description devel -l pl.UTF-8
113 Pliki nagłówkowe biblioteki OpenColorIO.
114
115 %package static
116 Summary:        Static OpenColorIO library
117 Summary(pl.UTF-8):      Statyczna biblioteka OpenColorIO
118 Group:          Development/Libraries
119 Requires:       %{name}-devel = %{version}-%{release}
120
121 %description static
122 Static OpenColorIO library.
123
124 %description static -l pl.UTF-8
125 Statyczna biblioteka OpenColorIO.
126
127 %package -n java-OpenColorIO
128 Summary:        Java binding for OpenColorIO library
129 Summary(pl.UTF-8):      Wiązanie Javy do biblioteki OpenColorIO
130 Group:          Libraries/Java
131 Requires:       %{name} = %{version}-%{release}
132
133 %description -n java-OpenColorIO
134 Java binding for OpenColorIO library.
135
136 %description -n java-OpenColorIO -l pl.UTF-8
137 Wiązanie Javy do biblioteki OpenColorIO.
138
139 %package -n python-OpenColorIO
140 Summary:        Python binding for OpenColorIO library
141 Summary(pl.UTF-8):      Wiązanie Pythona do biblioteki OpenColorIO
142 Group:          Libraries/Python
143 Requires:       %{name} = %{version}-%{release}
144
145 %description -n python-OpenColorIO
146 Python binding for OpenColorIO library.
147
148 %description -n python-OpenColorIO -l pl.UTF-8
149 Wiązanie Pythona do biblioteki OpenColorIO.
150
151 %package -n python-OpenColorIO-devel
152 Summary:        Header file for PyOpenColorIO API
153 Summary(pl.UTF-8):      Plik nagłówkowy API PyOpenColorIO
154 Group:          Development/Libraries
155 Requires:       %{name}-devel = %{version}-%{release}
156 Requires:       python-OpenColorIO = %{version}-%{release}
157
158 %description -n python-OpenColorIO-devel
159 Header file for PyOpenColorIO API.
160
161 %description -n python-OpenColorIO-devel -l pl.UTF-8
162 Plik nagłówkowy API PyOpenColorIO.
163
164 %prep
165 %setup -q -n imageworks-OpenColorIO-2b12063
166 %patch0 -p1
167 %patch1 -p1
168 %patch2 -p1
169 %patch3 -p1
170
171 %build
172 # required for cmake to find JNI headers/libs when lib64 is in use
173 %{?with_java:export JAVA_HOME=%{_jvmlibdir}/java}
174
175 install -d build
176 cd build
177 %cmake .. \
178         -DOCIO_BUILD_DOCS=ON \
179 %if %{with java}
180         -DOCIO_BUILD_JNIGLUE=ON \
181         -DOCIO_STATIC_JNIGLUE=OFF \
182 %endif
183         %{!?with_sse2:-DOCIO_USE_SSE=OFF} \
184         -DUSE_EXTERNAL_TINYXML=ON \
185         -DUSE_EXTERNAL_YAML=ON
186
187 %{__make}
188
189 %install
190 rm -rf $RPM_BUILD_ROOT
191
192 %{__make} -C build install \
193         DESTDIR=$RPM_BUILD_ROOT
194
195 # not needed when installing to /usr
196 %{__rm} $RPM_BUILD_ROOT%{_datadir}/ocio/setup_ocio.sh
197 # packaged as %doc
198 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/OpenColorIO
199
200 %clean
201 rm -rf $RPM_BUILD_ROOT
202
203 %post   -p /sbin/ldconfig
204 %postun -p /sbin/ldconfig
205
206 %post   -n java-OpenColorIO -p /sbin/ldconfig
207 %postun -n java-OpenColorIO -p /sbin/ldconfig
208
209 %post   -n python-OpenColorIO -p /sbin/ldconfig
210 %postun -n python-OpenColorIO -p /sbin/ldconfig
211
212 %files
213 %defattr(644,root,root,755)
214 %doc ChangeLog LICENSE README
215 %attr(755,root,root) %{_bindir}/ociobakelut
216 %attr(755,root,root) %{_bindir}/ociocheck
217 %attr(755,root,root) %{_libdir}/libOpenColorIO.so.*.*.*
218 %attr(755,root,root) %ghost %{_libdir}/libOpenColorIO.so.1
219
220 %if %{with oiio}
221 %files convert
222 %defattr(644,root,root,755)
223 %attr(755,root,root) %{_bindir}/ocioconvert
224 %attr(755,root,root) %{_bindir}/ociolutimage
225 %endif
226
227 %if %{with oiio} && %{with opengl}
228 %files display
229 %defattr(644,root,root,755)
230 %attr(755,root,root) %{_bindir}/ociodisplay
231 %endif
232
233 %files devel
234 %defattr(644,root,root,755)
235 %doc build/docs/build-html/*
236 %attr(755,root,root) %{_libdir}/libOpenColorIO.so
237 %{_includedir}/OpenColorIO
238 %{_pkgconfigdir}/OpenColorIO.pc
239
240 %files static
241 %defattr(644,root,root,755)
242 %{_libdir}/libOpenColorIO.a
243
244 %if %{with java}
245 %files -n java-OpenColorIO
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{_libdir}/libOpenColorIO-JNI.so.*.*.*
248 %attr(755,root,root) %ghost %{_libdir}/libOpenColorIO-JNI.so.1
249 %attr(755,root,root) %{_libdir}/libOpenColorIO-JNI.so
250 %dir %{_datadir}/ocio
251 %{_datadir}/ocio/OpenColorIO-%{version}.jar
252 %endif
253
254 %files -n python-OpenColorIO
255 %defattr(644,root,root,755)
256 %attr(755,root,root) %{py_sitedir}/PyOpenColorIO.so
257
258 %files -n python-OpenColorIO-devel
259 %defattr(644,root,root,755)
260 %{_includedir}/PyOpenColorIO
This page took 0.077971 seconds and 4 git commands to generate.