]> git.pld-linux.org Git - packages/OpenColorIO.git/blob - OpenColorIO.spec
- release 2 (by relup.sh)
[packages/OpenColorIO.git] / OpenColorIO.spec
1 # TODO (proprietary?):
2 # - truelight http://www.filmlight.ltd.uk/products/truelight/overview_tl.php
3 # - nuke: http://docs.thefoundry.co.uk/products/nuke/
4 #
5 # Conditional build:
6 %bcond_without  oiio    # OpenImageIO-dependent apps (ocioconvert,ociodisplay)
7 %bcond_without  opengl  # OpenGL-dependent app (ociodisplay)
8 %bcond_without  java    # JNI glue
9 %bcond_without  docs    # documentation
10 %bcond_with     sse2    # use SSE2 instructions
11 #
12 %ifarch %{x8664} pentrium4
13 %define with_sse2       1
14 %endif
15 Summary:        Complete color management solution
16 Summary(pl.UTF-8):      Kompletny pakiet do zarządzania kolorami
17 Name:           OpenColorIO
18 Version:        1.0.6
19 Release:        2
20 License:        BSD
21 Group:          Libraries
22 Source0:        https://github.com/imageworks/OpenColorIO/tarball/v%{version}#/%{name}-%{version}.tar.gz
23 # Source0-md5:  7bd5521d8671be9f9f92339b32497908
24 Patch0:         %{name}-system-libs.patch
25 Patch1:         %{name}-java.patch
26 Patch2:         %{name}-libsuffix.patch
27 URL:            http://opencolorio.org/
28 # g++ with tr1 support or...
29 #BuildRequires: boost-devel >= 1.34
30 BuildRequires:  cmake >= 2.8
31 %{?with_java:BuildRequires:     jdk}
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  pkgconfig
34 BuildRequires:  python-devel
35 %{?with_docs:BuildRequires:     sphinx-pdg >= 1.1}
36 BuildRequires:  tinyxml-devel >= 2.6.1
37 BuildRequires:  yaml-cpp-devel >= 0.2.6
38 %if %{with opengl}
39 BuildRequires:  OpenGL-devel
40 BuildRequires:  OpenGL-glut-devel
41 BuildRequires:  glew-devel >= 1.5.1
42 %endif
43 %if %{with oiio}
44 BuildRequires:  OpenImageIO-devel
45 BuildRequires:  lcms2-devel >= 2.1
46 %endif
47 Requires:       tinyxml >= 2.6.1
48 Requires:       yaml-cpp >= 0.2.6
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 OpenColorIO (OCIO) is a complete color management solution geared
53 towards motion picture production with an emphasis on visual effects
54 and computer animation. OCIO provides a straightforward and consistent
55 user experience across all supporting applications while allowing for
56 sophisticated back-end configuration options suitable for high-end
57 production usage. OCIO is compatible with the Academy Color Encoding
58 Specification (ACES) and is LUT-format agnostic, supporting many
59 popular formats.
60
61 %description -l pl.UTF-8
62 OpenColorIO (OCIO) to kompletne rozwiązanie zarządzania kolorami
63 przeznaczone do tworzenia obrazów ruchomych, w szczególności efektów
64 wizualnych i animacji komputerowej. OCIO zapewnia proste i spójne
65 elementy we wszystkich współpracujących aplikacjach, pozwalając na
66 wyszukane opcje konfiguracyjne backendu, nadające się do zastosowań
67 produkcyjnych wysokiej jakości. OCIO jest zgodne ze specyfikacją ACES
68 (Academy Color Encoding Specification) i jest niezależne od formatu
69 LUT dzięki obsłudze wielu popularnych formatów.
70
71 %package convert
72 Summary:        OpenColorIO convert tool
73 Summary(pl.UTF-8):      Narzędzie OpenColorIO do konwersji
74 Group:          Applications/Graphics
75 Requires:       %{name} = %{version}-%{release}
76
77 %description convert
78 OpenColorIO convert tool.
79
80 %description convert -l pl.UTF-8
81 Narzędzie OpenColorIO do konwersji.
82
83 %package display
84 Summary:        OpenColorIO viewer based on OpenGL
85 Summary(pl.UTF-8):      Przeglądarka OpenColorIO oparta na OpenGL-u
86 Group:          X11/Applications/Graphics
87 Requires:       %{name} = %{version}-%{release}
88
89 %description display
90 OpenColorIO viewer based on OpenGL.
91
92 %description display -l pl.UTF-8
93 Przeglądarka OpenColorIO oparta na OpenGL-u.
94
95 %package devel
96 Summary:        Header files for OpenColorIO library
97 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenColorIO
98 Group:          Development/Libraries
99 Requires:       %{name} = %{version}-%{release}
100 Requires:       libstdc++-devel
101
102 %description devel
103 Header files for OpenColorIO library.
104
105 %description devel -l pl.UTF-8
106 Pliki nagłówkowe biblioteki OpenColorIO.
107
108 %package static
109 Summary:        Static OpenColorIO library
110 Summary(pl.UTF-8):      Statyczna biblioteka OpenColorIO
111 Group:          Development/Libraries
112 Requires:       %{name}-devel = %{version}-%{release}
113
114 %description static
115 Static OpenColorIO library.
116
117 %description static -l pl.UTF-8
118 Statyczna biblioteka OpenColorIO.
119
120 %package -n java-OpenColorIO
121 Summary:        Java binding for OpenColorIO library
122 Summary(pl.UTF-8):      Wiązanie Javy do biblioteki OpenColorIO
123 Group:          Libraries/Java
124 Requires:       %{name} = %{version}-%{release}
125
126 %description -n java-OpenColorIO
127 Java binding for OpenColorIO library.
128
129 %description -n java-OpenColorIO -l pl.UTF-8
130 Wiązanie Javy do biblioteki OpenColorIO.
131
132 %package -n python-OpenColorIO
133 Summary:        Python binding for OpenColorIO library
134 Summary(pl.UTF-8):      Wiązanie Pythona do biblioteki OpenColorIO
135 Group:          Libraries/Python
136 Requires:       %{name} = %{version}-%{release}
137
138 %description -n python-OpenColorIO
139 Python binding for OpenColorIO library.
140
141 %description -n python-OpenColorIO -l pl.UTF-8
142 Wiązanie Pythona do biblioteki OpenColorIO.
143
144 %package -n python-OpenColorIO-devel
145 Summary:        Header file for PyOpenColorIO API
146 Summary(pl.UTF-8):      Plik nagłówkowy API PyOpenColorIO
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{version}-%{release}
149 Requires:       python-OpenColorIO = %{version}-%{release}
150
151 %description -n python-OpenColorIO-devel
152 Header file for PyOpenColorIO API.
153
154 %description -n python-OpenColorIO-devel -l pl.UTF-8
155 Plik nagłówkowy API PyOpenColorIO.
156
157 %prep
158 %setup -q -n imageworks-OpenColorIO-a16d9ac
159 %patch0 -p1
160 %patch1 -p1
161 %patch2 -p1
162
163 %build
164 # required for cmake to find JNI headers/libs when lib64 is in use
165 %{?with_java:export JAVA_HOME=%{_jvmlibdir}/java}
166
167 install -d build
168 cd build
169 %cmake .. \
170         -DOCIO_BUILD_DOCS=ON \
171 %if %{with java}
172         -DOCIO_BUILD_JNIGLUE=ON \
173         -DOCIO_STATIC_JNIGLUE=OFF \
174 %endif
175         %{!?with_sse2:-DOCIO_USE_SSE=OFF} \
176         -DPYTHON_INCLUDE_LIB_PREFIX=ON
177
178 %{__make}
179
180 %install
181 rm -rf $RPM_BUILD_ROOT
182
183 %{__make} -C build install \
184         DESTDIR=$RPM_BUILD_ROOT
185
186 # we use PYTHON_INCLUDE_LIB_PREFIX=ON so library is useful as C++ API
187 # but allow it to be loaded without lib prefix
188 ln -sf $(basename $RPM_BUILD_ROOT%{_libdir}/libPyOpenColorIO.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/PyOpenColorIO.so
189
190 # not needed when installing to /usr
191 %{__rm} $RPM_BUILD_ROOT%{_datadir}/ocio/setup_ocio.sh
192 # packaged as %doc
193 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/OpenColorIO
194
195 %clean
196 rm -rf $RPM_BUILD_ROOT
197
198 %post   -p /sbin/ldconfig
199 %postun -p /sbin/ldconfig
200
201 %post   -n java-OpenColorIO -p /sbin/ldconfig
202 %postun -n java-OpenColorIO -p /sbin/ldconfig
203
204 %post   -n python-OpenColorIO -p /sbin/ldconfig
205 %postun -n python-OpenColorIO -p /sbin/ldconfig
206
207 %files
208 %defattr(644,root,root,755)
209 %doc ChangeLog LICENSE README
210 %attr(755,root,root) %{_bindir}/ociobakelut
211 %attr(755,root,root) %{_bindir}/ociocheck
212 %attr(755,root,root) %{_libdir}/libOpenColorIO.so.*.*.*
213 %attr(755,root,root) %ghost %{_libdir}/libOpenColorIO.so.1
214
215 %if %{with oiio}
216 %files convert
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{_bindir}/ocioconvert
219 %endif
220
221 %if %{with oiio} && %{with opengl}
222 %files display
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_bindir}/ociodisplay
225 %endif
226
227 %files devel
228 %defattr(644,root,root,755)
229 %doc build/docs/build-html/*
230 %attr(755,root,root) %{_libdir}/libOpenColorIO.so
231 %{_includedir}/OpenColorIO
232 %{_pkgconfigdir}/OpenColorIO.pc
233
234 %files static
235 %defattr(644,root,root,755)
236 %{_libdir}/libOpenColorIO.a
237
238 %if %{with java}
239 %files -n java-OpenColorIO
240 %defattr(644,root,root,755)
241 %attr(755,root,root) %{_libdir}/libOpenColorIO-JNI.so.*.*.*
242 %attr(755,root,root) %ghost %{_libdir}/libOpenColorIO-JNI.so.1
243 %attr(755,root,root) %{_libdir}/libOpenColorIO-JNI.so
244 %dir %{_datadir}/ocio
245 %{_datadir}/ocio/OpenColorIO-1.0.6.jar
246 %endif
247
248 %files -n python-OpenColorIO
249 %defattr(644,root,root,755)
250 %attr(755,root,root) %{_libdir}/libPyOpenColorIO.so.*.*.*
251 %attr(755,root,root) %ghost %{_libdir}/libPyOpenColorIO.so.1
252 %attr(755,root,root) %{_libdir}/PyOpenColorIO.so
253
254 %files -n python-OpenColorIO-devel
255 %defattr(644,root,root,755)
256 %attr(755,root,root) %{_libdir}/libPyOpenColorIO.so
257 %{_includedir}/PyOpenColorIO
This page took 0.075196 seconds and 4 git commands to generate.