]> git.pld-linux.org Git - packages/OpenColorIO.git/blob - OpenColorIO.spec
- x32 rebuild
[packages/OpenColorIO.git] / OpenColorIO.spec
1 # TODO (proprietary?):
2 # - truelight http://www.filmlight.ltd.uk/products/truelight/overview_tl.php
3 # - nuke: http://docs.thefoundry.co.uk/products/nuke/
4 #
5 # Conditional build:
6 %bcond_without  oiio    # OpenImageIO-dependent apps (ocioconvert,ociodisplay)
7 %bcond_without  opengl  # OpenGL-dependent app (ociodisplay)
8 %bcond_without  java    # JNI glue
9 %bcond_without  docs    # documentation
10 %bcond_with     sse2    # use SSE2 instructions
11 #
12 %ifarch %{x8664} pentrium4
13 %define with_sse2       1
14 %endif
15 Summary:        Complete color management solution
16 Summary(pl.UTF-8):      Kompletny pakiet do zarządzania kolorami
17 Name:           OpenColorIO
18 Version:        1.0.9
19 Release:        4
20 License:        BSD
21 Group:          Libraries
22 Source0:        https://github.com/imageworks/OpenColorIO/tarball/v%{version}/%{name}-%{version}.tar.gz
23 # Source0-md5:  ad3c4ea59c010a18d79276ab9d83af95
24 Patch0:         %{name}-system-libs.patch
25 Patch1:         %{name}-java.patch
26 Patch2:         %{name}-libsuffix.patch
27 Patch3:         %{name}-missing.patch
28 Patch4:         %{name}-yaml-cpp.patch
29 URL:            http://opencolorio.org/
30 # g++ with tr1 support or...
31 #BuildRequires: boost-devel >= 1.34
32 BuildRequires:  cmake >= 2.8
33 %{?with_java:BuildRequires:     jdk}
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  python-devel
37 %if %{with docs}
38 BuildRequires:  sphinx-pdg >= 1.1
39 BuildRequires:  texlive-latex-ams
40 %endif
41 BuildRequires:  tinyxml-devel >= 2.6.1
42 BuildRequires:  yaml-cpp-devel >= 0.2.6
43 %if %{with opengl}
44 BuildRequires:  OpenGL-devel
45 BuildRequires:  OpenGL-glut-devel
46 BuildRequires:  glew-devel >= 1.5.1
47 %endif
48 %if %{with oiio}
49 BuildRequires:  OpenImageIO-devel
50 BuildRequires:  lcms2-devel >= 2.1
51 %endif
52 Requires:       tinyxml >= 2.6.1
53 Requires:       yaml-cpp >= 0.2.6
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 OpenColorIO (OCIO) is a complete color management solution geared
58 towards motion picture production with an emphasis on visual effects
59 and computer animation. OCIO provides a straightforward and consistent
60 user experience across all supporting applications while allowing for
61 sophisticated back-end configuration options suitable for high-end
62 production usage. OCIO is compatible with the Academy Color Encoding
63 Specification (ACES) and is LUT-format agnostic, supporting many
64 popular formats.
65
66 %description -l pl.UTF-8
67 OpenColorIO (OCIO) to kompletne rozwiązanie zarządzania kolorami
68 przeznaczone do tworzenia obrazów ruchomych, w szczególności efektów
69 wizualnych i animacji komputerowej. OCIO zapewnia proste i spójne
70 elementy we wszystkich współpracujących aplikacjach, pozwalając na
71 wyszukane opcje konfiguracyjne backendu, nadające się do zastosowań
72 produkcyjnych wysokiej jakości. OCIO jest zgodne ze specyfikacją ACES
73 (Academy Color Encoding Specification) i jest niezależne od formatu
74 LUT dzięki obsłudze wielu popularnych formatów.
75
76 %package convert
77 Summary:        OpenColorIO convert tool
78 Summary(pl.UTF-8):      Narzędzie OpenColorIO do konwersji
79 Group:          Applications/Graphics
80 Requires:       %{name} = %{version}-%{release}
81
82 %description convert
83 OpenColorIO convert tool.
84
85 %description convert -l pl.UTF-8
86 Narzędzie OpenColorIO do konwersji.
87
88 %package display
89 Summary:        OpenColorIO viewer based on OpenGL
90 Summary(pl.UTF-8):      Przeglądarka OpenColorIO oparta na OpenGL-u
91 Group:          X11/Applications/Graphics
92 Requires:       %{name} = %{version}-%{release}
93
94 %description display
95 OpenColorIO viewer based on OpenGL.
96
97 %description display -l pl.UTF-8
98 Przeglądarka OpenColorIO oparta na OpenGL-u.
99
100 %package devel
101 Summary:        Header files for OpenColorIO library
102 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenColorIO
103 Group:          Development/Libraries
104 Requires:       %{name} = %{version}-%{release}
105 Requires:       libstdc++-devel
106
107 %description devel
108 Header files for OpenColorIO library.
109
110 %description devel -l pl.UTF-8
111 Pliki nagłówkowe biblioteki OpenColorIO.
112
113 %package static
114 Summary:        Static OpenColorIO library
115 Summary(pl.UTF-8):      Statyczna biblioteka OpenColorIO
116 Group:          Development/Libraries
117 Requires:       %{name}-devel = %{version}-%{release}
118
119 %description static
120 Static OpenColorIO library.
121
122 %description static -l pl.UTF-8
123 Statyczna biblioteka OpenColorIO.
124
125 %package -n java-OpenColorIO
126 Summary:        Java binding for OpenColorIO library
127 Summary(pl.UTF-8):      Wiązanie Javy do biblioteki OpenColorIO
128 Group:          Libraries/Java
129 Requires:       %{name} = %{version}-%{release}
130
131 %description -n java-OpenColorIO
132 Java binding for OpenColorIO library.
133
134 %description -n java-OpenColorIO -l pl.UTF-8
135 Wiązanie Javy do biblioteki OpenColorIO.
136
137 %package -n python-OpenColorIO
138 Summary:        Python binding for OpenColorIO library
139 Summary(pl.UTF-8):      Wiązanie Pythona do biblioteki OpenColorIO
140 Group:          Libraries/Python
141 Requires:       %{name} = %{version}-%{release}
142
143 %description -n python-OpenColorIO
144 Python binding for OpenColorIO library.
145
146 %description -n python-OpenColorIO -l pl.UTF-8
147 Wiązanie Pythona do biblioteki OpenColorIO.
148
149 %package -n python-OpenColorIO-devel
150 Summary:        Header file for PyOpenColorIO API
151 Summary(pl.UTF-8):      Plik nagłówkowy API PyOpenColorIO
152 Group:          Development/Libraries
153 Requires:       %{name}-devel = %{version}-%{release}
154 Requires:       python-OpenColorIO = %{version}-%{release}
155
156 %description -n python-OpenColorIO-devel
157 Header file for PyOpenColorIO API.
158
159 %description -n python-OpenColorIO-devel -l pl.UTF-8
160 Plik nagłówkowy API PyOpenColorIO.
161
162 %prep
163 %setup -q -n imageworks-OpenColorIO-2b12063
164 %patch0 -p1
165 %patch1 -p1
166 %patch2 -p1
167 %patch3 -p1
168 %patch4 -p1
169
170 %build
171 # required for cmake to find JNI headers/libs when lib64 is in use
172 %{?with_java:export JAVA_HOME=%{_jvmlibdir}/java}
173
174 install -d build
175 cd build
176 %cmake .. \
177         -DOCIO_BUILD_DOCS=ON \
178 %if %{with java}
179         -DOCIO_BUILD_JNIGLUE=ON \
180         -DOCIO_STATIC_JNIGLUE=OFF \
181 %endif
182         %{!?with_sse2:-DOCIO_USE_SSE=OFF} \
183         -DUSE_EXTERNAL_TINYXML=ON \
184         -DUSE_EXTERNAL_YAML=ON
185
186 %{__make}
187
188 %install
189 rm -rf $RPM_BUILD_ROOT
190
191 %{__make} -C build install \
192         DESTDIR=$RPM_BUILD_ROOT
193
194 # not needed when installing to /usr
195 %{__rm} $RPM_BUILD_ROOT%{_datadir}/ocio/setup_ocio.sh
196 # packaged as %doc
197 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/OpenColorIO
198
199 %clean
200 rm -rf $RPM_BUILD_ROOT
201
202 %post   -p /sbin/ldconfig
203 %postun -p /sbin/ldconfig
204
205 %post   -n java-OpenColorIO -p /sbin/ldconfig
206 %postun -n java-OpenColorIO -p /sbin/ldconfig
207
208 %post   -n python-OpenColorIO -p /sbin/ldconfig
209 %postun -n python-OpenColorIO -p /sbin/ldconfig
210
211 %files
212 %defattr(644,root,root,755)
213 %doc ChangeLog LICENSE README
214 %attr(755,root,root) %{_bindir}/ociobakelut
215 %attr(755,root,root) %{_bindir}/ociocheck
216 %attr(755,root,root) %{_libdir}/libOpenColorIO.so.*.*.*
217 %attr(755,root,root) %ghost %{_libdir}/libOpenColorIO.so.1
218
219 %if %{with oiio}
220 %files convert
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_bindir}/ocioconvert
223 %attr(755,root,root) %{_bindir}/ociolutimage
224 %endif
225
226 %if %{with oiio} && %{with opengl}
227 %files display
228 %defattr(644,root,root,755)
229 %attr(755,root,root) %{_bindir}/ociodisplay
230 %endif
231
232 %files devel
233 %defattr(644,root,root,755)
234 %doc build/docs/build-html/*
235 %attr(755,root,root) %{_libdir}/libOpenColorIO.so
236 %{_includedir}/OpenColorIO
237 %{_pkgconfigdir}/OpenColorIO.pc
238
239 %files static
240 %defattr(644,root,root,755)
241 %{_libdir}/libOpenColorIO.a
242
243 %if %{with java}
244 %files -n java-OpenColorIO
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_libdir}/libOpenColorIO-JNI.so.*.*.*
247 %attr(755,root,root) %ghost %{_libdir}/libOpenColorIO-JNI.so.1
248 %attr(755,root,root) %{_libdir}/libOpenColorIO-JNI.so
249 %dir %{_datadir}/ocio
250 %{_datadir}/ocio/OpenColorIO-%{version}.jar
251 %endif
252
253 %files -n python-OpenColorIO
254 %defattr(644,root,root,755)
255 %attr(755,root,root) %{py_sitedir}/PyOpenColorIO.so
256
257 %files -n python-OpenColorIO-devel
258 %defattr(644,root,root,755)
259 %{_includedir}/PyOpenColorIO
This page took 0.193815 seconds and 4 git commands to generate.