]> git.pld-linux.org Git - packages/OpenColorIO.git/blob - OpenColorIO.spec
- rel 3; BR texlive-latex-am for doc
[packages/OpenColorIO.git] / OpenColorIO.spec
1 # TODO (proprietary?):
2 # - truelight http://www.filmlight.ltd.uk/products/truelight/overview_tl.php
3 # - nuke: http://docs.thefoundry.co.uk/products/nuke/
4 #
5 # Conditional build:
6 %bcond_without  oiio    # OpenImageIO-dependent apps (ocioconvert,ociodisplay)
7 %bcond_without  opengl  # OpenGL-dependent app (ociodisplay)
8 %bcond_without  java    # JNI glue
9 %bcond_without  docs    # documentation
10 %bcond_with     sse2    # use SSE2 instructions
11 #
12 %ifarch %{x8664} pentrium4
13 %define with_sse2       1
14 %endif
15 Summary:        Complete color management solution
16 Summary(pl.UTF-8):      Kompletny pakiet do zarządzania kolorami
17 Name:           OpenColorIO
18 Version:        1.0.8
19 Release:        3
20 License:        BSD
21 Group:          Libraries
22 Source0:        https://github.com/imageworks/OpenColorIO/tarball/v%{version}/%{name}-%{version}.tar.gz
23 # Source0-md5:  9838f5f1cf624a3d1253241f22e2179a
24 Patch0:         %{name}-system-libs.patch
25 Patch1:         %{name}-java.patch
26 Patch2:         %{name}-libsuffix.patch
27 # for yaml-cpp 0.5.0 (unfinished)
28 Patch3:         %{name}-yaml-cpp.patch
29 URL:            http://opencolorio.org/
30 # g++ with tr1 support or...
31 #BuildRequires: boost-devel >= 1.34
32 BuildRequires:  cmake >= 2.8
33 %{?with_java:BuildRequires:     jdk}
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  python-devel
37 %if %{with docs}
38 BuildRequires:  sphinx-pdg >= 1.1
39 BuildRequires:  texlive-latex-ams
40 %endif
41 BuildRequires:  tinyxml-devel >= 2.6.1
42 BuildRequires:  yaml-cpp-devel >= 0.2.6
43 BuildRequires:  yaml-cpp-devel < 0.4.0
44 %if %{with opengl}
45 BuildRequires:  OpenGL-devel
46 BuildRequires:  OpenGL-glut-devel
47 BuildRequires:  glew-devel >= 1.5.1
48 %endif
49 %if %{with oiio}
50 BuildRequires:  OpenImageIO-devel
51 BuildRequires:  lcms2-devel >= 2.1
52 %endif
53 Requires:       tinyxml >= 2.6.1
54 Requires:       yaml-cpp >= 0.2.6
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 OpenColorIO (OCIO) is a complete color management solution geared
59 towards motion picture production with an emphasis on visual effects
60 and computer animation. OCIO provides a straightforward and consistent
61 user experience across all supporting applications while allowing for
62 sophisticated back-end configuration options suitable for high-end
63 production usage. OCIO is compatible with the Academy Color Encoding
64 Specification (ACES) and is LUT-format agnostic, supporting many
65 popular formats.
66
67 %description -l pl.UTF-8
68 OpenColorIO (OCIO) to kompletne rozwiązanie zarządzania kolorami
69 przeznaczone do tworzenia obrazów ruchomych, w szczególności efektów
70 wizualnych i animacji komputerowej. OCIO zapewnia proste i spójne
71 elementy we wszystkich współpracujących aplikacjach, pozwalając na
72 wyszukane opcje konfiguracyjne backendu, nadające się do zastosowań
73 produkcyjnych wysokiej jakości. OCIO jest zgodne ze specyfikacją ACES
74 (Academy Color Encoding Specification) i jest niezależne od formatu
75 LUT dzięki obsłudze wielu popularnych formatów.
76
77 %package convert
78 Summary:        OpenColorIO convert tool
79 Summary(pl.UTF-8):      Narzędzie OpenColorIO do konwersji
80 Group:          Applications/Graphics
81 Requires:       %{name} = %{version}-%{release}
82
83 %description convert
84 OpenColorIO convert tool.
85
86 %description convert -l pl.UTF-8
87 Narzędzie OpenColorIO do konwersji.
88
89 %package display
90 Summary:        OpenColorIO viewer based on OpenGL
91 Summary(pl.UTF-8):      Przeglądarka OpenColorIO oparta na OpenGL-u
92 Group:          X11/Applications/Graphics
93 Requires:       %{name} = %{version}-%{release}
94
95 %description display
96 OpenColorIO viewer based on OpenGL.
97
98 %description display -l pl.UTF-8
99 Przeglądarka OpenColorIO oparta na OpenGL-u.
100
101 %package devel
102 Summary:        Header files for OpenColorIO library
103 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenColorIO
104 Group:          Development/Libraries
105 Requires:       %{name} = %{version}-%{release}
106 Requires:       libstdc++-devel
107
108 %description devel
109 Header files for OpenColorIO library.
110
111 %description devel -l pl.UTF-8
112 Pliki nagłówkowe biblioteki OpenColorIO.
113
114 %package static
115 Summary:        Static OpenColorIO library
116 Summary(pl.UTF-8):      Statyczna biblioteka OpenColorIO
117 Group:          Development/Libraries
118 Requires:       %{name}-devel = %{version}-%{release}
119
120 %description static
121 Static OpenColorIO library.
122
123 %description static -l pl.UTF-8
124 Statyczna biblioteka OpenColorIO.
125
126 %package -n java-OpenColorIO
127 Summary:        Java binding for OpenColorIO library
128 Summary(pl.UTF-8):      Wiązanie Javy do biblioteki OpenColorIO
129 Group:          Libraries/Java
130 Requires:       %{name} = %{version}-%{release}
131
132 %description -n java-OpenColorIO
133 Java binding for OpenColorIO library.
134
135 %description -n java-OpenColorIO -l pl.UTF-8
136 Wiązanie Javy do biblioteki OpenColorIO.
137
138 %package -n python-OpenColorIO
139 Summary:        Python binding for OpenColorIO library
140 Summary(pl.UTF-8):      Wiązanie Pythona do biblioteki OpenColorIO
141 Group:          Libraries/Python
142 Requires:       %{name} = %{version}-%{release}
143
144 %description -n python-OpenColorIO
145 Python binding for OpenColorIO library.
146
147 %description -n python-OpenColorIO -l pl.UTF-8
148 Wiązanie Pythona do biblioteki OpenColorIO.
149
150 %package -n python-OpenColorIO-devel
151 Summary:        Header file for PyOpenColorIO API
152 Summary(pl.UTF-8):      Plik nagłówkowy API PyOpenColorIO
153 Group:          Development/Libraries
154 Requires:       %{name}-devel = %{version}-%{release}
155 Requires:       python-OpenColorIO = %{version}-%{release}
156
157 %description -n python-OpenColorIO-devel
158 Header file for PyOpenColorIO API.
159
160 %description -n python-OpenColorIO-devel -l pl.UTF-8
161 Plik nagłówkowy API PyOpenColorIO.
162
163 %prep
164 %setup -q -n imageworks-OpenColorIO-8883824
165 %patch0 -p1
166 %patch1 -p1
167 %patch2 -p1
168
169 %build
170 # required for cmake to find JNI headers/libs when lib64 is in use
171 %{?with_java:export JAVA_HOME=%{_jvmlibdir}/java}
172
173 install -d build
174 cd build
175 %cmake .. \
176         -DOCIO_BUILD_DOCS=ON \
177 %if %{with java}
178         -DOCIO_BUILD_JNIGLUE=ON \
179         -DOCIO_STATIC_JNIGLUE=OFF \
180 %endif
181         %{!?with_sse2:-DOCIO_USE_SSE=OFF} \
182         -DUSE_EXTERNAL_TINYXML=ON \
183         -DUSE_EXTERNAL_YAML=ON
184
185 %{__make}
186
187 %install
188 rm -rf $RPM_BUILD_ROOT
189
190 %{__make} -C build install \
191         DESTDIR=$RPM_BUILD_ROOT
192
193 # not needed when installing to /usr
194 %{__rm} $RPM_BUILD_ROOT%{_datadir}/ocio/setup_ocio.sh
195 # packaged as %doc
196 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/OpenColorIO
197
198 %clean
199 rm -rf $RPM_BUILD_ROOT
200
201 %post   -p /sbin/ldconfig
202 %postun -p /sbin/ldconfig
203
204 %post   -n java-OpenColorIO -p /sbin/ldconfig
205 %postun -n java-OpenColorIO -p /sbin/ldconfig
206
207 %post   -n python-OpenColorIO -p /sbin/ldconfig
208 %postun -n python-OpenColorIO -p /sbin/ldconfig
209
210 %files
211 %defattr(644,root,root,755)
212 %doc ChangeLog LICENSE README
213 %attr(755,root,root) %{_bindir}/ociobakelut
214 %attr(755,root,root) %{_bindir}/ociocheck
215 %attr(755,root,root) %{_libdir}/libOpenColorIO.so.*.*.*
216 %attr(755,root,root) %ghost %{_libdir}/libOpenColorIO.so.1
217
218 %if %{with oiio}
219 %files convert
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{_bindir}/ocioconvert
222 %endif
223
224 %if %{with oiio} && %{with opengl}
225 %files display
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_bindir}/ociodisplay
228 %endif
229
230 %files devel
231 %defattr(644,root,root,755)
232 %doc build/docs/build-html/*
233 %attr(755,root,root) %{_libdir}/libOpenColorIO.so
234 %{_includedir}/OpenColorIO
235 %{_pkgconfigdir}/OpenColorIO.pc
236
237 %files static
238 %defattr(644,root,root,755)
239 %{_libdir}/libOpenColorIO.a
240
241 %if %{with java}
242 %files -n java-OpenColorIO
243 %defattr(644,root,root,755)
244 %attr(755,root,root) %{_libdir}/libOpenColorIO-JNI.so.*.*.*
245 %attr(755,root,root) %ghost %{_libdir}/libOpenColorIO-JNI.so.1
246 %attr(755,root,root) %{_libdir}/libOpenColorIO-JNI.so
247 %dir %{_datadir}/ocio
248 %{_datadir}/ocio/OpenColorIO-%{version}.jar
249 %endif
250
251 %files -n python-OpenColorIO
252 %defattr(644,root,root,755)
253 %attr(755,root,root) %{py_sitedir}/PyOpenColorIO.so
254
255 %files -n python-OpenColorIO-devel
256 %defattr(644,root,root,755)
257 %{_includedir}/PyOpenColorIO
This page took 0.060398 seconds and 4 git commands to generate.