]> git.pld-linux.org Git - packages/OpenColorIO.git/blob - OpenColorIO.spec
- release 10 (by relup.sh)
[packages/OpenColorIO.git] / OpenColorIO.spec
1 # TODO (proprietary?):
2 # - truelight http://www.filmlight.ltd.uk/products/truelight/overview_tl.php
3 # - nuke: http://docs.thefoundry.co.uk/products/nuke/
4 #
5 # Conditional build:
6 %bcond_without  oiio    # OpenImageIO-dependent apps (ocioconvert,ociodisplay)
7 %bcond_without  opengl  # OpenGL-dependent app (ociodisplay)
8 %bcond_without  java    # JNI glue
9 %bcond_without  docs    # documentation
10 %bcond_with     sse2    # use SSE2 instructions
11 #
12 %ifarch %{x8664} pentrium4
13 %define with_sse2       1
14 %endif
15 Summary:        Complete color management solution
16 Summary(pl.UTF-8):      Kompletny pakiet do zarządzania kolorami
17 Name:           OpenColorIO
18 Version:        1.0.9
19 Release:        10
20 License:        BSD
21 Group:          Libraries
22 Source0:        https://github.com/imageworks/OpenColorIO/tarball/v%{version}/%{name}-%{version}.tar.gz
23 # Source0-md5:  ad3c4ea59c010a18d79276ab9d83af95
24 Patch0:         %{name}-system-libs.patch
25 Patch1:         %{name}-java.patch
26 Patch2:         %{name}-libsuffix.patch
27 Patch3:         %{name}-missing.patch
28 Patch4:         %{name}-yaml-cpp.patch
29 URL:            http://opencolorio.org/
30 # g++ with tr1 support or...
31 #BuildRequires: boost-devel >= 1.34
32 BuildRequires:  cmake >= 2.8
33 %{?with_java:BuildRequires:     jdk}
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  python-devel
37 %if %{with docs}
38 BuildRequires:  sphinx-pdg >= 1.1
39 BuildRequires:  texlive-latex-ams
40 BuildRequires:  texlive-xetex
41 %endif
42 BuildRequires:  tinyxml-devel >= 2.6.1
43 BuildRequires:  yaml-cpp-devel >= 0.2.6
44 %if %{with opengl}
45 BuildRequires:  OpenGL-devel
46 BuildRequires:  OpenGL-glut-devel
47 BuildRequires:  glew-devel >= 1.5.1
48 %endif
49 %if %{with oiio}
50 BuildRequires:  OpenImageIO-devel
51 BuildRequires:  lcms2-devel >= 2.1
52 %endif
53 Requires:       tinyxml >= 2.6.1
54 Requires:       yaml-cpp >= 0.2.6
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 OpenColorIO (OCIO) is a complete color management solution geared
59 towards motion picture production with an emphasis on visual effects
60 and computer animation. OCIO provides a straightforward and consistent
61 user experience across all supporting applications while allowing for
62 sophisticated back-end configuration options suitable for high-end
63 production usage. OCIO is compatible with the Academy Color Encoding
64 Specification (ACES) and is LUT-format agnostic, supporting many
65 popular formats.
66
67 %description -l pl.UTF-8
68 OpenColorIO (OCIO) to kompletne rozwiązanie zarządzania kolorami
69 przeznaczone do tworzenia obrazów ruchomych, w szczególności efektów
70 wizualnych i animacji komputerowej. OCIO zapewnia proste i spójne
71 elementy we wszystkich współpracujących aplikacjach, pozwalając na
72 wyszukane opcje konfiguracyjne backendu, nadające się do zastosowań
73 produkcyjnych wysokiej jakości. OCIO jest zgodne ze specyfikacją ACES
74 (Academy Color Encoding Specification) i jest niezależne od formatu
75 LUT dzięki obsłudze wielu popularnych formatów.
76
77 %package convert
78 Summary:        OpenColorIO convert tool
79 Summary(pl.UTF-8):      Narzędzie OpenColorIO do konwersji
80 Group:          Applications/Graphics
81 Requires:       %{name} = %{version}-%{release}
82
83 %description convert
84 OpenColorIO convert tool.
85
86 %description convert -l pl.UTF-8
87 Narzędzie OpenColorIO do konwersji.
88
89 %package display
90 Summary:        OpenColorIO viewer based on OpenGL
91 Summary(pl.UTF-8):      Przeglądarka OpenColorIO oparta na OpenGL-u
92 Group:          X11/Applications/Graphics
93 Requires:       %{name} = %{version}-%{release}
94
95 %description display
96 OpenColorIO viewer based on OpenGL.
97
98 %description display -l pl.UTF-8
99 Przeglądarka OpenColorIO oparta na OpenGL-u.
100
101 %package devel
102 Summary:        Header files for OpenColorIO library
103 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenColorIO
104 Group:          Development/Libraries
105 Requires:       %{name} = %{version}-%{release}
106 Requires:       libstdc++-devel
107
108 %description devel
109 Header files for OpenColorIO library.
110
111 %description devel -l pl.UTF-8
112 Pliki nagłówkowe biblioteki OpenColorIO.
113
114 %package static
115 Summary:        Static OpenColorIO library
116 Summary(pl.UTF-8):      Statyczna biblioteka OpenColorIO
117 Group:          Development/Libraries
118 Requires:       %{name}-devel = %{version}-%{release}
119
120 %description static
121 Static OpenColorIO library.
122
123 %description static -l pl.UTF-8
124 Statyczna biblioteka OpenColorIO.
125
126 %package -n java-OpenColorIO
127 Summary:        Java binding for OpenColorIO library
128 Summary(pl.UTF-8):      Wiązanie Javy do biblioteki OpenColorIO
129 Group:          Libraries/Java
130 Requires:       %{name} = %{version}-%{release}
131
132 %description -n java-OpenColorIO
133 Java binding for OpenColorIO library.
134
135 %description -n java-OpenColorIO -l pl.UTF-8
136 Wiązanie Javy do biblioteki OpenColorIO.
137
138 %package -n python-OpenColorIO
139 Summary:        Python binding for OpenColorIO library
140 Summary(pl.UTF-8):      Wiązanie Pythona do biblioteki OpenColorIO
141 Group:          Libraries/Python
142 Requires:       %{name} = %{version}-%{release}
143
144 %description -n python-OpenColorIO
145 Python binding for OpenColorIO library.
146
147 %description -n python-OpenColorIO -l pl.UTF-8
148 Wiązanie Pythona do biblioteki OpenColorIO.
149
150 %package -n python-OpenColorIO-devel
151 Summary:        Header file for PyOpenColorIO API
152 Summary(pl.UTF-8):      Plik nagłówkowy API PyOpenColorIO
153 Group:          Development/Libraries
154 Requires:       %{name}-devel = %{version}-%{release}
155 Requires:       python-OpenColorIO = %{version}-%{release}
156
157 %description -n python-OpenColorIO-devel
158 Header file for PyOpenColorIO API.
159
160 %description -n python-OpenColorIO-devel -l pl.UTF-8
161 Plik nagłówkowy API PyOpenColorIO.
162
163 %prep
164 %setup -q -n imageworks-OpenColorIO-2b12063
165 %patch0 -p1
166 %patch1 -p1
167 %patch2 -p1
168 %patch3 -p1
169 %patch4 -p1
170
171 %build
172 # required for cmake to find JNI headers/libs when lib64 is in use
173 %{?with_java:export JAVA_HOME=%{_jvmlibdir}/java}
174
175 install -d build
176 cd build
177 %cmake .. \
178         -DOCIO_BUILD_DOCS=ON \
179 %if %{with java}
180         -DOCIO_BUILD_JNIGLUE=ON \
181         -DOCIO_STATIC_JNIGLUE=OFF \
182 %endif
183         %{!?with_sse2:-DOCIO_USE_SSE=OFF} \
184         -DUSE_EXTERNAL_TINYXML=ON \
185         -DUSE_EXTERNAL_YAML=ON
186
187 %{__make}
188
189 %install
190 rm -rf $RPM_BUILD_ROOT
191
192 %{__make} -C build install \
193         DESTDIR=$RPM_BUILD_ROOT
194
195 # not needed when installing to /usr
196 %{__rm} $RPM_BUILD_ROOT%{_datadir}/ocio/setup_ocio.sh
197 # packaged as %doc
198 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/OpenColorIO
199
200 %clean
201 rm -rf $RPM_BUILD_ROOT
202
203 %post   -p /sbin/ldconfig
204 %postun -p /sbin/ldconfig
205
206 %post   -n java-OpenColorIO -p /sbin/ldconfig
207 %postun -n java-OpenColorIO -p /sbin/ldconfig
208
209 %post   -n python-OpenColorIO -p /sbin/ldconfig
210 %postun -n python-OpenColorIO -p /sbin/ldconfig
211
212 %files
213 %defattr(644,root,root,755)
214 %doc ChangeLog LICENSE README
215 %attr(755,root,root) %{_bindir}/ociobakelut
216 %attr(755,root,root) %{_bindir}/ociocheck
217 %attr(755,root,root) %{_libdir}/libOpenColorIO.so.*.*.*
218 %attr(755,root,root) %ghost %{_libdir}/libOpenColorIO.so.1
219
220 %if %{with oiio}
221 %files convert
222 %defattr(644,root,root,755)
223 %attr(755,root,root) %{_bindir}/ocioconvert
224 %attr(755,root,root) %{_bindir}/ociolutimage
225 %endif
226
227 %if %{with oiio} && %{with opengl}
228 %files display
229 %defattr(644,root,root,755)
230 %attr(755,root,root) %{_bindir}/ociodisplay
231 %endif
232
233 %files devel
234 %defattr(644,root,root,755)
235 %doc build/docs/build-html/*
236 %attr(755,root,root) %{_libdir}/libOpenColorIO.so
237 %{_includedir}/OpenColorIO
238 %{_pkgconfigdir}/OpenColorIO.pc
239
240 %files static
241 %defattr(644,root,root,755)
242 %{_libdir}/libOpenColorIO.a
243
244 %if %{with java}
245 %files -n java-OpenColorIO
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{_libdir}/libOpenColorIO-JNI.so.*.*.*
248 %attr(755,root,root) %ghost %{_libdir}/libOpenColorIO-JNI.so.1
249 %attr(755,root,root) %{_libdir}/libOpenColorIO-JNI.so
250 %dir %{_datadir}/ocio
251 %{_datadir}/ocio/OpenColorIO-%{version}.jar
252 %endif
253
254 %files -n python-OpenColorIO
255 %defattr(644,root,root,755)
256 %attr(755,root,root) %{py_sitedir}/PyOpenColorIO.so
257
258 %files -n python-OpenColorIO-devel
259 %defattr(644,root,root,755)
260 %{_includedir}/PyOpenColorIO
This page took 0.081191 seconds and 4 git commands to generate.