]> git.pld-linux.org Git - packages/ModemManager.git/blob - ModemManager.spec
Release 2
[packages/ModemManager.git] / ModemManager.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build API documentation
4 #
5 Summary:        Mobile broadband modem management service
6 Summary(pl.UTF-8):      Usługa zarządzająca szerokopasmowymi modemami komórkowymi
7 Name:           ModemManager
8 Version:        1.0.0
9 Release:        2
10 License:        GPL v2+
11 Group:          Networking
12 Source0:        http://www.freedesktop.org/software/ModemManager/%{name}-%{version}.tar.xz
13 # Source0-md5:  bb59fda111d8e1038b02ed7e57efe83a
14 URL:            http://www.freedesktop.org/wiki/Software/ModemManager
15 BuildRequires:  autoconf >= 2.63
16 BuildRequires:  automake >= 1:1.9
17 BuildRequires:  gettext-devel >= 0.17
18 BuildRequires:  glib2-devel >= 1:2.32.0
19 BuildRequires:  gtk-doc
20 BuildRequires:  intltool >= 0.40.0
21 BuildRequires:  libmbim-devel >= 1.4
22 BuildRequires:  libqmi-devel >= 1.4
23 BuildRequires:  libtool >= 2:2.2
24 BuildRequires:  pkgconfig
25 BuildRequires:  polkit-devel >= 0.97
26 BuildRequires:  ppp-plugin-devel >= 3:2.4.5
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  udev-glib-devel >= 1:147
29 BuildRequires:  xz
30 Requires(post,preun,postun):    systemd-units
31 Requires:       %{name}-libs = %{version}-%{release}
32 Requires:       glib2 >= 1:2.32.0
33 Requires:       hicolor-icon-theme
34 Requires:       libmbim >= 1.4
35 Requires:       libqmi >= 1.4
36 Requires:       polkit >= 0.97
37 Requires:       udev-glib >= 1:147
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 The ModemManager service provides a consistent API to operate many
42 different modems, including mobile broadband (3G) devices.
43
44 %description -l pl.UTF-8
45 Usługa ModemManager zapewnia spójne API do obsługi wielu różnych
46 modemów, w tym szerokopasmowych modemów komórkowych (3G).
47
48 %package libs
49 Summary:        Library to control and monitor the ModemManager
50 Summary(pl.UTF-8):      Biblioteka do sterowania i monitorowania ModemManagera
51 Group:          Libraries
52 Requires:       glib2 >= 1:2.32.0
53
54 %description libs
55 This package provides library to control and monitor the ModemManager.
56
57 %description libs -l pl.UTF-8
58 Ten pakiet dostarcza bibliotekę do sterowania i monitorowania
59 ModemManagera.
60
61 %package devel
62 Summary:        Header file defining ModemManager D-Bus interface
63 Summary(pl.UTF-8):      Plik nagłówkowy opisujący interfejs D-Bus ModemManagera
64 Group:          Development/Libraries
65 Requires:       %{name}-libs = %{version}-%{release}
66 Requires:       glib2-devel >= 1:2.32.0
67
68 %description devel
69 Header file defining ModemManager D-Bus interface.
70
71 %description devel -l pl.UTF-8
72 Plik nagłówkowy opisujący interfejs D-Bus ModemManagera.
73
74 %package apidocs
75 Summary:        API documentation for ModemManager
76 Summary(pl.UTF-8):      Dokumentacja API ModemManagera
77 Group:          Documentation
78 Requires:       gtk-doc-common
79
80 %description apidocs
81 API documentation for ModemManager.
82
83 %description apidocs -l pl.UTF-8
84 Dokumentacja API biblioteki ModemManagera.
85
86 %prep
87 %setup -q
88
89 %build
90 %{__libtoolize}
91 %{__aclocal} -I m4
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 %configure \
96         %{__enable_disable apidocs gtk-doc} \
97         --disable-silent-rules \
98         --disable-static \
99         --enable-more-warnings \
100         --with-html-dir=%{_gtkdocdir} \
101         --with-polkit
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
111 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post
117 %update_icon_cache hicolor
118 %systemd_service_enable ModemManager.service
119
120 %preun
121 %systemd_preun ModemManager.service
122
123 %postun
124 %update_icon_cache hicolor
125 %systemd_reload
126
127 %post libs -p /sbin/ldconfig
128 %postun libs -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog NEWS README
133 %attr(755,root,root) %{_bindir}/mmcli
134 %attr(755,root,root) %{_sbindir}/ModemManager
135 %dir %{_libdir}/ModemManager
136 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-altair-lte.so
137 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-anydata.so
138 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-cinterion.so
139 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-generic.so
140 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-gobi.so
141 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-hso.so
142 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-huawei.so
143 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-iridium.so
144 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-linktop.so
145 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-longcheer.so
146 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-mbm.so
147 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-motorola.so
148 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-nokia-icera.so
149 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-nokia.so
150 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-novatel-lte.so
151 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-novatel.so
152 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-option.so
153 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-pantech.so
154 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-samsung.so
155 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-sierra.so
156 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-simtech.so
157 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-telit.so
158 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-via.so
159 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-wavecom.so
160 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-x22x.so
161 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-zte.so
162 /lib/udev/rules.d/77-mm-ericsson-mbm.rules
163 /lib/udev/rules.d/77-mm-huawei-net-port-types.rules
164 /lib/udev/rules.d/77-mm-longcheer-port-types.rules
165 /lib/udev/rules.d/77-mm-nokia-port-types.rules
166 /lib/udev/rules.d/77-mm-pcmcia-device-blacklist.rules
167 /lib/udev/rules.d/77-mm-platform-serial-whitelist.rules
168 /lib/udev/rules.d/77-mm-simtech-port-types.rules
169 /lib/udev/rules.d/77-mm-usb-device-blacklist.rules
170 /lib/udev/rules.d/77-mm-usb-serial-adapters-greylist.rules
171 /lib/udev/rules.d/77-mm-x22x-port-types.rules
172 /lib/udev/rules.d/77-mm-zte-port-types.rules
173 /lib/udev/rules.d/80-mm-candidate.rules
174 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/org.freedesktop.ModemManager1.conf
175 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Bearer.xml
176 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Firmware.xml
177 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Location.xml
178 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Messaging.xml
179 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Modem3gpp.Ussd.xml
180 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Modem3gpp.xml
181 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.ModemCdma.xml
182 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Simple.xml
183 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Time.xml
184 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.xml
185 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Sim.xml
186 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Sms.xml
187 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.xml
188 %{_datadir}/dbus-1/interfaces/wip-org.freedesktop.ModemManager1.Modem.Contacts.xml
189 %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
190 %{_datadir}/polkit-1/actions/org.freedesktop.ModemManager1.policy
191 %{_iconsdir}/hicolor/*/apps/*.png
192 %{_mandir}/man8/ModemManager.8*
193 %{_mandir}/man8/mmcli.8*
194 %{systemdunitdir}/ModemManager.service
195
196 %files libs
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/libmm-glib.so.*.*.*
199 %attr(755,root,root) %ghost %{_libdir}/libmm-glib.so.0
200
201 %files devel
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_libdir}/libmm-glib.so
204 %{_includedir}/ModemManager
205 %{_includedir}/libmm-glib
206 %{_pkgconfigdir}/ModemManager.pc
207 %{_pkgconfigdir}/mm-glib.pc
208
209 %files apidocs
210 %defattr(644,root,root,755)
211 %{_gtkdocdir}/ModemManager
212 %{_gtkdocdir}/libmm-glib
This page took 0.07058 seconds and 4 git commands to generate.