]> git.pld-linux.org Git - packages/ModemManager.git/blob - ModemManager.spec
- up to 0.5
[packages/ModemManager.git] / ModemManager.spec
1 %define         ppp_version     2.4.5
2 Summary:        Mobile broadband modem management service
3 Name:           ModemManager
4 Version:        0.5
5 Release:        1
6 License:        GPL v2
7 Group:          Networking
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/ModemManager/0.5/%{name}-%{version}.tar.bz2
9 # Source0-md5:  cd04109506e88bf4c4cd3e7ce0034c08
10 URL:            http://www.gnome.org/projects/NetworkManager/
11 BuildRequires:  autoconf >= 2.52
12 BuildRequires:  automake >= 1:1.9
13 BuildRequires:  dbus-glib-devel >= 0.86
14 BuildRequires:  gettext-devel
15 BuildRequires:  glib2-devel >= 1:2.18.0
16 BuildRequires:  intltool
17 BuildRequires:  libtool
18 BuildRequires:  pkgconfig
19 BuildRequires:  polkit-devel
20 BuildRequires:  ppp-plugin-devel >= 3:%{ppp_version}
21 BuildRequires:  udev-glib-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The ModemManager service provides a consistent API to operate many
26 different modems, including mobile broadband (3G) devices.
27
28 %prep
29 %setup -q
30
31 %build
32 %{__libtoolize}
33 %{__aclocal} -I m4
34 %{__autoconf}
35 %{__autoheader}
36 %{__automake}
37 %configure \
38         --with-pppd-plugin-dir=%{_libdir}/pppd/%{ppp_version} \
39         --with-polkit \
40         --enable-more-warnings=yes \
41         --disable-silent-rules
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
51 rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/*.*.*/*.{a,la}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc AUTHORS ChangeLog NEWS README
59 %attr(755,root,root) %{_sbindir}/modem-manager
60 %dir %{_libdir}/ModemManager
61 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-anydata.so
62 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-generic.so
63 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-gobi.so
64 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-hso.so
65 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-huawei.so
66 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-linktop.so
67 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-longcheer.so
68 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-mbm.so
69 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-moto-c.so
70 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-nokia.so
71 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-novatel.so
72 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-option.so
73 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-samsung.so
74 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-sierra.so
75 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-simtech.so
76 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-wavecom.so
77 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-x22x.so
78 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-zte.so
79 %attr(755,root,root) %{_libdir}/pppd/%{ppp_version}/mm-test-pppd-plugin.so
80 /lib/udev/rules.d/77-mm-ericsson-mbm.rules
81 /lib/udev/rules.d/77-mm-longcheer-port-types.rules
82 /lib/udev/rules.d/77-mm-pcmcia-device-blacklist.rules
83 /lib/udev/rules.d/77-mm-platform-serial-whitelist.rules
84 /lib/udev/rules.d/77-mm-simtech-port-types.rules
85 /lib/udev/rules.d/77-mm-usb-device-blacklist.rules
86 /lib/udev/rules.d/77-mm-x22x-port-types.rules
87 /lib/udev/rules.d/77-mm-zte-port-types.rules
88 /lib/udev/rules.d/80-mm-candidate.rules
89 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/org.freedesktop.ModemManager.conf
90 %{_datadir}/dbus-1/interfaces/mm-mobile-error.xml
91 %{_datadir}/dbus-1/interfaces/mm-modem-connect-error.xml
92 %{_datadir}/dbus-1/interfaces/mm-modem-error.xml
93 %{_datadir}/dbus-1/interfaces/mm-serial-error.xml
94 %{_datadir}/dbus-1/interfaces/org.freedesktop.DBus.Properties.xml
95 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Cdma.xml
96 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Gsm.Card.xml
97 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Gsm.Contacts.xml
98 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Gsm.Hso.xml
99 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Gsm.Network.xml
100 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Gsm.SMS.xml
101 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Gsm.Ussd.xml
102 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Gsm.xml
103 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Location.xml
104 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Simple.xml
105 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.xml
106 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.xml
107 %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager.service
108 %{_datadir}/polkit-1/actions/org.freedesktop.modem-manager.policy
109 %{_iconsdir}/hicolor/*/apps/*.png
This page took 0.12897 seconds and 4 git commands to generate.