]> git.pld-linux.org Git - packages/ModemManager.git/blob - ModemManager.spec
- updated to 0.5.2.0
[packages/ModemManager.git] / ModemManager.spec
1 %define         ppp_version     2.4.5
2 Summary:        Mobile broadband modem management service
3 Summary(pl.UTF-8):      Usługa zarządzająca szerokopasmowymi modemami komórkowymi
4 Name:           ModemManager
5 Version:        0.5.2.0
6 Release:        1
7 License:        GPL v2+
8 Group:          Networking
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/ModemManager/0.5/%{name}-%{version}.tar.xz
10 # Source0-md5:  a4da11ad17f937156c30b08a29cee13f
11 URL:            http://www.gnome.org/projects/NetworkManager/
12 BuildRequires:  autoconf >= 2.60
13 BuildRequires:  automake >= 1:1.9
14 BuildRequires:  dbus-glib-devel >= 0.86
15 BuildRequires:  gettext-devel
16 BuildRequires:  glib2-devel >= 1:2.18
17 BuildRequires:  intltool >= 0.35.0
18 BuildRequires:  libtool >= 2:2.2
19 BuildRequires:  pkgconfig
20 BuildRequires:  polkit-devel >= 0.95
21 BuildRequires:  ppp-plugin-devel >= 3:%{ppp_version}
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  udev-glib-devel
24 BuildRequires:  xz
25 Requires:       dbus-glib >= 0.86
26 Requires:       glib2 >= 1:2.18
27 Requires:       hicolor-icon-theme
28 Requires:       polkit >= 0.95
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 The ModemManager service provides a consistent API to operate many
33 different modems, including mobile broadband (3G) devices.
34
35 %description -l pl.UTF-8
36 Usługa ModemManager zapewnia spójne API do obsługi wielu różnych
37 modemów, w tym szerokopasmowych modemów komórkowych (3G).
38
39 %package devel
40 Summary:        Header file defining ModemManager D-Bus interface
41 Summary(pl.UTF-8):      Plik nagłówkowy opisujący interfejs D-Bus ModemManagera
42 Group:          Development/Libraries
43 # doesn't require base
44
45 %description devel
46 Header file defining ModemManager D-Bus interface.
47
48 %description devel -l pl.UTF-8
49 Plik nagłówkowy opisujący interfejs D-Bus ModemManagera.
50
51 %prep
52 %setup -q
53
54 %build
55 %{__libtoolize}
56 %{__aclocal} -I m4
57 %{__autoconf}
58 %{__autoheader}
59 %{__automake}
60 %configure \
61         --disable-silent-rules \
62         --disable-static \
63         --enable-more-warnings \
64         --with-polkit \
65         --with-pppd-plugin-dir=%{_libdir}/pppd/%{ppp_version}
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
75 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pppd/*.*.*/*.la
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 %update_icon_cache hicolor
82
83 %postun
84 %update_icon_cache hicolor
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS ChangeLog NEWS README
89 %attr(755,root,root) %{_sbindir}/modem-manager
90 %dir %{_libdir}/ModemManager
91 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-anydata.so
92 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-generic.so
93 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-gobi.so
94 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-hso.so
95 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-huawei.so
96 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-linktop.so
97 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-longcheer.so
98 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-mbm.so
99 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-moto-c.so
100 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-nokia.so
101 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-novatel.so
102 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-option.so
103 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-samsung.so
104 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-sierra.so
105 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-simtech.so
106 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-wavecom.so
107 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-x22x.so
108 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-zte.so
109 %attr(755,root,root) %{_libdir}/pppd/%{ppp_version}/mm-test-pppd-plugin.so
110 /lib/udev/rules.d/77-mm-ericsson-mbm.rules
111 /lib/udev/rules.d/77-mm-longcheer-port-types.rules
112 /lib/udev/rules.d/77-mm-nokia-port-types.rules
113 /lib/udev/rules.d/77-mm-pcmcia-device-blacklist.rules
114 /lib/udev/rules.d/77-mm-platform-serial-whitelist.rules
115 /lib/udev/rules.d/77-mm-simtech-port-types.rules
116 /lib/udev/rules.d/77-mm-usb-device-blacklist.rules
117 /lib/udev/rules.d/77-mm-x22x-port-types.rules
118 /lib/udev/rules.d/77-mm-zte-port-types.rules
119 /lib/udev/rules.d/80-mm-candidate.rules
120 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/org.freedesktop.ModemManager.conf
121 %{_datadir}/dbus-1/interfaces/mm-mobile-error.xml
122 %{_datadir}/dbus-1/interfaces/mm-modem-connect-error.xml
123 %{_datadir}/dbus-1/interfaces/mm-modem-error.xml
124 %{_datadir}/dbus-1/interfaces/mm-serial-error.xml
125 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Cdma.xml
126 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Gsm.Card.xml
127 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Gsm.Contacts.xml
128 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Gsm.Hso.xml
129 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Gsm.Network.xml
130 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Gsm.SMS.xml
131 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Gsm.Ussd.xml
132 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Gsm.xml
133 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Location.xml
134 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.Simple.xml
135 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.Modem.xml
136 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager.xml
137 %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager.service
138 %{_datadir}/polkit-1/actions/org.freedesktop.modem-manager.policy
139 %{_iconsdir}/hicolor/*/apps/*.png
140
141 %files devel
142 %defattr(644,root,root,755)
143 %{_includedir}/mm
This page took 0.086938 seconds and 4 git commands to generate.