]> git.pld-linux.org Git - packages/ModemManager.git/blob - ModemManager.spec
- updated to 1.4.10
[packages/ModemManager.git] / ModemManager.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build API documentation
4
5 Summary:        Mobile broadband modem management service
6 Summary(pl.UTF-8):      Usługa zarządzająca szerokopasmowymi modemami komórkowymi
7 Name:           ModemManager
8 Version:        1.4.10
9 Release:        1
10 License:        GPL v2+
11 Group:          Networking
12 Source0:        http://www.freedesktop.org/software/ModemManager/%{name}-%{version}.tar.xz
13 # Source0-md5:  1e46a148e2af0e9f503660fcd2d8957d
14 URL:            http://www.freedesktop.org/wiki/Software/ModemManager
15 BuildRequires:  autoconf >= 2.63
16 BuildRequires:  automake >= 1:1.9
17 BuildRequires:  gettext-tools >= 0.17
18 BuildRequires:  glib2-devel >= 1:2.32.0
19 BuildRequires:  gobject-introspection-devel >= 0.9.6
20 BuildRequires:  gtk-doc >= 1.0
21 BuildRequires:  intltool >= 0.40.0
22 BuildRequires:  libmbim-devel >= 1.10
23 BuildRequires:  libqmi-devel >= 1.12.4
24 BuildRequires:  libtool >= 2:2.2
25 BuildRequires:  pkgconfig
26 BuildRequires:  polkit-devel >= 0.97
27 BuildRequires:  ppp-plugin-devel >= 3:2.4.5
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  udev-glib-devel >= 1:147
30 BuildRequires:  vala >= 2:0.18.0
31 BuildRequires:  xz
32 Requires(post,preun,postun):    systemd-units
33 Requires:       %{name}-libs = %{version}-%{release}
34 Requires:       glib2 >= 1:2.32.0
35 Requires:       hicolor-icon-theme
36 Requires:       libmbim >= 1.10
37 Requires:       libqmi >= 1.12.4
38 Requires:       polkit >= 0.97
39 Requires:       udev-glib >= 1:147
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 The ModemManager service provides a consistent API to operate many
44 different modems, including mobile broadband (3G) devices.
45
46 %description -l pl.UTF-8
47 Usługa ModemManager zapewnia spójne API do obsługi wielu różnych
48 modemów, w tym szerokopasmowych modemów komórkowych (3G).
49
50 %package libs
51 Summary:        Library to control and monitor the ModemManager
52 Summary(pl.UTF-8):      Biblioteka do sterowania i monitorowania ModemManagera
53 Group:          Libraries
54 Requires:       glib2 >= 1:2.32.0
55
56 %description libs
57 This package provides library to control and monitor the ModemManager.
58
59 %description libs -l pl.UTF-8
60 Ten pakiet dostarcza bibliotekę do sterowania i monitorowania
61 ModemManagera.
62
63 %package devel
64 Summary:        Header file defining ModemManager D-Bus interface
65 Summary(pl.UTF-8):      Plik nagłówkowy opisujący interfejs D-Bus ModemManagera
66 Group:          Development/Libraries
67 Requires:       %{name}-libs = %{version}-%{release}
68 Requires:       glib2-devel >= 1:2.32.0
69
70 %description devel
71 Header file defining ModemManager D-Bus interface.
72
73 %description devel -l pl.UTF-8
74 Plik nagłówkowy opisujący interfejs D-Bus ModemManagera.
75
76 %package apidocs
77 Summary:        API documentation for ModemManager
78 Summary(pl.UTF-8):      Dokumentacja API ModemManagera
79 Group:          Documentation
80 Requires:       gtk-doc-common
81 %if "%{_rpmversion}" >= "5"
82 BuildArch:      noarch
83 %endif
84
85 %description apidocs
86 API documentation for ModemManager.
87
88 %description apidocs -l pl.UTF-8
89 Dokumentacja API biblioteki ModemManagera.
90
91 %package -n vala-libmm-glib
92 Summary:        libmm-glib API for Vala language
93 Summary(pl.UTF-8):      API libmm-glib dla języka Vala
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96 Requires:       vala >= 2:0.18.0
97
98 %description -n vala-libmm-glib
99 libmm-glib API for Vala language.
100
101 %description -n vala-libmm-glib -l pl.UTF-8
102 API libmm-glib dla języka Vala.
103
104 %prep
105 %setup -q
106
107 %build
108 %{__libtoolize}
109 %{__aclocal} -I m4
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         %{__enable_disable apidocs gtk-doc} \
115         --disable-silent-rules \
116         --disable-static \
117         --enable-more-warnings \
118         --enable-vala \
119         --with-html-dir=%{_gtkdocdir} \
120         --with-polkit
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
130 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
131
132 %find_lang %{name}
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post
138 %update_icon_cache hicolor
139 %systemd_service_enable ModemManager.service
140
141 %preun
142 %systemd_preun ModemManager.service
143
144 %postun
145 %update_icon_cache hicolor
146 %systemd_reload
147
148 %post   libs -p /sbin/ldconfig
149 %postun libs -p /sbin/ldconfig
150
151 %files -f %{name}.lang
152 %defattr(644,root,root,755)
153 %doc AUTHORS ChangeLog NEWS README
154 %attr(755,root,root) %{_bindir}/mmcli
155 %attr(755,root,root) %{_sbindir}/ModemManager
156 %dir %{_libdir}/ModemManager
157 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-altair-lte.so
158 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-anydata.so
159 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-cinterion.so
160 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-generic.so
161 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-gobi.so
162 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-hso.so
163 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-huawei.so
164 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-iridium.so
165 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-linktop.so
166 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-longcheer.so
167 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-mbm.so
168 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-mtk.so
169 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-motorola.so
170 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-nokia-icera.so
171 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-nokia.so
172 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-novatel-lte.so
173 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-novatel.so
174 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-option.so
175 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-pantech.so
176 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-samsung.so
177 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-sierra.so
178 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-simtech.so
179 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-telit.so
180 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-via.so
181 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-wavecom.so
182 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-x22x.so
183 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-zte.so
184 /lib/udev/rules.d/77-mm-cinterion-port-types.rules
185 /lib/udev/rules.d/77-mm-ericsson-mbm.rules
186 /lib/udev/rules.d/77-mm-huawei-net-port-types.rules
187 /lib/udev/rules.d/77-mm-longcheer-port-types.rules
188 /lib/udev/rules.d/77-mm-mtk-port-types.rules
189 /lib/udev/rules.d/77-mm-nokia-port-types.rules
190 /lib/udev/rules.d/77-mm-pcmcia-device-blacklist.rules
191 /lib/udev/rules.d/77-mm-platform-serial-whitelist.rules
192 /lib/udev/rules.d/77-mm-simtech-port-types.rules
193 /lib/udev/rules.d/77-mm-telit-port-types.rules
194 /lib/udev/rules.d/77-mm-usb-device-blacklist.rules
195 /lib/udev/rules.d/77-mm-usb-serial-adapters-greylist.rules
196 /lib/udev/rules.d/77-mm-x22x-port-types.rules
197 /lib/udev/rules.d/77-mm-zte-port-types.rules
198 /lib/udev/rules.d/80-mm-candidate.rules
199 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/org.freedesktop.ModemManager1.conf
200 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Bearer.xml
201 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Firmware.xml
202 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Location.xml
203 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Messaging.xml
204 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Modem3gpp.Ussd.xml
205 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Modem3gpp.xml
206 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.ModemCdma.xml
207 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Oma.xml
208 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Simple.xml
209 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Signal.xml
210 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Time.xml
211 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.xml
212 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Sim.xml
213 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Sms.xml
214 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.xml
215 %{_datadir}/dbus-1/interfaces/wip-org.freedesktop.ModemManager1.Modem.Contacts.xml
216 %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
217 %{_datadir}/polkit-1/actions/org.freedesktop.ModemManager1.policy
218 %{_iconsdir}/hicolor/*/apps/*.png
219 %{_mandir}/man8/ModemManager.8*
220 %{_mandir}/man8/mmcli.8*
221 %{systemdunitdir}/ModemManager.service
222
223 %files libs
224 %defattr(644,root,root,755)
225 %attr(755,root,root) %{_libdir}/libmm-glib.so.*.*.*
226 %attr(755,root,root) %ghost %{_libdir}/libmm-glib.so.0
227 %{_libdir}/girepository-1.0/ModemManager-1.0.typelib
228
229 %files devel
230 %defattr(644,root,root,755)
231 %attr(755,root,root) %{_libdir}/libmm-glib.so
232 %{_includedir}/ModemManager
233 %{_includedir}/libmm-glib
234 %{_pkgconfigdir}/ModemManager.pc
235 %{_pkgconfigdir}/mm-glib.pc
236 %{_datadir}/gir-1.0/ModemManager-1.0.gir
237
238 %files apidocs
239 %defattr(644,root,root,755)
240 %{_gtkdocdir}/ModemManager
241 %{_gtkdocdir}/libmm-glib
242
243 %files -n vala-libmm-glib
244 %defattr(644,root,root,755)
245 %{_datadir}/vala/vapi/libmm-glib.deps
246 %{_datadir}/vala/vapi/libmm-glib.vapi
This page took 0.106881 seconds and 3 git commands to generate.