]> git.pld-linux.org Git - packages/ModemManager.git/blob - ModemManager.spec
Update to 1.0.0
[packages/ModemManager.git] / ModemManager.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build API documentation
4 #
5 Summary:        Mobile broadband modem management service
6 Summary(pl.UTF-8):      Usługa zarządzająca szerokopasmowymi modemami komórkowymi
7 Name:           ModemManager
8 Version:        1.0.0
9 Release:        1
10 License:        GPL v2+
11 Group:          Networking
12 Source0:        http://www.freedesktop.org/software/ModemManager/%{name}-%{version}.tar.xz
13 # Source0-md5:  bb59fda111d8e1038b02ed7e57efe83a
14 URL:            http://www.freedesktop.org/wiki/Software/ModemManager
15 BuildRequires:  autoconf >= 2.63
16 BuildRequires:  automake >= 1:1.9
17 BuildRequires:  gettext-devel
18 BuildRequires:  glib2-devel >= 1:2.32.0
19 BuildRequires:  gtk-doc
20 BuildRequires:  intltool >= 0.40.0
21 BuildRequires:  libmbim-devel >= 1.4
22 BuildRequires:  libqmi-devel >= 1.4
23 BuildRequires:  libtool >= 2:2.2
24 BuildRequires:  pkgconfig
25 BuildRequires:  polkit-devel >= 0.97
26 BuildRequires:  ppp-plugin-devel >= 3:2.4.5
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  udev-glib-devel >= 147
29 BuildRequires:  xz
30 Requires(post,preun,postun):    systemd-units
31 Requires:       %{name}-libs = %{version}-%{release}
32 Requires:       glib2 >= 1:2.32.0
33 Requires:       hicolor-icon-theme
34 Requires:       polkit >= 0.97
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 The ModemManager service provides a consistent API to operate many
39 different modems, including mobile broadband (3G) devices.
40
41 %description -l pl.UTF-8
42 Usługa ModemManager zapewnia spójne API do obsługi wielu różnych
43 modemów, w tym szerokopasmowych modemów komórkowych (3G).
44
45 %package libs
46 Summary:        Library to control and monitor the ModemManager
47 Summary(pl.UTF-8):      Biblioteka do sterowania i monitorowania ModemManagera
48 Group:          Libraries
49 Requires:       glib2 >= 1:2.32.0
50
51 %description libs
52 This package provides library to control and monitor the ModemManager.
53
54 %description libs -l pl.UTF-8
55 Ten pakiet dostarcza bibliotekę do sterowania i monitorowania
56 ModemManagera.
57
58 %package devel
59 Summary:        Header file defining ModemManager D-Bus interface
60 Summary(pl.UTF-8):      Plik nagłówkowy opisujący interfejs D-Bus ModemManagera
61 Group:          Development/Libraries
62 Requires:       %{name}-libs = %{version}-%{release}
63 Requires:       glib2-devel >= 1:2.32.0
64
65 %description devel
66 Header file defining ModemManager D-Bus interface.
67
68 %description devel -l pl.UTF-8
69 Plik nagłówkowy opisujący interfejs D-Bus ModemManagera.
70
71 %package apidocs
72 Summary:        API documentation for ModemManager
73 Summary(pl.UTF-8):      Dokumentacja API ModemManagera
74 Group:          Documentation
75 Requires:       gtk-doc-common
76
77 %description apidocs
78 API documentation for ModemManager.
79
80 %description apidocs -l pl.UTF-8
81 Dokumentacja API biblioteki ModemManagera.
82
83 %prep
84 %setup -q
85
86 %build
87 %{__libtoolize}
88 %{__aclocal} -I m4
89 %{__autoconf}
90 %{__autoheader}
91 %{__automake}
92 %configure \
93         %{__enable_disable apidocs gtk-doc} \
94         --disable-silent-rules \
95         --disable-static \
96         --enable-more-warnings \
97         --with-html-dir=%{_gtkdocdir} \
98         --with-polkit
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
108 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post
114 %update_icon_cache hicolor
115 %systemd_service_enable ModemManager.service
116
117 %preun
118 %systemd_preun ModemManager.service
119
120 %postun
121 %update_icon_cache hicolor
122 %systemd_reload
123
124 %post libs -p /sbin/ldconfig
125 %postun libs -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %doc AUTHORS ChangeLog NEWS README
130 %attr(755,root,root) %{_bindir}/mmcli
131 %attr(755,root,root) %{_sbindir}/ModemManager
132 %dir %{_libdir}/ModemManager
133 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-altair-lte.so
134 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-anydata.so
135 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-cinterion.so
136 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-generic.so
137 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-gobi.so
138 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-hso.so
139 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-huawei.so
140 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-iridium.so
141 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-linktop.so
142 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-longcheer.so
143 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-mbm.so
144 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-motorola.so
145 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-nokia-icera.so
146 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-nokia.so
147 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-novatel-lte.so
148 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-novatel.so
149 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-option.so
150 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-pantech.so
151 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-samsung.so
152 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-sierra.so
153 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-simtech.so
154 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-telit.so
155 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-via.so
156 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-wavecom.so
157 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-x22x.so
158 %attr(755,root,root) %{_libdir}/%{name}/libmm-plugin-zte.so
159 /lib/udev/rules.d/77-mm-ericsson-mbm.rules
160 /lib/udev/rules.d/77-mm-huawei-net-port-types.rules
161 /lib/udev/rules.d/77-mm-longcheer-port-types.rules
162 /lib/udev/rules.d/77-mm-nokia-port-types.rules
163 /lib/udev/rules.d/77-mm-pcmcia-device-blacklist.rules
164 /lib/udev/rules.d/77-mm-platform-serial-whitelist.rules
165 /lib/udev/rules.d/77-mm-simtech-port-types.rules
166 /lib/udev/rules.d/77-mm-usb-device-blacklist.rules
167 /lib/udev/rules.d/77-mm-usb-serial-adapters-greylist.rules
168 /lib/udev/rules.d/77-mm-x22x-port-types.rules
169 /lib/udev/rules.d/77-mm-zte-port-types.rules
170 /lib/udev/rules.d/80-mm-candidate.rules
171 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/org.freedesktop.ModemManager1.conf
172 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Bearer.xml
173 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Firmware.xml
174 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Location.xml
175 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Messaging.xml
176 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Modem3gpp.Ussd.xml
177 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Modem3gpp.xml
178 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.ModemCdma.xml
179 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Simple.xml
180 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.Time.xml
181 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Modem.xml
182 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Sim.xml
183 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.Sms.xml
184 %{_datadir}/dbus-1/interfaces/org.freedesktop.ModemManager1.xml
185 %{_datadir}/dbus-1/interfaces/wip-org.freedesktop.ModemManager1.Modem.Contacts.xml
186 %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
187 %{_datadir}/polkit-1/actions/org.freedesktop.ModemManager1.policy
188 %{_iconsdir}/hicolor/*/apps/*.png
189 %{_mandir}/man8/ModemManager.8*
190 %{_mandir}/man8/mmcli.8*
191 %{systemdunitdir}/ModemManager.service
192
193 %files libs
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/libmm-glib.so.*.*.*
196 %attr(755,root,root) %ghost %{_libdir}/libmm-glib.so.0
197
198 %files devel
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_libdir}/libmm-glib.so
201 %{_includedir}/ModemManager
202 %{_includedir}/libmm-glib
203 %{_pkgconfigdir}/ModemManager.pc
204 %{_pkgconfigdir}/mm-glib.pc
205
206 %files apidocs
207 %defattr(644,root,root,755)
208 %{_gtkdocdir}/ModemManager
209 %{_gtkdocdir}/libmm-glib
This page took 0.080684 seconds and 3 git commands to generate.