]> git.pld-linux.org Git - packages/Lunchbox.git/commitdiff
- updated to 1.17.0 (note: new soname) auto/th/Lunchbox-1.17.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 26 May 2019 07:22:01 +0000 (09:22 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 26 May 2019 07:22:01 +0000 (09:22 +0200)
- updated cxx patch

Lunchbox.spec
cxx.patch

index 939c36604757a98bd25d746706661134d072126f..ef450d67bc12ab4e46c259985a0fd78377493941 100644 (file)
@@ -2,36 +2,31 @@
 # Conditional build:
 %bcond_without apidocs         # do not build and package API docs
 %bcond_with    mpi             # MPI support
-%bcond_with    skv             # SKV (Scalable Key-Value Store) support
 
 Summary:       Lunchbox - C++ library for multi-threading programming
 Summary(pl.UTF-8):     Lunchbox - biblioteka C++ do programowania wielowątkowego
 Name:          Lunchbox
-Version:       1.15.0
-Release:       2
+Version:       1.17.0
+Release:       1
 License:       LGPL v2.1
 Group:         Libraries
+#Source0Download: https://github.com/Eyescale/Lunchbox/releases
 Source0:       https://github.com/Eyescale/Lunchbox/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 5d36a9eb706ab65572fd208574c187a2
+# Source0-md5: 76bcd79003c9b9d58d5f772cfdd812c7
 Patch2:                cxx.patch
 URL:           http://pogl.wordpress.com/category/lunchbox/
-BuildRequires: Eyescale-CMake >= 2016.04
+BuildRequires: Eyescale-CMake >= 2018.02
 BuildRequires: Servus-devel >= 1.5.0
 BuildRequires: avahi-devel
 BuildRequires: boost-devel >= 1.41.0
-BuildRequires: cmake >= 2.8
+BuildRequires: cmake >= 3.1
 %{?with_apidocs:BuildRequires: doxygen}
-BuildRequires: gcc-c++ >= 6:4.2
 BuildRequires: hwloc-devel >= 1.3
-BuildRequires: leveldb-devel
-BuildRequires: libgomp-devel
-BuildRequires: libjpeg-turbo-devel >= 1.2.1
 BuildRequires: libstdc++-devel
 %{?with_mpi:BuildRequires:     mpi-devel}
 BuildRequires: pkgconfig
-%{?with_skv:BuildRequires:     skv-devel}
+Requires:      Servus >= 1.5.0
 Requires:      hwloc-libs >= 1.3
-Requires:      libjpeg-turbo >= 1.2.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -53,8 +48,8 @@ Summary:      Header files for Lunchbox library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki Lunchbox
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      Servus-devel >= 1.5.0
 Requires:      boost-devel >= 1.41.0
-Requires:      libgomp-devel
 Requires:      libstdc++-devel
 
 %description devel
@@ -80,8 +75,8 @@ Dokumentacja API biblioteki Lunchbox.
 %prep
 %setup -q
 
+rmdir CMake/common
 ln -s %{_datadir}/Eyescale-CMake CMake/common
-%{__rm} .gitexternals
 
 %patch2 -p1
 
@@ -89,10 +84,9 @@ ln -s %{_datadir}/Eyescale-CMake CMake/common
 install -d build
 cd build
 %cmake .. \
-       -DBUILDYARD_DISABLED=ON \
        -DCOMMON_DISABLE_WERROR:BOOL=ON \
-       %{!?with_mpi:-DCMAKE_DISABLE_FIND_PACKAGE_MPI=ON} \
-       %{!?with_skv:-DCMAKE_DISABLE_FIND_PACKAGE_skv=ON}
+       %{!?with_mpi:-DCMAKE_DISABLE_FIND_PACKAGE_MPI=ON}
+
 %{__make}
 
 %if %{with apidocs}
@@ -117,13 +111,14 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc ACKNOWLEDGEMENTS.txt AUTHORS.txt CHANGES.txt LICENSE.txt README.md doc/Changelog.md
 %attr(755,root,root) %{_libdir}/libLunchbox.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libLunchbox.so.8
+%attr(755,root,root) %ghost %{_libdir}/libLunchbox.so.10
+%dir %{_datadir}/Lunchbox
+%{_datadir}/Lunchbox/benchmarks
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libLunchbox.so
 %{_includedir}/lunchbox
-%dir %{_datadir}/Lunchbox
 %{_datadir}/Lunchbox/CMake
 
 %if %{with apidocs}
index 4dcfedd61e463a1f5d348a3fb7147a3a69d4c2fc..23d655831d4964cc83a4633401702ea12006e917 100644 (file)
--- a/cxx.patch
+++ b/cxx.patch
@@ -1,13 +1,12 @@
---- Lunchbox-1.10.0/tests/refPtr.cpp~  2014-10-09 10:14:54.000000000 +0000
-+++ Lunchbox-1.10.0/tests/refPtr.cpp   2016-05-24 19:29:04.438092680 +0000
-@@ -38,9 +38,9 @@
+--- Lunchbox-1.17.0/tests/refPtr.cpp.orig      2019-05-26 08:38:17.065749629 +0200
++++ Lunchbox-1.17.0/tests/refPtr.cpp   2019-05-26 08:39:27.702033626 +0200
+@@ -35,8 +35,8 @@
  {
  public:
      Foo() {}
-+    virtual ~Foo() {}
- private:
--    virtual ~Foo() {}
+-private:
+     virtual ~Foo() {}
++private:
      friend class boost::serialization::access;
-     template< class Archive > void serialize( Archive&, unsigned int ) {}
+     template <class Archive>
+     void serialize(Archive&, unsigned int)
This page took 0.103368 seconds and 4 git commands to generate.