]> git.pld-linux.org Git - packages/Lunchbox.git/blame - Lunchbox.spec
- updated to 1.17.0 (note: new soname)
[packages/Lunchbox.git] / Lunchbox.spec
CommitLineData
7c02bafe
JB
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
4%bcond_with mpi # MPI support
3da0d941 5
7c02bafe
JB
6Summary: Lunchbox - C++ library for multi-threading programming
7Summary(pl.UTF-8): Lunchbox - biblioteka C++ do programowania wielowątkowego
8Name: Lunchbox
7c79b477
JB
9Version: 1.17.0
10Release: 1
7c02bafe
JB
11License: LGPL v2.1
12Group: Libraries
7c79b477 13#Source0Download: https://github.com/Eyescale/Lunchbox/releases
7c02bafe 14Source0: https://github.com/Eyescale/Lunchbox/archive/%{version}/%{name}-%{version}.tar.gz
7c79b477 15# Source0-md5: 76bcd79003c9b9d58d5f772cfdd812c7
382ae9ec 16Patch2: cxx.patch
7c02bafe 17URL: http://pogl.wordpress.com/category/lunchbox/
7c79b477 18BuildRequires: Eyescale-CMake >= 2018.02
99b90907 19BuildRequires: Servus-devel >= 1.5.0
7c02bafe
JB
20BuildRequires: avahi-devel
21BuildRequires: boost-devel >= 1.41.0
7c79b477 22BuildRequires: cmake >= 3.1
7c02bafe 23%{?with_apidocs:BuildRequires: doxygen}
7c02bafe 24BuildRequires: hwloc-devel >= 1.3
7c02bafe
JB
25BuildRequires: libstdc++-devel
26%{?with_mpi:BuildRequires: mpi-devel}
27BuildRequires: pkgconfig
7c79b477 28Requires: Servus >= 1.5.0
7c02bafe 29Requires: hwloc-libs >= 1.3
7c02bafe
JB
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33Lunchbox is a C++ library for multi-threaded programming. Lunchbox was
34formerly known as eq::base or co::base, the foundation for the
35Equalizer parallel rendering framework and the Collage network
36library. It is intended for all application developers creating
37high-performance multi-threaded programs.
38
39%description -l pl.UTF-8
40Lunchbox to biblioteka C++ do programowania wielowątkowego. Wcześniej
41była znana jako eq::base lub co::base - podstawa szkieletu do
42renderowania wielowątkowego Equalizer lub biblioteki sieciowej
43Collage. Biblioteka jest przeznaczona dla wszystkich programistów
44tworzących wysoko wydajne, wielowątkowe aplikacje.
45
46%package devel
47Summary: Header files for Lunchbox library
48Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Lunchbox
49Group: Development/Libraries
50Requires: %{name} = %{version}-%{release}
7c79b477 51Requires: Servus-devel >= 1.5.0
7c02bafe 52Requires: boost-devel >= 1.41.0
7c02bafe
JB
53Requires: libstdc++-devel
54
55%description devel
56Header files for Lunchbox library.
57
58%description devel -l pl.UTF-8
59Pliki nagłówkowe biblioteki Lunchbox.
60
61%package apidocs
62Summary: Lunchbox API documentation
63Summary(pl.UTF-8): Dokumentacja API biblioteki Lunchbox
64Group: Documentation
3da0d941
ER
65%if "%{_rpmversion}" >= "5"
66BuildArch: noarch
67%endif
7c02bafe
JB
68
69%description apidocs
70API documentation for Lunchbox library.
71
72%description apidocs -l pl.UTF-8
73Dokumentacja API biblioteki Lunchbox.
74
75%prep
c6de7caf 76%setup -q
7c02bafe 77
7c79b477 78rmdir CMake/common
c6de7caf 79ln -s %{_datadir}/Eyescale-CMake CMake/common
7c02bafe 80
382ae9ec 81%patch2 -p1
c428797b 82
7c02bafe
JB
83%build
84install -d build
85cd build
86%cmake .. \
87a51c8c 87 -DCOMMON_DISABLE_WERROR:BOOL=ON \
7c79b477
JB
88 %{!?with_mpi:-DCMAKE_DISABLE_FIND_PACKAGE_MPI=ON}
89
7c02bafe
JB
90%{__make}
91
92%if %{with apidocs}
93doxygen doc/Doxyfile
94%endif
95
96%install
97rm -rf $RPM_BUILD_ROOT
98
99%{__make} -C build install \
100 DESTDIR=$RPM_BUILD_ROOT
101
102%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Lunchbox/{doc,tests}
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%post -p /sbin/ldconfig
108%postun -p /sbin/ldconfig
109
110%files
111%defattr(644,root,root,755)
c6de7caf 112%doc ACKNOWLEDGEMENTS.txt AUTHORS.txt CHANGES.txt LICENSE.txt README.md doc/Changelog.md
7c02bafe 113%attr(755,root,root) %{_libdir}/libLunchbox.so.*.*.*
7c79b477
JB
114%attr(755,root,root) %ghost %{_libdir}/libLunchbox.so.10
115%dir %{_datadir}/Lunchbox
116%{_datadir}/Lunchbox/benchmarks
7c02bafe
JB
117
118%files devel
119%defattr(644,root,root,755)
120%attr(755,root,root) %{_libdir}/libLunchbox.so
121%{_includedir}/lunchbox
7c02bafe
JB
122%{_datadir}/Lunchbox/CMake
123
124%if %{with apidocs}
125%files apidocs
126%defattr(644,root,root,755)
127%doc build/doc/html/*
128%endif
This page took 0.115611 seconds and 4 git commands to generate.