]> git.pld-linux.org Git - packages/Lunchbox.git/commitdiff
- fix building with modern g++ auto/th/Lunchbox-1.10.0-7
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 24 May 2016 19:30:46 +0000 (19:30 +0000)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 24 May 2016 19:30:46 +0000 (19:30 +0000)
- rel 7

Lunchbox.spec
cxx.patch [new file with mode: 0644]

index d3ab7a023a5b0638cfed1c1a8d4aa79098a24037..9e454abb739acb62af0c3be29c3b407340c40999 100644 (file)
@@ -8,7 +8,7 @@ Summary:        Lunchbox - C++ library for multi-threading programming
 Summary(pl.UTF-8):     Lunchbox - biblioteka C++ do programowania wielowątkowego
 Name:          Lunchbox
 Version:       1.10.0
-Release:       6
+Release:       7
 License:       LGPL v2.1
 Group:         Libraries
 Source0:       https://github.com/Eyescale/Lunchbox/archive/%{version}/%{name}-%{version}.tar.gz
@@ -17,6 +17,7 @@ Source1:      https://github.com/Eyescale/CMake/archive/139ce7d/Eyescale-CMake-139ce7
 # Source1-md5: 4a6abcd9e0fc417528a8ca68a97e65eb
 Patch0:                disable-broken-cmakefiles.patch
 Patch1:                boost-1.57.0.patch
+Patch2:                cxx.patch
 URL:           http://pogl.wordpress.com/category/lunchbox/
 BuildRequires: avahi-devel
 BuildRequires: boost-devel >= 1.41.0
@@ -86,6 +87,7 @@ Dokumentacja API biblioteki Lunchbox.
 
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 install -d build
diff --git a/cxx.patch b/cxx.patch
new file mode 100644 (file)
index 0000000..4dcfedd
--- /dev/null
+++ b/cxx.patch
@@ -0,0 +1,13 @@
+--- Lunchbox-1.10.0/tests/refPtr.cpp~  2014-10-09 10:14:54.000000000 +0000
++++ Lunchbox-1.10.0/tests/refPtr.cpp   2016-05-24 19:29:04.438092680 +0000
+@@ -38,9 +38,9 @@
+ {
+ public:
+     Foo() {}
++    virtual ~Foo() {}
+ private:
+-    virtual ~Foo() {}
+     friend class boost::serialization::access;
+     template< class Archive > void serialize( Archive&, unsigned int ) {}
This page took 0.110532 seconds and 4 git commands to generate.