]> git.pld-linux.org Git - packages/Lunchbox.git/blob - Lunchbox.spec
d3ab7a023a5b0638cfed1c1a8d4aa79098a24037
[packages/Lunchbox.git] / Lunchbox.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_with     mpi             # MPI support
5 %bcond_with     skv             # SKV (Scalable Key-Value Store) support
6
7 Summary:        Lunchbox - C++ library for multi-threading programming
8 Summary(pl.UTF-8):      Lunchbox - biblioteka C++ do programowania wielowątkowego
9 Name:           Lunchbox
10 Version:        1.10.0
11 Release:        6
12 License:        LGPL v2.1
13 Group:          Libraries
14 Source0:        https://github.com/Eyescale/Lunchbox/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  3e01c3a2ddeeb7b3682e88092831d5a5
16 Source1:        https://github.com/Eyescale/CMake/archive/139ce7d/Eyescale-CMake-139ce7d.tar.gz
17 # Source1-md5:  4a6abcd9e0fc417528a8ca68a97e65eb
18 Patch0:         disable-broken-cmakefiles.patch
19 Patch1:         boost-1.57.0.patch
20 URL:            http://pogl.wordpress.com/category/lunchbox/
21 BuildRequires:  avahi-devel
22 BuildRequires:  boost-devel >= 1.41.0
23 BuildRequires:  cmake >= 2.8
24 %{?with_apidocs:BuildRequires:  doxygen}
25 BuildRequires:  gcc-c++ >= 6:4.2
26 BuildRequires:  hwloc-devel >= 1.3
27 BuildRequires:  leveldb-devel
28 BuildRequires:  libgomp-devel
29 BuildRequires:  libjpeg-turbo-devel >= 1.2.1
30 BuildRequires:  libstdc++-devel
31 %{?with_mpi:BuildRequires:      mpi-devel}
32 BuildRequires:  pkgconfig
33 %{?with_skv:BuildRequires:      skv-devel}
34 Requires:       hwloc-libs >= 1.3
35 Requires:       libjpeg-turbo >= 1.2.1
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Lunchbox is a C++ library for multi-threaded programming. Lunchbox was
40 formerly known as eq::base or co::base, the foundation for the
41 Equalizer parallel rendering framework and the Collage network
42 library. It is intended for all application developers creating
43 high-performance multi-threaded programs.
44
45 %description -l pl.UTF-8
46 Lunchbox to biblioteka C++ do programowania wielowątkowego. Wcześniej
47 była znana jako eq::base lub co::base - podstawa szkieletu do
48 renderowania wielowątkowego Equalizer lub biblioteki sieciowej
49 Collage. Biblioteka jest przeznaczona dla wszystkich programistów
50 tworzących wysoko wydajne, wielowątkowe aplikacje.
51
52 %package devel
53 Summary:        Header files for Lunchbox library
54 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Lunchbox
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       boost-devel >= 1.41.0
58 Requires:       libgomp-devel
59 Requires:       libstdc++-devel
60
61 %description devel
62 Header files for Lunchbox library.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe biblioteki Lunchbox.
66
67 %package apidocs
68 Summary:        Lunchbox API documentation
69 Summary(pl.UTF-8):      Dokumentacja API biblioteki Lunchbox
70 Group:          Documentation
71 %if "%{_rpmversion}" >= "5"
72 BuildArch:      noarch
73 %endif
74
75 %description apidocs
76 API documentation for Lunchbox library.
77
78 %description apidocs -l pl.UTF-8
79 Dokumentacja API biblioteki Lunchbox.
80
81 %prep
82 %setup -q -a1
83
84 %{__mv} CMake-* CMake/common
85 %{__rm} .gitexternals
86
87 %patch0 -p1
88 %patch1 -p1
89
90 %build
91 install -d build
92 cd build
93 %cmake .. \
94         -DBUILDYARD_DISABLED=ON \
95         %{!?with_mpi:-DCMAKE_DISABLE_FIND_PACKAGE_MPI=ON} \
96         %{!?with_skv:-DCMAKE_DISABLE_FIND_PACKAGE_skv=ON}
97 %{__make}
98
99 %if %{with apidocs}
100 doxygen doc/Doxyfile
101 %endif
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} -C build install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Lunchbox/{doc,tests}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc ACKNOWLEDGEMENTS.txt AUTHORS.txt CHANGES.txt LICENSE.txt README.md doc/RelNotes.md
120 %attr(755,root,root) %{_libdir}/libLunchbox.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libLunchbox.so.3
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libLunchbox.so
126 %{_includedir}/lunchbox
127 %{_pkgconfigdir}/Lunchbox.pc
128 %dir %{_datadir}/Lunchbox
129 %{_datadir}/Lunchbox/CMake
130
131 %if %{with apidocs}
132 %files apidocs
133 %defattr(644,root,root,755)
134 %doc build/doc/html/*
135 %endif
This page took 0.028901 seconds and 2 git commands to generate.