]> git.pld-linux.org Git - packages/Lunchbox.git/blob - Lunchbox.spec
boost rebuild
[packages/Lunchbox.git] / Lunchbox.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_with     mpi             # MPI support
5
6 Summary:        Lunchbox - C++ library for multi-threading programming
7 Summary(pl.UTF-8):      Lunchbox - biblioteka C++ do programowania wielowątkowego
8 Name:           Lunchbox
9 Version:        1.17.0
10 Release:        8
11 License:        LGPL v2.1
12 Group:          Libraries
13 #Source0Download: https://github.com/Eyescale/Lunchbox/releases
14 Source0:        https://github.com/Eyescale/Lunchbox/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  76bcd79003c9b9d58d5f772cfdd812c7
16 Patch0:         cxx.patch
17 Patch1:         nanosleep.patch
18 URL:            http://pogl.wordpress.com/category/lunchbox/
19 BuildRequires:  Eyescale-CMake >= 2018.02
20 BuildRequires:  Servus-devel >= 1.5.0
21 BuildRequires:  avahi-devel
22 BuildRequires:  boost-devel >= 1.41.0
23 BuildRequires:  cmake >= 3.1
24 %{?with_apidocs:BuildRequires:  doxygen}
25 BuildRequires:  hwloc-devel >= 1.3
26 BuildRequires:  hwloc-devel < 2
27 BuildRequires:  libstdc++-devel
28 %{?with_mpi:BuildRequires:      mpi-devel}
29 BuildRequires:  pkgconfig
30 BuildRequires:  rpm-build >= 4.6
31 BuildRequires:  rpmbuild(macros) >= 1.605
32 Requires:       Servus >= 1.5.0
33 Requires:       hwloc-libs >= 1.3
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Lunchbox is a C++ library for multi-threaded programming. Lunchbox was
38 formerly known as eq::base or co::base, the foundation for the
39 Equalizer parallel rendering framework and the Collage network
40 library. It is intended for all application developers creating
41 high-performance multi-threaded programs.
42
43 %description -l pl.UTF-8
44 Lunchbox to biblioteka C++ do programowania wielowątkowego. Wcześniej
45 była znana jako eq::base lub co::base - podstawa szkieletu do
46 renderowania wielowątkowego Equalizer lub biblioteki sieciowej
47 Collage. Biblioteka jest przeznaczona dla wszystkich programistów
48 tworzących wysoko wydajne, wielowątkowe aplikacje.
49
50 %package devel
51 Summary:        Header files for Lunchbox library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Lunchbox
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       Servus-devel >= 1.5.0
56 Requires:       boost-devel >= 1.41.0
57 Requires:       libstdc++-devel
58
59 %description devel
60 Header files for Lunchbox library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki Lunchbox.
64
65 %package apidocs
66 Summary:        Lunchbox API documentation
67 Summary(pl.UTF-8):      Dokumentacja API biblioteki Lunchbox
68 Group:          Documentation
69 BuildArch:      noarch
70
71 %description apidocs
72 API documentation for Lunchbox library.
73
74 %description apidocs -l pl.UTF-8
75 Dokumentacja API biblioteki Lunchbox.
76
77 %prep
78 %setup -q
79
80 rmdir CMake/common
81 ln -s %{_datadir}/Eyescale-CMake CMake/common
82
83 %patch0 -p1
84 %patch1 -p1
85
86 %build
87 install -d build
88 cd build
89 %cmake .. \
90         -DCOMMON_DISABLE_WERROR:BOOL=ON \
91         %{!?with_mpi:-DCMAKE_DISABLE_FIND_PACKAGE_MPI=ON}
92
93 %{__make}
94
95 %if %{with apidocs}
96 doxygen doc/Doxyfile
97 %endif
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} -C build install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Lunchbox/{doc,tests}
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc ACKNOWLEDGEMENTS.txt AUTHORS.txt CHANGES.txt LICENSE.txt README.md doc/Changelog.md
116 %attr(755,root,root) %{_libdir}/libLunchbox.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libLunchbox.so.10
118 %dir %{_datadir}/Lunchbox
119 %{_datadir}/Lunchbox/benchmarks
120
121 %files devel
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/libLunchbox.so
124 %{_includedir}/lunchbox
125 %{_datadir}/Lunchbox/CMake
126
127 %if %{with apidocs}
128 %files apidocs
129 %defattr(644,root,root,755)
130 %doc build/doc/html/*
131 %endif
This page took 0.118658 seconds and 3 git commands to generate.