]> git.pld-linux.org Git - packages/Glide_VG.git/blob - Glide_VG.spec
- cleanup
[packages/Glide_VG.git] / Glide_VG.spec
1 Summary:        Glide runtime for 3Dfx Voodoo Banshee and Voodoo3 boards
2 Name:           Glide_VG
3 Version:        2.46
4 Release:        4
5 Group:          Libraries
6 Copyright:      3DFX GLIDE Source Code General Public License
7 URL:            http://www.3dfx.com     
8 Source:         Glide2.46.tar.gz
9 Patch:          Glide_VG-asm.patch
10 Vendor:         3Dfx Interactive Inc.
11 Icon:           3dfx.gif
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 This library allows the user to use a 3dfx Interactive Voodoo Graphics
16 card under Linux.
17
18 %package -n Glide2x_SDK
19 Summary:        Development libraries for Glide 2.x
20 Version:        2.1
21 Group:          Development/Libraries
22
23 %description -n Glide2x_SDK
24 This package includes the headers files, documentation, and test files
25 necessary for developing applications that use the 3Dfx Interactive
26 Voodoo Graphics, Voodoo Rush, or Voodoo2 card.
27
28 %prep
29 %setup -q -c
30 %patch -p1
31 chmod +x swlibs/include/make/ostype
32
33 %build
34 make -f makefile.unix CNODEBUG="$RPM_OPT_FLAGS -fomit-frame-pointer \
35         -funroll-loops -fexpensive-optimizations -ffast-math"
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_includedir}/glide}
40 install -d $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/{tests,texus/{lib,cmd,examples}}
41
42 # Install the glibc 2.1 libraries normally
43 install -s sst1/lib/libglide2x.so $RPM_BUILD_ROOT%{_libdir}/libglide2x_VG.so
44 install -s swlibs/lib/libtexus.so $RPM_BUILD_ROOT%{_libdir}
45 ln -s libglide2x_VG.so $RPM_BUILD_ROOT%{_libdir}/libglide2x.so
46
47 # Install the executables
48 install -s swlibs/bin/texus $RPM_BUILD_ROOT%{_bindir}
49 install -s sst1/glide/tests/test00 $RPM_BUILD_ROOT%{_bindir}/test3Dfx
50
51 # Install the headers
52 install swlibs/include/3dfx.h $RPM_BUILD_ROOT%{_includedir}/glide
53 install sst1/include/glide.h $RPM_BUILD_ROOT%{_includedir}/glide
54 install sst1/include/glidesys.h $RPM_BUILD_ROOT%{_includedir}/glide
55 install sst1/include/glideutl.h $RPM_BUILD_ROOT%{_includedir}/glide
56 install sst1/include/sst1vid.h $RPM_BUILD_ROOT%{_includedir}/glide
57 install sst1/include/gump.h $RPM_BUILD_ROOT%{_includedir}/glide
58 install swlibs/include/linutil.h $RPM_BUILD_ROOT%{_includedir}/glide
59 install swlibs/include/texus.h $RPM_BUILD_ROOT%{_includedir}/glide
60
61 # Install the examples and their source
62 install sst1/glide/tests/makefile.distrib $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/tests/makefile
63 install sst1/glide/tests/*.3df $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/tests
64 install sst1/glide/tests/test??.c $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/tests
65 install sst1/glide/tests/tldata.inc $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/tests
66 install sst1/glide/tests/tlib.[ch] $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/tests
67
68 # Install the texture tools source
69 install swlibs/texus/makefile.distrib $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/texus/makefile
70 install swlibs/texus/lib/makefile.distrib $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/texus/lib/makefile
71 install swlibs/texus/cmd/makefile.distrib $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/texus/cmd/makefile
72 install swlibs/texus/examples/makefile.distrib $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/texus/examples/makefile
73 install swlibs/texus/lib/*.c $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/texus/lib
74 install swlibs/texus/lib/texusint.h $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/texus/lib
75 install swlibs/texus/cmd/*.c $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/texus/cmd
76 install swlibs/texus/examples/*.c $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/texus/examples
77
78 gzip -9nf glide_license.txt
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %doc glide_license.txt.gz
89 %attr(755,root,root) %{_bindir}/texus
90 %attr(755,root,root) %{_bindir}/test3Dfx
91 %attr(755,root,root) %{_libdir}/libglide2x.so
92 %attr(755,root,root) %{_libdir}/libglide2x_VG.so
93 %attr(755,root,root) %{_libdir}/libtexus.so
94
95 %files -n Glide2x_SDK
96 %defattr(644,root,root,755)
97 %doc docs/*.pdf
98 %{_prefix}/src/examples/glide
99 %{_includedir}/glide
This page took 0.085713 seconds and 3 git commands to generate.