]> git.pld-linux.org Git - packages/GLM.git/blob - GLM.spec
- initial revision
[packages/GLM.git] / GLM.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4 #
5 Summary:        OpenGL Mathematics (GLM)
6 Name:           GLM
7 Version:        0.9.4.4
8 Release:        1
9 License:        MIT
10 Group:          Applications
11 Source0:        http://downloads.sourceforge.net/ogl-math/glm-%{version}.7z
12 # Source0-md5:  1c5a626c025dff9664b08d8f39c7e11b
13 URL:            http://glm.g-truc.net/
14 BuildRequires:  cmake
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 OpenGL Mathematics (GLM) is a C++ mathematics library for graphics
19 software based on the OpenGL Shading Language (GLSL) specification.
20
21 GLM is a header only library, there is nothing to build,
22 just include it.
23
24 %prep
25 %setup -q -n glm-%{version}
26
27 %build
28 mkdir build
29 cd build
30 %cmake \
31         ../ \
32         -DGLM_TEST_ENABLE:BOOL=%{!?with_tests:OFF}%{?with_tests:ON}
33
34 %{?with_tests:%{__make}}
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT
39
40 cd build
41 %{__make} install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc readme.txt doc/glm.pdf
50 %attr(755,root,root) %{_includedir}/glm
This page took 0.068542 seconds and 3 git commands to generate.