]> git.pld-linux.org Git - packages/FlightGear.git/blob - FlightGear.spec
- quick and dirty repair of linux build with RTI enabled
[packages/FlightGear.git] / FlightGear.spec
1 # TODO:
2 # - Make FlightGear-extra-planes for subset of planes from
3 #   http://www.flightgear.org/Downloads/aircraft/index.shtml
4
5 Summary:        Free Flight Simulator
6 Summary(pl.UTF-8):      darmowy symulator lotu
7 Name:           FlightGear
8 Version:        3.2.0
9 Release:        2
10 License:        GPL
11 Group:          X11/Applications/Games
12 Source0:        ftp://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Source/flightgear-%{version}.tar.bz2
13 # Source0-md5:  0a16920cc22ea070f8bb345e76c55e05
14 Source1:        ftp://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Shared/%{name}-data-%{version}.tar.bz2
15 # Source1-md5:  24774fae7199bcbc5e23672f4a586884
16 #Source2:       ftp://ftp.flightgear.org/pub/fgfs/Everything-0.7/Base-Packages/fgfs-docs-0.7.7.tar.gz
17 ## Source2-md5: 31f35d3e63e522565e8990ead99e7507
18 Patch0:         flightgear-cmake.patch
19 Patch1:         OpenSceneGraph-3.3.2.patch
20 Patch2:         rtti-fix.patch
21 URL:            http://www.flightgear.org/
22 BuildRequires:  OpenAL-devel
23 BuildRequires:  OpenGL-devel
24 BuildRequires:  OpenSceneGraph-devel
25 BuildRequires:  SimGear-devel = %{version}
26 BuildRequires:  cmake
27 BuildRequires:  flite-devel
28 BuildRequires:  fltk-gl-devel
29 BuildRequires:  freeglut-devel
30 BuildRequires:  libgsm-devel
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  speex-devel
33 BuildRequires:  sqlite3-devel
34 BuildRequires:  plib-devel >= 1.8.5-3
35 BuildRequires:  zlib-devel
36 Requires:       %{name}-data = %{version}
37 Requires:       OpenGL
38 Requires:       OpenSceneGraph-plugins
39 Requires:       plib >= 1.8.4
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libGLcore.so.1
43
44 %description
45 The Flight Gear project is working to create a sophisticated flight
46 simulator framework for the development and pursuit of interesting
47 flight simulator ideas. We are developing a solid basic sim that can
48 be expanded and improved upon by anyone interested in contributing.
49
50 %description -l pl.UTF-8
51 Projekt Flight Gear to wyrafinowany symulator lotów pozwalający
52 rozpowszechniać idee tego typu symulacji.
53
54 %package data
55 Summary:        FlightGear base scenery and data files
56 License:        GPL v2+
57 Group:          Applications/Games
58 %if "%{_rpmversion}" >= "5"
59 BuildArch:      noarch
60 %endif
61
62 %description data
63 This package contains the base scenery for FlightGear and must be
64 installed
65
66 %prep
67 %setup -q -n flightgear-%{version} -a 1
68 %patch0 -p1
69 %patch1 -p1
70 %patch2 -p1
71
72 cat > runfgfs <<'EOF'
73 #!/bin/sh
74 exec %{_bindir}/fgfs --fg-root=%{_datadir}/games/%{name}/fgdata "$@"
75 EOF
76
77 %build
78 install -d build
79 cd build
80 %cmake .. \
81         -DSYSTEM_SQLITE:BOOL=ON
82
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT%{_datadir}/games/%{name}
88
89 %{__make} -C build install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 install -p runfgfs $RPM_BUILD_ROOT%{_bindir}
93 cp -a fgdata $RPM_BUILD_ROOT%{_datadir}/games/%{name}
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(644,root,root,755)
100 %doc AUTHORS NEWS docs-mini/*
101 %attr(755,root,root) %{_bindir}/*
102 %{_mandir}/*/*
103
104 %files data
105 %defattr(644,root,root,755)
106 %{_datadir}/games/%{name}
This page took 0.488708 seconds and 3 git commands to generate.