]> git.pld-linux.org Git - packages/FlightGear.git/blob - FlightGear.spec
- fixes for OpenSceneGraph 3.3.2 API changes
[packages/FlightGear.git] / FlightGear.spec
1 # TODO:
2 # - Make FlightGear-extra-planes for subset of planes from
3 #   http://www.flightgear.org/Downloads/aircraft/index.shtml
4
5 Summary:        Free Flight Simulator
6 Summary(pl.UTF-8):      darmowy symulator lotu
7 Name:           FlightGear
8 Version:        3.2.0
9 Release:        1
10 License:        GPL
11 Group:          X11/Applications/Games
12 Source0:        ftp://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Source/flightgear-%{version}.tar.bz2
13 # Source0-md5:  0a16920cc22ea070f8bb345e76c55e05
14 Source1:        ftp://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Shared/%{name}-data-%{version}.tar.bz2
15 # Source1-md5:  24774fae7199bcbc5e23672f4a586884
16 #Source2:       ftp://ftp.flightgear.org/pub/fgfs/Everything-0.7/Base-Packages/fgfs-docs-0.7.7.tar.gz
17 ## Source2-md5: 31f35d3e63e522565e8990ead99e7507
18 Patch0:         flightgear-cmake.patch
19 Patch1:         OpenSceneGraph-3.3.2.patch
20 URL:            http://www.flightgear.org/
21 BuildRequires:  OpenAL-devel
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  SimGear-devel = %{version}
24 BuildRequires:  cmake
25 BuildRequires:  fltk-gl-devel
26 BuildRequires:  freeglut-devel
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libxml-devel
29 BuildRequires:  plib-devel >= 1.8.5-3
30 BuildRequires:  zlib-devel
31 Requires:       %{name}-data = %{version}
32 Requires:       OpenGL
33 Requires:       OpenSceneGraph-plugins
34 Requires:       plib >= 1.8.4
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libGLcore.so.1
38
39 %description
40 The Flight Gear project is working to create a sophisticated flight
41 simulator framework for the development and pursuit of interesting
42 flight simulator ideas. We are developing a solid basic sim that can
43 be expanded and improved upon by anyone interested in contributing.
44
45 %description -l pl.UTF-8
46 Projekt Flight Gear to wyrafinowany symulator lotów pozwalający
47 rozpowszechniać idee tego typu symulacji.
48
49 %package data
50 Summary:        FlightGear base scenery and data files
51 License:        GPL v2+
52 Group:          Applications/Games
53 %if "%{_rpmversion}" >= "5"
54 BuildArch:      noarch
55 %endif
56
57 %description data
58 This package contains the base scenery for FlightGear and must be
59 installed
60
61 %prep
62 %setup -q -n flightgear-%{version} -a 1
63 %patch0 -p1
64 %patch1 -p1
65
66 cat > runfgfs <<'EOF'
67 #!/bin/sh
68 exec %{_bindir}/fgfs --fg-root=%{_datadir}/games/%{name}/fgdata "$@"
69 EOF
70
71 %build
72 install -d build
73 cd build
74 %cmake ..
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT%{_datadir}/games/%{name}
80 %{__make} -C build install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 install -p runfgfs $RPM_BUILD_ROOT%{_bindir}
84 cp -a fgdata $RPM_BUILD_ROOT%{_datadir}/games/%{name}
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %doc AUTHORS NEWS docs-mini/*
92 %attr(755,root,root) %{_bindir}/*
93 %{_mandir}/*/*
94
95 %files data
96 %defattr(644,root,root,755)
97 %{_datadir}/games/%{name}
This page took 0.074074 seconds and 3 git commands to generate.