]> git.pld-linux.org Git - packages/DirectFB.git/blob - DirectFB.spec
perl -pi -e "s/^gettextize --copy --force/\%%\{__gettextize\}/"
[packages/DirectFB.git] / DirectFB.spec
1 Summary:        DirectFB - Hardware graphics acceleration
2 Summary(pl):    DirectFB - Wspomaganie grafiki
3 Name:           DirectFB
4 Version:        0.9.10
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 Source0:        http://www.directfb.org/download/%{name}/%{name}-%{version}.tar.gz
9 Patch0:         %{name}-am.patch
10 URL:            http://www.directfb.org/
11 BuildRequires:  libpng-devel >= 1.2.0
12 BuildRequires:  zlib-devel >= 1.1.3
13 BuildRequires:  libjpeg-devel >= 6b
14 BuildRequires:  freetype-devel >= 2.0.2
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 DirectFB hardware graphics acceleration - libraries.
21
22 %description -l pl
23 Wspomaganie grafiki DirectFB - biblioteki.
24
25 %package devel
26 Summary:        DirectFB - development package
27 Summary(pl):    DirectFB - pliki nag³ówkowe
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}
30
31 %description devel
32 DirectFB header files.
33
34 %description -l pl devel
35 Pliki nag³ówkowe dla DirectFB.
36
37 %package doc
38 Summary:        DirectFB - documentation
39 Summary(pl):    DirectFB - dokumantacja
40 Group:          Development/Libraries
41
42 %description doc
43 DirectFB documentation and examples.
44
45 %description -l pl doc
46 Dokumentacja dla systemu DirectFB wraz z przyk³adami.
47
48 %prep
49 %setup  -q
50 %patch0 -p1
51
52 %build
53 rm -f missing
54 %{__libtoolize}
55 %{__gettextize}
56 aclocal
57 %{__autoconf}
58 automake -a -c 
59 if [ -f %{_pkgconfigdir}/libpng12.pc ] ; then
60         CPPFLAGS="`pkg-config libpng12 --cflags`"
61 fi
62 %configure CPPFLAGS="$CPPFLAGS" \
63         --disable-maintainer-mode \
64         --enable-shared \
65         --disable-fast-install \
66         --disable-debug \
67         --disable-avifile \
68         --enable-mmx 
69
70 %{__make} RPM_OPT_FLAGS="%{rpmcflags}"
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %{__make} DESTDIR=$RPM_BUILD_ROOT install
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %post devel -p /sbin/ldconfig
83 %postun devel -p /sbin/ldconfig
84
85 %files
86 %defattr(644,root,root,755)
87 %attr(755,root,root) %{_libdir}/lib*.so.*.*
88 %{_libdir}/directfb
89 %{_datadir}/directfb
90
91 %files devel
92 %defattr(644,root,root,755)
93 %attr(755,root,root) %{_bindir}/directfb-config
94 %{_includedir}/directfb.h
95 %{_includedir}/directfb-internal
96 %{_pkgconfigdir}/*
97 %{_libdir}/*.la
98 %{_libdir}/*.so
99
100 %files doc
101 %defattr(644,root,root,755)
102 %doc docs/html/*
This page took 0.05842 seconds and 3 git commands to generate.