]> git.pld-linux.org Git - packages/DirectFB.git/blob - DirectFB.spec
- fixed epoch issue after adding it in rev. 1.44; new-style bcond; release 2
[packages/DirectFB.git] / DirectFB.spec
1 #
2 # Conditional build:
3 %bcond_without  mpg     # don't build support for MPG/MPEG3
4 #
5 Summary:        DirectFB - Hardware graphics acceleration
6 Summary(pl):    DirectFB - Wspomaganie grafiki
7 Name:           DirectFB
8 Version:        0.9.20
9 Release:        2
10 Epoch:          1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://www.directfb.org/download/%{name}/%{name}-%{version}.tar.gz
14 # Source0-md5:  e42e8ae43f0ad873643f73cc0a9ae7d0
15 Source1:        http://www.directfb.org/download/DirectFB/DFBTutorials-0.5.0.tar.gz
16 # Source1-md5:  13e443a64bddd68835b574045d9025e9
17 Patch0:         %{name}-am.patch
18 Patch1:         %{name}-pmake.patch
19 # workaround for havily broken i2c 2.8.[01] <linux/i2c*.h> headers
20 # should be removed ASAP after fixing these headers!
21 Patch2:         %{name}-broken-i2c-workaround.patch
22 URL:            http://www.directfb.org/
23 BuildRequires:  SDL-devel
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  freetype-devel >= 2.0.2
27 BuildRequires:  libjpeg-devel >= 6b
28 %{?with_mpg:BuildRequires:      libmpeg3-devel}
29 BuildRequires:  libpng-devel >= 1.0
30 BuildRequires:  libtool
31 BuildRequires:  zlib-devel >= 1.1.3
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         dfbdir  %{_libdir}/directfb-%{version}
35
36 %description
37 DirectFB hardware graphics acceleration - libraries.
38
39 %description -l pl
40 Wspomaganie grafiki DirectFB - biblioteki.
41
42 %package devel
43 Summary:        DirectFB - development package
44 Summary(pl):    DirectFB - pliki nag³ówkowe
45 Group:          Development/Libraries
46 Requires:       %{name} = %{epoch}:%{version}
47
48 %description devel
49 DirectFB header files.
50
51 %description devel -l pl
52 Pliki nag³ówkowe dla DirectFB.
53
54 %package static
55 Summary:        DirectFB static libraries
56 Summary(pl):    Statyczne biblioteki DirectFB
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{epoch}:%{version}
59
60 %description static
61 DirectFB static libraries.
62
63 %description static -l pl
64 Statyczne biblioteki DirectFB.
65
66 %package doc
67 Summary:        DirectFB - documentation
68 Summary(pl):    DirectFB - dokumentacja
69 Group:          Development/Libraries
70
71 %description doc
72 DirectFB documentation and tutorials.
73
74 %description doc -l pl
75 Dokumentacja dla systemu DirectFB wraz z wprowadzeniem.
76
77 %package core-sdl
78 Summary:        SDL core system for DirectFB
79 Summary(pl):    System SDL dla DirectFB
80 Group:          Libraries
81 Requires:       %{name} = %{epoch}:%{version}
82
83 %description core-sdl
84 This package contains SDL core system module for DirectFB.
85
86 %description core-sdl -l pl
87 Ten pakiet zawiera modu³ systemu SDL dla DirectFB.
88
89 %package font-ft2
90 Summary:        FreeType2 font provider for DirectFB
91 Summary(pl):    DirectFB - wtyczka dostarczaj±ca fonty poprzez FreeType2
92 Group:          Libraries
93 Requires:       %{name} = %{epoch}:%{version}
94
95 %description font-ft2
96 This package contains FreeType2 font provider for DirectFB.
97
98 %description font-ft2 -l pl
99 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± fonty poprzez
100 bibliotekê FreeType2.
101
102 %package image-jpeg
103 Summary:        JPEG image provider for DirectFB
104 Summary(pl):    DirectFB - wtyczka dostarczaj±ca grafikê JPEG
105 Group:          Libraries
106 Requires:       %{name} = %{epoch}:%{version}
107
108 %description image-jpeg
109 This package contains JPEG image provider for DirectFB.
110
111 %description image-jpeg -l pl
112 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê JPEG.
113
114 %package image-png
115 Summary:        PNG image provider for DirectFB
116 Summary(pl):    DirectFB - wtyczka dostarczaj±ca grafikê PNG
117 Group:          Libraries
118 Requires:       %{name} = %{epoch}:%{version}
119
120 %description image-png
121 This package contains PNG image provider for DirectFB.
122
123 %description image-png -l pl
124 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê PNG.
125
126 %package video-libmpeg3
127 Summary:        MPEG video provider for DirectFB
128 Summary(pl):    DirectFB - wtyczka dostarczaj±ca obraz MPEG
129 Group:          Libraries
130 Requires:       %{name} = %{epoch}:%{version}
131
132 %description video-libmpeg3
133 This package contains MPEG (MPEG-1 and MPEG-2) video provider for
134 DirectFB. It uses libmpeg3 library.
135
136 %description video-libmpeg3 -l pl
137 Ten pakiet zawiera wtyczkê dla DirectFB dostarczajac± obraz MPEG
138 (MPEG-1 i MPEG-2) przy u¿yciu biblioteki libmpeg3.
139
140 %prep
141 %setup -q -a1
142 %patch0 -p1
143 %patch1 -p1
144 %patch2 -p1
145
146 %build
147 %{__libtoolize}
148 %{__aclocal}
149 %{__autoconf}
150 %{__automake}
151 CPPFLAGS="-I/usr/include/libmpeg3"
152 # MMX and SSE are detected at runtime, so it's safe to enable
153 %configure \
154         --disable-maintainer-mode \
155         --enable-shared \
156         --enable-static \
157         --enable-fast-install \
158         --disable-debug \
159         %{!?with_mpg:--disable-libmpeg3} \
160         --enable-sdl \
161 %ifarch i586 i686 athlon
162         --enable-mmx \
163 %endif
164 %ifarch i686 athlon
165         --enable-sse
166 %endif
167
168 %{__make}
169
170 %install
171 rm -rf $RPM_BUILD_ROOT
172 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
173
174 %{__make} install \
175         DESTDIR=$RPM_BUILD_ROOT
176
177 cp -rf DFBTutorials* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %post   -p /sbin/ldconfig
183 %postun -p /sbin/ldconfig
184
185 %files
186 %defattr(644,root,root,755)
187 # dbfdump and dfbg require multi-application core - useless now
188 %attr(755,root,root) %{_bindir}/dfbinfo
189 %attr(755,root,root) %{_libdir}/lib*.so.*.*
190 %dir %{dfbdir}
191 %dir %{dfbdir}/gfxdrivers
192 %attr(755,root,root) %{dfbdir}/gfxdrivers/*.so
193 %dir %{dfbdir}/inputdrivers
194 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_joystick.so
195 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_keyboard.so
196 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_lirc.so
197 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_ps2mouse.so
198 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_serialmouse.so
199 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_sonypi.so
200 %dir %{dfbdir}/interfaces
201 %dir %{dfbdir}/interfaces/IDirectFBFont
202 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_default.so
203 %dir %{dfbdir}/interfaces/IDirectFBImageProvider
204 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.so
205 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.so
206 %dir %{dfbdir}/interfaces/IDirectFBVideoProvider
207 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_v4l.so
208 %dir %{dfbdir}/systems
209 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_fbdev.so
210 %{_datadir}/directfb-%{version}
211 %{_mandir}/man5/*
212
213 %files devel
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_bindir}/directfb-config
216 %attr(755,root,root) %{_bindir}/directfb-csource
217 %attr(755,root,root) %{_libdir}/*.so
218 %{_libdir}/*.la
219 %{_includedir}/directfb
220 %{_includedir}/directfb-internal
221 %{_pkgconfigdir}/*
222 %{_mandir}/man1/directfb-csource.1*
223
224 %files static
225 %defattr(644,root,root,755)
226 %{_libdir}/lib*.a
227 %{dfbdir}/gfxdrivers/*.*a
228 %{dfbdir}/inputdrivers/*.*a
229 %{dfbdir}/interfaces/*/*.*a
230 %{dfbdir}/systems/*.*a
231
232 %files doc
233 %defattr(644,root,root,755)
234 %doc docs/html/*
235 %{_examplesdir}/%{name}-%{version}
236
237 %files core-sdl
238 %defattr(644,root,root,755)
239 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_sdlinput.so
240 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_sdl.so
241
242 %files font-ft2
243 %defattr(644,root,root,755)
244 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_ft2.so
245
246 %files image-jpeg
247 %defattr(644,root,root,755)
248 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.so
249
250 %files image-png
251 %defattr(644,root,root,755)
252 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.so
253
254 %if %{with mpg}
255 %files video-libmpeg3
256 %defattr(644,root,root,755)
257 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_libmpeg3.so
258 %endif
This page took 0.432625 seconds and 3 git commands to generate.