]> git.pld-linux.org Git - packages/Collage.git/blob - Collage.spec
noarch apidocs
[packages/Collage.git] / Collage.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 Summary:        Cross-platform C++ network library
6 Summary(pl.UTF-8):      Wieloplatformowa biblioteka sieciowa dla C++
7 Name:           Collage
8 Version:        1.1.2
9 Release:        5
10 License:        LGPL v2.1
11 Group:          Libraries
12 Source0:        https://github.com/Eyescale/Collage/archive/%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  89d37ca9f592da59ddfa57ac82eb83c3
14 Source1:        https://github.com/Eyescale/CMake/archive/92d0663/Eyescale-CMake-92d0663.tar.gz
15 # Source1-md5:  7abca85af7f36fec7e22d7f63d601cf8
16 URL:            http://libcollage.net/
17 BuildRequires:  Lunchbox-devel >= 1.10
18 BuildRequires:  boost-devel >= 1.41.0
19 BuildRequires:  cmake >= 2.8
20 %{?with_apidocs:BuildRequires:  doxygen}
21 BuildRequires:  libibverbs-devel
22 BuildRequires:  librdmacm-devel
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  pkgconfig
25 BuildRequires:  udt-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Collage is a cross-platform C++ library for building heterogenous,
30 distributed applications. Among other things, it is the cluster
31 backend for the Equalizer parallel rendering framework. Collage
32 provides an abstraction of different network connections, peer-to-peer
33 messaging, node discovery, synchronization and high-performance,
34 object-oriented, versioned data distribution. Collage is designed for
35 low-overhead multi-threaded execution which allows applications to
36 easily exploit multi-core architectures.
37
38 %description -l pl.UTF-8
39 Collage to wieloplatformowa biblioteka C++ do tworzenia
40 heterogenicznych, rozproszonych aplikacji. Jest to między innymi
41 backend klastrowy dla szkieletu równoległego renderowania Equalizer.
42 Zapewnia abstrakcję różnych połączeń sieciowych, przesyłania
43 komunikatów między węzłami, wykrywanie węzłów, synchronizację oraz
44 wydajne, zorientowane obiektowo i wersjonowane rozproszenie danych.
45 Collage został zaprojektowany pod kątem lekkiej wielowątkowości, co
46 pozwala aplikacjom łatwo wykorzystywać architektury wielordzeniowe.
47
48 %package devel
49 Summary:        Header files for Collage library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Collage
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53
54 %description devel
55 Header files for Collage library.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe biblioteki Collage.
59
60 %package apidocs
61 Summary:        Collage API documentation
62 Summary(pl.UTF-8):      Dokumentacja API biblioteki Collage
63 Group:          Documentation
64 %if "%{_rpmversion}" >= "5"
65 BuildArch:      noarch
66 %endif
67
68 %description apidocs
69 API documentation for Collage library.
70
71 %description apidocs -l pl.UTF-8
72 Dokumentacja API biblioteki Collage.
73
74 %prep
75 %setup -q -a1
76
77 %{__mv} CMake-* CMake/common
78 %{__rm} .gitexternals
79
80 %build
81 install -d build
82 cd build
83 %cmake .. \
84         -DBUILDYARD_DISABLED=ON
85 %{__make}
86
87 %if %{with apidocs}
88 doxygen doc/Doxyfile
89 %endif
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} -C build install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Collage/{doc,tests}
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %doc AUTHORS CHANGES.txt LICENSE.txt README.md doc/{README.IB,README.udt} build/doc/RelNotes.md
108 %attr(755,root,root) %{_bindir}/coNetperf
109 %attr(755,root,root) %{_bindir}/coNodeperf
110 %attr(755,root,root) %{_bindir}/coObjectperf
111 %attr(755,root,root) %{_libdir}/libCollage.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libCollage.so.2
113
114 %files devel
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/libCollage.so
117 %{_includedir}/co
118 %{_pkgconfigdir}/Collage.pc
119 %dir %{_datadir}/Collage
120 %{_datadir}/Collage/CMake
121
122 %if %{with apidocs}
123 %files apidocs
124 %defattr(644,root,root,755)
125 %doc build/doc/html/*
126 %endif
This page took 0.075147 seconds and 4 git commands to generate.